ApsaraDB RDS インスタンスのリストを照会します。
操作説明
対象エンジン
RDS MySQL
RDS PostgreSQL
RDS SQL Server
RDS MariaDB
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
rds:DescribeDBInstances |
get |
DBInstance
|
|
なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| ClientToken |
string |
任意 |
リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認する必要があります。トークンには ASCII 文字のみを使用でき、長さは 64 文字以下である必要があります。 |
ETnLKlblzczshOTUbOCz**** |
| proxyId |
string |
任意 |
非推奨のパラメーターです。このパラメーターを設定する必要はありません。 |
API |
| Engine |
string |
任意 |
データベースエンジン。有効な値:
デフォルトでは、すべてのデータベースエンジンのインスタンスが返されます。 |
MySQL |
| ZoneId |
string |
任意 |
ゾーンの ID。 |
cn-hangzhou-a |
| ResourceGroupId |
string |
任意 |
リソースグループの ID。 |
rg-acfmy**** |
| DBInstanceStatus |
string |
任意 |
インスタンスステータス。詳細については、「インスタンスステータス」をご参照ください。フォーマット: |
Running |
| Expired |
string |
任意 |
インスタンスの有効期限ステータス。有効な値: |
True |
| SearchKey |
string |
任意 |
インスタンス ID またはインスタンスの説明によるあいまい検索に使用されるキーワード。 |
rm-uf6w |
| DBInstanceId |
string |
任意 |
インスタンスの ID。 |
rm-uf6wjk5**** |
| DBInstanceType |
string |
任意 |
インスタンスタイプ。有効な値: |
Primary |
| RegionId |
string |
必須 |
リージョン ID。DescribeRegions を呼び出して利用可能なリージョンをクエリできます。 |
cn-hangzhou |
| PageSize |
integer |
任意 |
ページあたりのエントリ数。有効な値: 1 ~ 100。 |
30 |
| PageNumber |
integer |
任意 |
ページ番号。値は Integer データの型の最大値を超えない正の整数である必要があります。 |
1 |
| InstanceNetworkType |
string |
任意 |
インスタンスのネットワークタイプ。有効な値: |
Classic |
| VpcId |
string |
任意 |
VPC の ID。 |
vpc-uf6f7l4fg90**** |
| VSwitchId |
string |
任意 |
vSwitch の ID。 |
vsw-uf6adz52c2p**** |
| DBInstanceClass |
string |
任意 |
インスタンスタイプ。詳細については、「インスタンスタイプ」をご参照ください。フォーマット: |
rds.mys2.small |
| EngineVersion |
string |
任意 |
データベースエンジンのバージョン。 |
8.0 |
| PayType |
string |
任意 |
課金方法。有効な値: |
Postpaid |
| ConnectionMode |
string |
任意 |
インスタンスのアクセスモード。有効な値: |
Standard |
| Tags |
string |
任意 |
インスタンスにバインドされているタグ。各タグは TagKey と TagValue で構成されます。一度に最大 5 ペアのタグを指定できます。フォーマット: {"key1":"value1","key2":"value2"...}。指定されたタグのいずれかに一致する場合、インスタンス情報が返されます。 |
{"key1":"value1"} |
| DedicatedHostGroupId |
string |
任意 |
専用クラスターの ID。 |
dhg-7a9**** |
| DedicatedHostId |
string |
任意 |
専用クラスター内のホストの ID。 |
i-bp**** |
| InstanceLevel |
integer |
任意 |
インスタンスエディション (Category) 情報を返すかどうかを指定します。有効な値: フォーマット: |
0 |
| QueryAutoRenewal |
boolean |
任意 |
予約済みのパラメーターです。このパラメーターを設定する必要はありません。 |
test |
| ConnectionString |
string |
任意 |
インスタンスのエンドポイント。このパラメーターは、指定されたエンドポイントを使用するインスタンスをクエリするために使用されます。 |
rm-uf6wjk5****.mysql.rds.aliyuncs.com |
| NextToken |
string |
任意 |
ページネーショントークン。このパラメーターには、前回 DescribeDBInstances 操作を呼び出した際に返された NextToken の値を設定します。結果が複数ページにわたるスパンの場合、このトークンを使用して次のページを取得できます。 |
o7PORW5o2TJg**** |
| MaxResults |
integer |
任意 |
1 ページあたりのエントリ数。有効な値: 1~100。 デフォルト値: 30。 説明
このパラメーターを指定した場合、PageSize および PageNumber パラメーターは使用できません。 |
30 |
| Filter |
string |
任意 |
インスタンスフィルター条件とその値で構成される JSON 文字列。 |
{"babelfishEnabled":"true"} |
| Category |
string |
任意 |
インスタンスのエディション。有効な値: |
クラスター |
この操作では、返されるデータを表示するために以下の 2 つの方法がサポートされています。
方法 1: MaxResults パラメーターを設定してページあたりのレコード数を指定し、NextToken パラメーターを使用してページネーショントークンを設定して次のページを表示します。NextToken には、DescribeDBInstances 操作の前回の呼び出しで返された NextToken の値を設定します。
ページネーションクエリを実行するためにこの操作を初めて呼び出す場合は、MaxResults のみをセットします。操作はデータの最初のページと NextToken 値を返します。
メソッド 2: PageSize パラメーターを設定してページあたりのレコード数を指定し、PageNumber パラメーターを使用してページ間を移動します。
前述のメソッドのうち 1 つのみを使用できます。多数のレコードが返される場合、クエリパフォーマンスが向上するためメソッド 1 を推奨します。
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
レスポンスパラメーター。 |
||
| Items |
object |
||
| DBInstance |
array<object> |
インスタンスのリスト。 |
|
|
array<object> |
インスタンスの詳細。 |
||
| BpeEnabled |
string |
非推奨のパラメーター。 |
0 |
| BurstingEnabled |
boolean |
I/O バーストが有効かどうかを示します。有効な値: |
false |
| Category |
string |
インスタンスエディション。有効な値:
説明
このパラメーターは、InstanceLevel が 1 に設定されている場合にのみ返されます。 |
Basic |
| IsAnalyticReadOnlyIns |
boolean |
インスタが MySQL DuckDB ベースの分析用インスタンス であるかどうかを示します。有効な値:
|
false |
| ConnectionMode |
string |
インスタンスのアクセスモード。有効な値:
|
標準 |
| ConnectionString |
string |
インスタンスのエンドポイント。 |
rm-uf6wjk5****.mysql.rds.aliyuncs.com |
| CreateTime |
string |
作成時間。フォーマット: yyyy-MM-ddTHH:mm:ssZ (協定世界時 (UTC))。 |
2018-11-05T11:26:02Z |
| DBInstanceCPU |
string |
インスタンスの CPU 数。 |
2 |
| DBInstanceClass |
string |
インスタンスタイプ。詳細については、「インスタンスタイプ」を参照してください。 |
rds.mys2.small |
| DBInstanceDescription |
string |
インスタンスの説明。 |
testdb |
| DBInstanceId |
string |
インスタンスの ID。 |
rm-uf6wjk5**** |
| DBInstanceMemory |
integer |
ノードのメモリサイズ。単位: MB。 |
4096 |
| DBInstanceNetType |
string |
インスタンスのネットワーク接続タイプ。有効な値:
|
インターネット |
| DBInstanceStatus |
string |
インスタンスステータス。詳細については、「インスタンスステータス」を参照してください。 |
Running |
| DBInstanceStorageType |
string |
インスタンスのストレージタイプ。 |
ModuleList.4.ModuleCode |
| DBInstanceType |
string |
インスタンスタイプ。有効な値:
|
Primary |
| DedicatedHostGroupId |
string |
専用クラスターの ID。 |
dhg-7a9**** |
| DedicatedHostGroupName |
string |
専用クラスターの名前。 |
テストホストグループ |
| DedicatedHostIdForLog |
string |
ロガーノードが存在するホストの ID。 |
dh-bp**** |
| DedicatedHostIdForMaster |
string |
マスターノードが存在するホストの ID。 |
dh-bp**** |
| DedicatedHostIdForSlave |
string |
スレーブノードが存在するホストの ID。 |
dh-bp**** |
| DedicatedHostNameForLog |
string |
ロガーノードが存在するホストの名前。 |
testlog |
| DedicatedHostNameForMaster |
string |
マスターノードが存在するホストの名前。 |
testmaster |
| DedicatedHostNameForSlave |
string |
スレーブノードが存在するホストの名前。 |
testslave |
| DedicatedHostZoneIdForLog |
string |
ロガーノードが存在するホストのゾーン ID。 |
cn-hangzhou-b |
| DedicatedHostZoneIdForMaster |
string |
マスターノードが存在するホストのゾーン ID。 |
cn-hangzhou-c |
| DedicatedHostZoneIdForSlave |
string |
スレーブノードが存在するホストのゾーン ID。 |
cn-hangzhou-d |
| DeletionProtection |
boolean |
リリース保護特徴が有効かどうかを示します。有効な値: |
false |
| DestroyTime |
string |
破棄時間。フォーマット: yyyy-MM-ddTHH:mm:ssZ (協定世界時 (UTC))。 |
2018-11-05T11:26:02Z |
| Engine |
string |
データベースエンジンのタイプ。 |
MySQL |
| EngineVersion |
string |
データベースエンジンのバージョン。 |
5.7 |
| ExpireTime |
string |
有効期限。フォーマット: yyyy-MM-ddTHH:mm:ssZ (UTC)。 説明
従量課金インスタンスには有効期限がありません。 |
2019-02-27T16:00:00Z |
| GeneralGroupName |
string |
専用クラスター MySQL 汎用インスタンスが属するグループの名前。 |
TestGroup |
| GuardDBInstanceId |
string |
ディザスタリカバリインスタンスの ID。プライマリインスタンスにディザスタリカバリインスタンスがある場合、このパラメーターが返されます。 |
rm-uf64zsu**** |
| InstanceNetworkType |
string |
インスタンスのネットワークタイプ。有効な値: |
Classic |
| IoAccelerationEnabled |
string |
I/O アクセラレーションが有効かどうかを示します。有効な値: |
0 |
| LockMode |
string |
インスタンスのロックステータス。有効な値: |
Unlock |
| LockReason |
string |
インスタンスがロック済みである理由。 |
インスタンス_期限切れ |
| MasterInstanceId |
string |
プライマリインスタンスの ID。このパラメーターが返されない場合 (null)、そのインスタンスはプライマリインスタンスです。 |
rm-uf6wjk5**** |
| MutriORsignle |
boolean |
インスタンスがマルチゾーンデプロイメントでデプロイされているかどうかを示します。有効な値:
説明
マルチゾーンデプロイメントとは、名前に「MAZ」を含むゾーンを指します。例: |
true |
| PayType |
string |
インスタンスの課金方法。有効な値:
|
Postpaid |
| ReadOnlyDBInstanceIds |
object |
||
| ReadOnlyDBInstanceId |
array<object> |
プライマリインスタンスに関連付けられている読み取り専用インスタンス ID のリスト。 |
|
|
object |
読み取り専用インスタンスの詳細。 |
||
| DBInstanceId |
string |
読み取り専用インスタンスの ID。 |
rr-uf6wjk5**** |
| RegionId |
string |
リージョン ID。 |
cn-hangzhou |
| ResourceGroupId |
string |
リソースグループの ID。 |
rg-acfmy**** |
| SwitchWeight |
integer |
専用クラスターの MySQL 汎用インスタンスが高可用性の重み切り替えをサポートしているかどうかを示します。有効な値:
|
100 |
| TempDBInstanceId |
string |
一時インスタンスの ID。プライマリインスタンスに一時インスタンスがある場合、このパラメーターが返されます。 |
rm-uf64zsu**** |
| Tips |
string |
専用クラスター MySQL 汎用インスタンスの例外アラート情報。 |
normal |
| TipsLevel |
integer |
専用クラスター MySQL 汎用インスタンスの例外に対するアラートレベル。有効な値:
|
1 |
| VSwitchId |
string |
vSwitch の ID。 |
vsw-uf6adz52c2p**** |
| VpcCloudInstanceId |
string |
VPC インスタンスの ID。 |
rm-uf6wjk5**** |
| VpcId |
string |
VPC の ID。 |
vpc-uf6f7l4fg90**** |
| VpcName |
string |
VPC の名前。 |
test-huadong |
| ZoneId |
string |
ゾーンの ID。 |
cn-hangzhou-a |
| BlueGreenDeploymentName |
string |
予約済みのパラメーターです。このパラメーターを設定する必要はありません。 |
test |
| BlueInstanceName |
string |
予約済みのパラメーターです。このパラメーターを設定する必要はありません。 |
test |
| GreenInstanceName |
string |
予約済みのパラメーターです。このパラメーターを設定する必要はありません。 |
test |
| AutoRenewal |
boolean |
インスタンスの自動更新が有効かどうかを示します。有効な値:
説明
このパラメーターは、PayType が Prepaid (サブスクリプション) に設定されている場合にのみ返されます。 |
false |
| ColdDataEnabled |
boolean |
予約済みパラメーター。 |
false |
| IsAnalyticIns |
string |
||
| NextToken |
string |
ページネーショントークン。結果が複数のページに表示される場合、次のリクエストで NextToken パラメーターにこの値を渡すと、結果の次のページが表示されます。 |
o7PORW5o2TJg**** |
| PageNumber |
integer |
ページ番号。 説明
MaxResults または NextToken を指定した場合、このパラメーターは 1 のみを返し、無視できます。 |
1 |
| PageRecordCount |
integer |
現在のページのインスタンス数。 |
10 |
| RequestId |
string |
リクエスト ID。 |
1AD222E9-E606-4A42-BF6D-8A4442913CEF |
| TotalRecordCount |
integer |
レコードの総数。 MaxResults または NextToken を指定した場合、この値は現在のページのレコード数のみを示します。この値は無視できます。 |
100 |
例
成功レスポンス
JSONJSON
{
"Items": {
"DBInstance": [
{
"BpeEnabled": "0",
"BurstingEnabled": false,
"Category": "Basic",
"IsAnalyticReadOnlyIns": false,
"ConnectionMode": "標準",
"ConnectionString": "rm-uf6wjk5****.mysql.rds.aliyuncs.com",
"CreateTime": "2018-11-05T11:26:02Z",
"DBInstanceCPU": "2",
"DBInstanceClass": "rds.mys2.small",
"DBInstanceDescription": "testdb",
"DBInstanceId": "rm-uf6wjk5****",
"DBInstanceMemory": 4096,
"DBInstanceNetType": "インターネット",
"DBInstanceStatus": "Running",
"DBInstanceStorageType": "ModuleList.4.ModuleCode",
"DBInstanceType": "Primary",
"DedicatedHostGroupId": "dhg-7a9****",
"DedicatedHostGroupName": "テストホストグループ",
"DedicatedHostIdForLog": "dh-bp****",
"DedicatedHostIdForMaster": "dh-bp****",
"DedicatedHostIdForSlave": "dh-bp****",
"DedicatedHostNameForLog": "testlog",
"DedicatedHostNameForMaster": "testmaster",
"DedicatedHostNameForSlave": "testslave",
"DedicatedHostZoneIdForLog": "cn-hangzhou-b",
"DedicatedHostZoneIdForMaster": "cn-hangzhou-c",
"DedicatedHostZoneIdForSlave": "cn-hangzhou-d",
"DeletionProtection": false,
"DestroyTime": "2018-11-05T11:26:02Z",
"Engine": "MySQL",
"EngineVersion": "5.7",
"ExpireTime": "2019-02-27T16:00:00Z",
"GeneralGroupName": "TestGroup",
"GuardDBInstanceId": "rm-uf64zsu****",
"InstanceNetworkType": "Classic",
"IoAccelerationEnabled": "0",
"LockMode": "Unlock",
"LockReason": "インスタンス_期限切れ",
"MasterInstanceId": "rm-uf6wjk5****",
"MutriORsignle": true,
"PayType": "Postpaid",
"ReadOnlyDBInstanceIds": {
"ReadOnlyDBInstanceId": [
{
"DBInstanceId": "rr-uf6wjk5****"
}
]
},
"RegionId": "cn-hangzhou",
"ResourceGroupId": "rg-acfmy****",
"SwitchWeight": 100,
"TempDBInstanceId": "rm-uf64zsu****",
"Tips": "normal",
"TipsLevel": 1,
"VSwitchId": "vsw-uf6adz52c2p****",
"VpcCloudInstanceId": "rm-uf6wjk5****",
"VpcId": "vpc-uf6f7l4fg90****",
"VpcName": "test-huadong",
"ZoneId": "cn-hangzhou-a",
"BlueGreenDeploymentName": "test",
"BlueInstanceName": "test",
"GreenInstanceName": "test",
"AutoRenewal": false,
"ColdDataEnabled": false,
"IsAnalyticIns": ""
}
]
},
"NextToken": "o7PORW5o2TJg****",
"PageNumber": 1,
"PageRecordCount": 10,
"RequestId": "1AD222E9-E606-4A42-BF6D-8A4442913CEF",
"TotalRecordCount": 100
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | Invalid.NextToken | The parameter NextToken is invalid. | NextToken パラメーターが無効です。 |
| 400 | InvalidDBInstanceType.ValueNotSupport | The specified parameter DBInstanceType is not valid. | |
| 400 | InvalidParameter.OwnerAccount | The specified parameter OwnerAccount is not valid. | 操作が失敗しました。OwnerAccount パラメーターが無効です。パラメーター値を確認してください。 |
| 400 | TimeoutRetryLater | Timeout, Please retry later. | |
| 400 | InvalidExpired.Format | The instance expiration status parameter is incorrect. | インスタンスの有効期限ステータスパラメーターが無効です。 |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Alibaba Cloud アカウントが存在しないか、AccessKey が期限切れです。 |
| 400 | Abs.ImageNotFound | The specified Image is disabled or is deleted. | 指定されたイメージが期限切れであるか、削除されています。 |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | パッケージインスタンスに対して個別の操作を行うことはできません。 |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | 料金プランの価格結果が見つかりませんでした。 |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | 実名認証が完了していないため、購入資格がありません。料金・コスト管理にログインして実名認証を完了してください。 |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | アカウントの利用可能額が 0 未満です。購入を試みる前にアカウントをチャージしてください。 |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | 商品サービスへの呼び出しに失敗しました。 |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Alibaba Cloud は現在のリージョンの最適化および調整を予定しています。このリージョンのクラウドサービスは終了されます。業務継続性とスムーズなデータ移行を確保するため、現時点では新規購入注文を行うことができません。ご理解とご支援のほどよろしくお願いいたします。 |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | 購入したモジュールが無効です。有効なモジュールを購入してください。 |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | リージョンが廃止されました。 |
| 400 | Price.CommoditySys | Commodity system call exception. | 商品システムの呼び出し時に例外が発生しました。 |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | 選択したサブスクリプション期間が無効です。有効な期間を選択してください。 |
| 400 | pay.noCreditCard | Account not bound to credit card. | 利用可能なクレジットカードがありません。 |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | 選択したサービスに未払いの注文があります。新しい注文を行う前に、既存の注文の支払いを完了するかキャンセルしてください。 |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | アカウントに支払方法が設定されていません。支払方法を追加してください。 |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | 基本情報が不完全です。この操作を実行する前に、基本情報のフォームを完了させてください。フォーマットを確認してください。 |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | アカウントで例外が発生しました。詳細についてはカスタマーサービスにお問い合わせください。 |
| 400 | Api.NotSupport | Specified api is not supported. | 現在の API オペレーションはサポートされていません。 |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | 注文ブロックタグが存在します。この問題を解決するには、販売代理店にお問い合わせください。 |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | 指定された DBInstanceId が存在しません。 |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | 現在のインスタンスタイプは、指定されたストレージタイプをサポートしていません。 |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | 入力パラメーターが無効です。 |
| 400 | KmsApiError | User secret key invalid. | ユーザーキーが無効です。 |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL コマンドの実行に失敗したか、または時間切れになりました。 |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | 現在のインスタンスの DPI エンジンバージョンは、コールドデータアーカイブをサポートしていません。 |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | 現在のカーネルバージョンは、コールドデータアーカイブをサポートしていません。 |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | 現在のインスタンスの仕様では、この操作はサポートされていません。 |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | エンドポイント名が重複しています。接続文字列を再設定してください。 |
| 400 | RequiredParam.NotFound | Required input param is not found. | 必須パラメーターが不足しています。 |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | パラメーターが正しくありません。パラメーターを確認してください。 |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | 現在のバックアップポリシーではこの操作はサポートされていません。 |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | インスタンスステータスはこの操作をサポートしていません。 |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | インスタンスリリース後のアーカイブバックアップデータの保持ポリシーが無効です。 |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | インスタンスのデータベースエンジンタイプはこの操作をサポートしていません。 |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | この操作は、VPC ネットワークタイプのインスタンスではサポートされていません。 |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | 現在のデータベースインスタンスのイメージが既に存在します。読み取りを確認してください。 |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | このインスタンスタイプは購入できなくなりました。 |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | 指定されたデータベースがバックアップセットに存在しません。 |
| 400 | OrdTCommodityQueryError | Failed to query for product. | プロダクトのクエリに失敗しました。 |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | インスタンスはリリースされています。注文を行う前にインスタンスを確認してください。 |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | 指定されたリージョンが無効です。 |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | サービスへのリクエストが失敗しました。後でもう一度お試しください。 |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | サービスリクエストに失敗しました。後でもう一度お試しいただくか、サポートにお問い合わせください。 |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | RDS API サービスの障害により、リクエストの処理が失敗しました。 |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | 現在のインスタンスに未払いの注文があります。注文の支払いを完了してから再試行してください。 |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | スケールダウンのターゲット容量を現在のストレージ使用量より小さくすることはできません。 |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | SSD ディスクはこの操作をサポートしていません。ESSD にアップグレードしてください。 |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | ユーザー権限ではこの操作はサポートされていません。 |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | 指定された VSwitchId のフォーマットが正しくないか、または空です。 |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | 現在のマイナーバージョンでは、この操作はサポートされていません。 |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | 利用可能な在庫リージョンがありません。 |
| 403 | NotInFlowController | Sorry,no permission. | この特徴は利用できません。法人クラウドユーザーではないため、権限がありません。 |
| 403 | InvalidKmsKey | Kms key is disabled. | KMS キーが無効化されています。 |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | 現在のデータベースインスタンスレベルは、この操作をサポートしていません。 |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | 現在のインスタンスは Key Management Service へのアクセスを許可されていません。 |
| 404 | Request.NotFound | The requested resource is not available. | リクエストされたリソースは利用できません。 |
| 404 | HostInfo.NotFound | The specified host info is not found. | 指定されたホスト情報が存在しません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。