このトピックでは、File Storage NAS のファイルシステムとマウントポイントの作成と削除に関するよくある質問にお答えします。
ファイルシステムの作成と制限
-
各アカウントは、単一リージョンで最大 20 個の汎用型 NAS ファイルシステムと 200 個のエクストリーム NAS ファイルシステムを作成できます。
-
単一ファイルシステムの最大容量:容量型汎用 NAS は 10 PiB、パフォーマンス型汎用 NAS は 1 PiB、アドバンスト型汎用 NAS は 1 PiB、エクストリーム NAS は 256 TiB です。
-
単一ファイルシステムの最大ファイル数:汎用 NAS は 10 億、エクストリーム NAS は 5 億です。
詳細については、「制限事項」をご参照ください。
「在庫が不足しています」エラー
このエラーは、選択したアベイラビリティゾーンでリソースが利用できないことを示します。別のアベイラビリティゾーンでファイルシステムを作成してみてください。
マウントポイント
マウントポイントは、ECS インスタンス、E-HPC、コンテナサービスなどのコンピュートノードがファイルシステムに接続するためのネットワークタイプと権限を指定するアクセスポイントです。複数のノードが同じマウントポイントを使用してファイルシステムにアクセスできます。
マウントされたコンピュートノードのカウント
ファイルシステムが ECS インスタンスにマウントされている場合、各 ECS インスタンスは 1 つのマウントされたコンピュートノードとしてカウントされます。ファイルシステムがコンテナにマウントされている場合、各コンテナは 1 つのマウントされたコンピュートノードとしてカウントされます。
マウントポイントのネットワークタイプの変更
いいえ。マウントポイント作成後にそのネットワークタイプを変更することはできません。ネットワークタイプを切り替えるには、目的のネットワークタイプのマウントポイントを新規作成し、それを使用してファイルシステムを再マウントしてください。
-
ファイルシステムに 2 つのマウントポイントがあり、両方がクラシックネットワークを使用している場合、新しい VPC タイプのマウントポイントを追加する前に、一方のマウントポイントを削除する必要があります。サービスの中断を最小限に抑えるために、この変更はオフピーク時間に行ってください。
-
切り替えを行う前に、NAS ファイルシステムをマウントしている ECS インスタンスがクラシックネットワークから VPC に移行されていることを確認してください。ECS インスタンスのネットワークタイプを切り替える方法の詳細については、「ECS インスタンスをクラシックネットワークから VPC に移行する」をご参照ください。
たとえば、クラシックネットワークタイプのマウントポイントを使用してマウントされている容量型汎用 NAS ファイルシステムがあるとします。マウントポイントを VPC タイプに切り替えるには、次の手順を実行します。
-
新しい VPC タイプのマウントポイントを作成します。詳細については、「マウントポイントの追加」をご参照ください。
-
クラシックネットワークタイプのマウントポイントを使用しているファイルシステムのマウントを解除します。詳細については、「ファイルシステムのマウント解除」をご参照ください。
NAS コンソールにログインします。ファイルシステムの詳細ページで、マウント使用 タブに移動します。マウントポイントの [操作] 列で、
> クライアント一覧 を選択します。クライアント一覧 が空であることを確認します。 -
VPC タイプのマウントポイントを使用して、元の宛先パスにファイルシステムを再マウントします。詳細については、「ファイルシステムのマウント」をご参照ください。
-
元のクラシックネットワークマウントポイントの 操作 列で、
> 無効 を選択し、操作を確定します。 -
サービスに影響がないことを確認した後、
> 削除 を選択し、操作を確定します。
NAS ファイルシステムの VPC の切り替え
汎用 NAS ファイルシステムは最大 2 つのマウントポイントをサポートします。エクストリーム NAS ファイルシステムは 1 つのマウントポイントのみをサポートし、それは VPC タイプのマウントポイントでなければなりません。
VPC の切り替えをサポートしているのは汎用 NAS ファイルシステムのみです。エクストリーム NAS ファイルシステムはサポートしていません。汎用 NAS ファイルシステムの VPC を切り替えるには、次のいずれかの操作を実行します。
-
ファイルシステムにマウントポイントが 1 つしかない場合は、宛先 VPC に別のマウントポイントを追加し、新しいマウントポイントを使用してファイルシステムにアクセスできます。
-
既存のマウントポイントを削除してから、宛先 VPC に新しいマウントポイントを追加する。
汎用 NAS ファイルシステムは最大 2 つのマウントポイントをサポートします。上限に達している場合は、宛先 VPC に新しいマウントポイントを追加する前に、まず古いマウントポイントを削除する必要があります。
-
古い VPC からファイルシステムのマウントを解除します。詳細については、「NAS コンソールからマウントディレクトリのマウントを解除する」または「コマンドを実行してマウントディレクトリのマウントを解除する」をご参照ください。
-
古いマウントポイントを削除します。詳細については、「マウントポイントの削除」をご参照ください。
-
宛先 VPC にマウントポイントを追加します。詳細については、「マウントポイントの追加」をご参照ください。
-
新しいマウントポイントを使用してファイルシステムをマウントします。詳細については、「マウントシナリオ」をご参照ください。
-
Cloud Shell によって作成されたマウントポイントの削除
Cloud Shell を使用して NAS リソースを管理すると、ファイルシステムのマウントポイントリストにマウントポイントが自動的に作成されます。
Cloud Shell によって作成されたマウントポイントを削除するには、次のいずれかの方法を使用します。
-
NAS コンソールからマウントポイントを削除する
-
NAS コンソールにログインします。
左側のナビゲーションウィンドウで、 を選択します。
-
上部のナビゲーションバーで、ファイルシステムが存在するリソースグループとリージョンを選択します。
-
ファイルシステムリスト ページで、目的のファイルシステムを探し、[操作] 列で を選択します。
-
削除ファイルシステム ダイアログボックスで、Cloud Shell によって作成されたマウントポイントを見つけ、[操作] 列の [削除] をクリックします。
アイコンにカーソルを合わせると、そのマウントポイントが削除したいものであるかを確認できます。 -
[マウントポイントの削除] ダイアログボックスで、情報を確認し、[OK] をクリックします。
-
[キャンセル] をクリックして、[ファイルシステムの削除] ダイアログボックスを閉じます。
-
-
Cloud Shell からマウントポイントを削除する
-
Cloud Shell にログインします。
-
上部のメニューバーで、 を選択します。
-
[ファイルストレージのアンマウント] ダイアログボックスで、アンマウントするファイルシステムの ID を確認します。
-
マウントポイントが現在の RAM ユーザーによって作成された場合は、[現在のユーザー] を選択し、[マウント解除] をクリックします。
-
マウントポイントが別の RAM ユーザーによって作成された場合は、Alibaba Cloud アカウントでログインし、[RAM ユーザー] を選択してから、[マウント解除] をクリックします。
-
-
Cloud Backup によって作成されたマウントポイントの削除
Cloud Backup を使用して汎用 NAS ファイルシステムのリソースをバックアップすると、Cloud Backup はファイルシステム内にマウントポイントを自動的に作成します。
Cloud Backup によって作成されたマウントポイントを削除するには、次のいずれかの方法を使用します。
バックアップに使用されるマウントポイントを削除すると、その後のバックアップジョブは失敗します。
-
NAS ファイルシステムからマウントポイントを削除する
-
NAS コンソールにログインします。
左側のナビゲーションウィンドウで、 を選択します。
-
上部のナビゲーションバーで、ファイルシステムが存在するリソースグループとリージョンを選択します。
-
ファイルシステムリスト ページで、目的のファイルシステムを見つけ、[操作] 列で を選択します。
-
削除ファイルシステム ダイアログボックスで、Cloud Backup によって作成されたマウントポイントを見つけ、[操作] 列の [削除] をクリックします。
アイコンにカーソルを合わせると、そのマウントポイントが削除したいものであるかを確認できます。 -
[マウントポイントの削除] ダイアログボックスで、情報を確認し、[OK] をクリックします。
-
[キャンセル] をクリックして、[ファイルシステムの削除] ダイアログボックスを閉じます。
-
-
ファイルバックアップページからマウントポイントを削除する
-
NAS コンソールにログインします。
-
左側のナビゲーションウィンドウで、 を選択します。
-
上部のナビゲーションバーで、ファイルシステムが存在するリソースグループとリージョンを選択します。
-
ファイルのバックアップ ページで、[マウントの管理] をクリックします。
-
[マウントの管理] パネルで、対象のファイルシステムを見つけ、[マウントポイントの削除] をクリックします。
-
ダイアログボックスの画面の指示に従い、[確認] をクリックしてマウントポイントを削除します。
-
PAI によって作成されたマウントポイントの削除
PAI がデータ処理とモデリングのために NAS ファイルシステムをデータセットとして使用すると、ファイルシステム内にマウントポイントが自動的に作成されます。
PAI によって作成されたマウントポイントを削除するには、次の手順を実行します。
-
NAS コンソールにログインします。
左側のナビゲーションウィンドウで、 を選択します。
-
上部のナビゲーションバーで、ファイルシステムが存在するリソースグループとリージョンを選択します。
-
ファイルシステムリスト ページで、目的のファイルシステムを見つけ、[操作] 列で を選択します。
-
削除ファイルシステム ダイアログボックスで、PAI によって作成されたマウントポイントを見つけ、[操作] 列の [削除] をクリックします。
アイコンにカーソルを合わせると、そのマウントポイントが削除したいものであるかを確認できます。 -
[マウントポイントの削除] ダイアログボックスで、情報を確認し、[OK] をクリックします。
-
[キャンセル] をクリックして、[ファイルシステムの削除] ダイアログボックスを閉じます。
マウント済みクライアントの表示
この機能は汎用 NAS ファイルシステムのみでサポートされています。
-
NAS コンソールにログインします。
左側のナビゲーションウィンドウで、 を選択します。
-
上部のナビゲーションバーで、ファイルシステムが存在するリソースグループとリージョンを選択します。
-
ファイルシステムリスト ページで、対象のファイルシステムの ID をクリックし、マウント使用 タブをクリックします。
-
マウントポイント リストで、目的のマウントポイントを見つけ、[アクション] 列で を選択します。
クライアント一覧 ダイアログボックスで、マウントされているクライアントの IP アドレスを表示します。
説明このリストには、過去 1 分以内に NAS ファイルシステムでアクティブだったクライアントのみが表示されます。マウントされているがアイドル状態のクライアントは、このリストに表示されない場合があります。
ファイルシステムの削除と権限グループ
いいえ。ファイルシステムを削除しても、関連付けられた権限グループとそのルールは削除されません。ただし、そのすべてのマウントポイントは削除されます。権限グループを削除する方法については、「権限グループの管理」をご参照ください。
ファイルシステムが削除されると、そのデータを回復することはできません。操作にはご注意ください。
誤って削除したファイルの回復
いいえ。
偶発的なデータ損失を防ぐために、スナップショット、ゴミ箱、Cloud Backup などの機能を有効にしてください。詳細については、「スナップショット」、「汎用 NAS ファイルシステムのバックアップ」、および「ゴミ箱」をご参照ください。
マウント後のファイル削除ができない
これは、権限グループの権限が不十分であるか、サポートされていないアカウントが原因である可能性があります。権限グループが読み取りおよび書き込みアクセスを許可していること、および管理者 (Windows の場合) または root ユーザー (Linux の場合) としてログインしていることを確認してください。
クラシックネットワークのマウントポイントが作成できない
2022 年 11 月 21 日以降、汎用 NAS ファイルシステム用のクラシックネットワークタイプのマウントポイントは作成できなくなりました。ただし、既存のクラシックネットワークマウントポイントは、引き続きファイルシステムのマウントとアクセスに使用できます。
ファイルシステムが削除できない
ファイルシステムを削除するために必要な権限がない可能性があります。
ファイルシステムを削除するには、RAM ユーザーにカスタムポリシーが必要です。まず、RAM ユーザーにすべてのファイルシステムの表示権限を付与します。次に、ユーザーが管理したい特定のファイルシステムに対して、削除や変更などの操作権限を付与します。詳細については、「RAM ユーザーに権限を付与する手順」および「例 1:RAM ユーザーにファイルシステムの権限を付与する」をご参照ください。
「ENIRamRole.NotAuth」エラー
-
原因: Extreme NAS と CPFS デフォルトサービスの許可 (AliyunNASManageENIRole) が付与されていません。
エクストリーム NAS ファイルシステムを使用する場合、File Storage NAS は VPC や ECS などの他のサービスのリソースにアクセスする必要があります。これを行うために、デフォルトで AliyunNASManageENIRole ロールを使用します。
-
解決策:
-
NAS コンソールにログインします。
-
概要 ページで、共通玄関 セクションの 承認管理 をクリックします。
-
Extreme NAS と CPFS デフォルトサービスの許可 カードで、[権限の付与] に移動 をクリックします。
-
[クラウドリソースアクセス承認] ページで、ロール情報を確認し、[承認に同意] をクリックします。
-
ECS インスタンスリリース後の NAS ファイルシステムの永続化
はい。マウントされた NAS ファイルシステムを持つ ECS インスタンスがリリースされても、ファイルシステムとそのデータは影響を受けません。
CSI プラグインの作成がエラー The specified AZone inventory is insufficient で失敗する
症状
CSI プラグインを使用したファイルシステムの作成が失敗し、次のエラーメッセージが返されます。
ErrorCode: InvalidAZone.NotFound
Recommend:
RequestId: xxxxx
Message: The specified AZone inventory is insufficient.
原因
パラメーターで無効なアベイラビリティゾーンが指定されました。
解決策
別のアベイラビリティゾーンを選択してください。OpenAPI Developer Portal で DescribeZones 操作を呼び出して、対象リージョンのすべてのアベイラビリティゾーンと、それらがサポートするファイルシステムタイプのリストを取得できます。
または、NAS コンソールで直接ファイルシステムを作成することもできます。詳細については、「ファイルシステムの作成」をご参照ください。
大量のデータを迅速に削除する
ネストされていないサブディレクトリを並行して削除するには、複数のターミナルセッションを開き、NAS マウントディレクトリ (例:/mnt) に移動し、ネストされていない各サブディレクトリで rm -rf コマンドを実行します。
ファイルシステム削除後にコマンドがハングする
/etc/fstab ファイル内の NAS 構成をコメントアウトしてから、サーバーを再起動します。
この問題の再発を防ぐには、コンソールでファイルシステムを削除する前に、必ずオペレーティングシステムでファイルシステムのマウントを解除してください。自動マウントを構成している場合は、対応する構成も削除または無効にする必要があります。詳細については、「NAS コンソールからマウントディレクトリのマウントを解除する」、「コマンドを実行してマウントディレクトリのマウントを解除する」、および「ファイルシステムの削除」をご参照ください。
サーバーの再起動は、許可されたメンテナンスウィンドウ中にのみ行ってください。
NAS リソースのリリース後のデータ保持
いいえ。NAS リソースを正常にリリースすると、データは直ちに削除されます。Alibaba Cloud は削除されたデータを保持しません。詳細については、「File Storage NAS サービスレベル契約」をご参照ください。
支払い遅延によりサービスが一時停止された場合、汎用 NAS ファイルシステムのデータは 15 日間保持され、エクストリーム NAS ファイルシステムのデータも 15 日間保持されます。この保持期間内に未払い額を支払わない場合、NAS サービスを自発的に放棄したものとみなされます。その後、Alibaba Cloud はサービス契約を終了し、サービスの提供を停止し、保存されているすべてのデータを削除します。データは削除されると回復できません。詳細については、「料金滞納について」をご参照ください。
エクストリーム NAS ファイルシステムのスループットの表示
-
NAS コンソールにログインします。
左側のナビゲーションウィンドウで、 を選択します。
-
上部のナビゲーションバーで、リージョンを選択します。
-
ファイルシステムリスト ページで、対象のファイルシステムの ID をクリックします。
-
基本情報 タブで、ファイルシステムの 最大容量 と 帯域幅 に基づいてスループットを確認します。さまざまなエクストリーム NAS 仕様の帯域幅の詳細については、「パフォーマンスメトリック」をご参照ください。