すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB for MongoDB:スタンドアロン MongoDB インスタンスを任意のアーキテクチャに移行

最終更新日:Jul 18, 2026

Data Transmission Service (DTS) を使用して、スタンドアロン MongoDB データベースから任意のアーキテクチャの MongoDB インスタンスへデータを完全に移行します。

サポートされるソースおよびターゲットデータベース

ソースデータベース

ターゲットデータベース

ApsaraDB for MongoDB

ApsaraDB for MongoDB

ECS インスタンス上の自己管理データベース

ECS インスタンス上の自己管理データベース

Express Connect、VPN Gateway、または Smart Access Gateway 経由で接続された自己管理データベース

Express Connect、VPN Gateway、または Smart Access Gateway 経由で接続された自己管理データベース

パブリック IP アドレスを持つ自己管理データベース

パブリック IP アドレスを持つ自己管理データベース

この例では、ApsaraDB for MongoDB のスタンドアロンインスタンスから、任意のアーキテクチャの ApsaraDB for MongoDB インスタンスへの移行方法を説明します。

前提条件

  • ソースとなる ApsaraDB for MongoDB スタンドアロンインスタンスおよびターゲットとなる ApsaraDB for MongoDB インスタンスを作成済みである必要があります。詳細については、「スタンドアロンインスタンスの作成」、「レプリカセットインスタンスの作成」、および「シャードクラスターインスタンスの作成」をご参照ください。

    説明

    サポートされているバージョンについては、「移行ソリューション」をご参照ください。

  • ターゲットとなる ApsaraDB for MongoDB インスタンスのストレージ容量は、ソースとなる ApsaraDB for MongoDB インスタンスが使用している容量よりも少なくとも 10 % 大きくする必要があります。

  • ターゲットとなる ApsaraDB for MongoDB インスタンスがシャードクラスター構成の場合、ビジネス要件に基づいて、ターゲットの ApsaraDB for MongoDB インスタンスでシャーディング対象のデータベースおよびコレクションを作成し、シャーディングを設定してバランサーを有効化し、事前シャーディングを実施してください。詳細については、「シャードパフォーマンスを最大化するためのシャーディング設定」および「MongoDB シャードクラスターでデータ分散が不均等になった場合の対処方法」をご参照ください。

    説明

    シャーディングを設定することで、すべてのデータが単一のシャードに移行され、クラスター性能が低下する問題を回避できます。バランサーを有効化し、事前シャーディングを実施することで、データスキューを防止できます。

制限事項

種別

説明

ソースデータベースの制限事項

  • 帯域幅要件:ソースデータベースサーバーには十分な送信帯域幅が必要です。そうでない場合、データ移行速度に影響します。

  • 移行対象のコレクションにはプライマリキーまたは一意制約が存在し、制約フィールドには一意の値が含まれている必要があります。そうでない場合、ターゲットデータベースに重複データが生成される可能性があります。

  • データ内のフィールド名に「.」(ドット) 文字を含めることはできません。含まれていると、データの不整合が発生する可能性があります。

  • コレクション単位でデータを移行し、コレクション名のマッピングなど編集を行う必要がある場合、1 つの移行タスクで移行できるコレクション数は最大 1,000 個です。この上限を超えると、タスク登録時にエラーが報告されます。その場合は、コレクションを複数のバッチに分割して各バッチごとに個別のタスクを設定するか、データベース全体を移行するタスクを設定してください。

  • ソースデータベース内の単一ドキュメントのサイズは 16 MB を超えてはなりません。超えると、移行タスクが失敗します。

  • ソースデータベースに対する操作に関する制限事項:

    • スキーマ移行および完全なデータ移行のフェーズ中は、データベースやコレクションに対してスキーマ変更(配列内のデータ更新を含む)を行わないでください。このような変更を行うと、移行が失敗したり、ソースおよびターゲットデータベース間でデータの不整合が発生したりする可能性があります。

    • この移行シナリオでは増分データ移行はサポートされていません。データ整合性を確保するため、完全なデータ移行中はソース MongoDB データベースに新しいデータを書き込まないでください。

  • 移行対象のコレクションに Time-to-Live (TTL) インデックスが含まれている場合、データの不整合が発生するか、インスタンスの遅延が増加する可能性があります。

その他の制限事項

  • ターゲットインスタンスがシャードクラスター構成の場合:

    • 移行性能に影響を与えるため、孤立ドキュメントをクリアする必要があります。_id の競合が移行中に検出された場合、データの不整合やタスクの失敗が発生する可能性があります。

    • タスク開始前に、ターゲットの各シャードコレクションに対応するソースデータにシャードキーを追加する必要があります。ソースデータにシャードキーを追加できない場合は、「シャードキーのない MongoDB インスタンスから MongoDB シャードクラスターインスタンスへのデータ移行」をご参照ください。

    • タスク開始後、INSERT コマンドには必ずシャードキーを含める必要があります。UPDATE コマンドではシャードキーを変更してはいけません。

  • ターゲットインスタンスがレプリカセット構成の場合:

    • アクセス方法 が Express Connect、VPN Gateway、または Smart Access Gateway、パブリック IP アドレス、または Cloud Enterprise Network (CEN) の場合、ドメイン名または IP アドレス および ポート番号 にプライマリノードのアドレスとポートを設定するか、高可用性接続アドレスを設定してください。高可用性接続アドレスの詳細については、「高可用性 MongoDB データベースのソースまたはターゲットインスタンスの作成」をご参照ください。

    • アクセス方法 が ECS 上の自己管理データベース の場合、ポート番号 にプライマリノードのポートを設定してください。

  • 増分データ移行はサポートされていません。

  • DTS は SRV レコードを使用した MongoDB データベースへの接続をサポートしていません。

  • ターゲットコレクションに一意なインデックスが存在するか、capped 属性が true に設定されている場合、増分データ移行中に同時リプレイ(シングルスレッドでのみ書き込み可能)がサポートされません。これにより、タスクの遅延が増加する可能性があります。

  • DTS は admin、config、local データベースからのデータ移行をサポートしていません。

  • DTS はトランザクション情報を保持しません。ソースデータベースのトランザクションは、ターゲットデータベースで個別の文に変換されます。

  • DTS がターゲットコレクションにデータを書き込む際、プライマリキーまたは一意キーの競合が発生した場合、DTS は競合するデータ書き込み文をスキップし、ターゲットコレクション内の既存データを保持します。

  • 互換性を確保するため、ソースおよびターゲットデータベースの MongoDB バージョンを一致させるか、古いバージョンから新しいバージョンへ移行してください。新しいバージョンから古いバージョンへの移行は、互換性の問題を引き起こす可能性があります。

  • ソースデータベースが MongoDB 3.6 より前のバージョンで、ターゲットデータベースが MongoDB 3.6 以降の場合、移行後のデータにおけるフィールド順序がソースと異なる可能性があります。ただし、フィールドと値のペアは正しいままです。これはデータベースエンジンの実行計画の違いによるものです。アプリケーションロジックでネスト構造に対するテキストマッチングが行われる場合は、このフィールド順序の変更が与える影響を評価してください。

  • データ移行前に、ソースおよびターゲットデータベースのパフォーマンスを評価し、オフピーク時間帯に移行を実施してください。完全なデータ移行中、DTS は読み取りおよび書き込みリソースを消費するため、データベース負荷が増加する可能性があります。

  • 完全なデータ移行中、DTS は同時 INSERT 操作を実行するため、ターゲットコレクションに断片化が発生します。その結果、ターゲットコレクションのストレージ使用量がソースインスタンスのコレクションよりも多くなる可能性があります。

  • FLOAT または DOUBLE 列に対して DTS が使用する移行精度がビジネス要件を満たしていることを確認してください。DTS はこれらの型の値を ROUND(COLUMN,PRECISION) を使用して読み取ります。精度を明示的に定義しない場合、DTS は FLOAT 値を 38 桁の精度で、DOUBLE 値を 308 桁の精度で移行します。

  • DTS は失敗した移行タスクを 7 日以内に再開しようと試みます。ターゲットインスタンスへのサービス切り替え前に、タスクを終了または解放するか、ターゲットインスタンスへのアクセスに使用する DTS アカウントの書き込み権限を revoke コマンドで取り消してください。これにより、タスクが自動的に再開された際にソースデータがターゲットインスタンスのデータを上書きしてしまうことを防げます。

  • DTS がデータを同時に書き込むため、ターゲットデータベースのストレージ使用量はソースデータベースよりも 5 % ~ 10 % 多くなります。

  • ターゲット MongoDB の件数をクエリするには、db.$table_name.aggregate([{ $count:"myCount"}]) 構文を使用してください。

  • ターゲット MongoDB データベースに、ソースデータベースと同じプライマリキー(デフォルトでは _id フィールド)を持つドキュメントが存在しないことを確認してください。存在する場合、データ損失が発生する可能性があります。このようなドキュメントが存在する場合は、ビジネスに影響がないことを確認した上で、移行前にターゲットデータベースから競合する _id 値を持つドキュメントを削除してください。

  • タスクが失敗した場合、DTS サポートスタッフが 8 時間以内に復旧を試みます。復旧中、タスクが再起動されたり、パラメーターが調整されたりする可能性があります。

    説明

    変更されるのは DTS タスクのパラメーターのみであり、データベースのパラメーターは変更されません。 調整対象となるパラメーターは、「インスタンスパラメーターの変更」に記載されています。

  • ターゲットデータベースが MongoDB シャードクラスターの場合、ビジネスをこのデータベースに切り替えた後は、ビジネス運用がシャードコレクションの要件に準拠していることを確認する必要があります。

  • ソースデータベースが MongoDB 5.0 以降で、ターゲットデータベースがそれ以前のバージョンの場合、capped collections を移行することはできません。これにより、タスクが失敗したり、データの不整合が発生したりする可能性があります。これは MongoDB 5.0 で capped collections の動作が変更され、明示的な削除および更新時のドキュメントサイズの増加が許可されたためです。それ以前のデータベースカーネルはこれらの機能と互換性がありません。

  • MongoDB 5.0 で導入された時系列コレクションは、移行に対応していません。

特殊ケース

ソースが自己管理 MongoDB データベースの場合、移行中にプライマリ/セカンダリ スイッチオーバーが発生すると、タスクが失敗します。

課金

移行タイプ

インスタンス構成料金

インターネットトラフィック料金

スキーマ移行および完全なデータ移行

無料です。

ターゲットデータベースの アクセス方法 パラメーターが パブリック IP アドレス に設定されている場合、インターネットトラフィック料金が発生します。詳細については、「課金概要」をご参照ください。

移行タイプ

移行タイプ

説明

スキーマ移行

オブジェクトスキーマをソースの ApsaraDB for MongoDB インスタンスからターゲットの ApsaraDB for MongoDB インスタンスに移行します。

説明

DTS は DATABASE、COLLECTION、INDEX オブジェクトのスキーマ移行をサポートしています。

完全なデータ移行

ソースの ApsaraDB for MongoDB インスタンスから、既存のすべてのデータをターゲットの ApsaraDB for MongoDB インスタンスに移行します。

説明

DTS は DATABASE および COLLECTION オブジェクト内のデータの完全なデータ移行をサポートしています。

データベースアカウントに必要な権限

データベース

スキーマ移行

完全なデータ移行

ソースの ApsaraDB for MongoDB インスタンス

移行対象のデータベースおよび config データベースに対する読み取り権限。

ターゲットの ApsaraDB for MongoDB インスタンス

dbAdminAnyDatabase 権限、ターゲットデータベースに対する readWrite 権限、および local データベースに対する読み取り権限。

ApsaraDB for MongoDB インスタンスのデータベースアカウントの作成および権限付与については、「DMS での MongoDB データベースユーザーの管理」をご参照ください。

操作手順

  1. 次のいずれかの方法で、ターゲットリージョンの移行タスクリストページに移動します。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソール にログインします。

    2. 左側のナビゲーションウィンドウで、データの移行 をクリックします。

    3. ページ左上隅で、移行インスタンスが配置されているリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモードコンソール」および「DMS コンソールのレイアウトおよびスタイルのカスタマイズ」をご参照ください。

    1. Data Management (DMS) コンソール にログインします。

    2. 上部のメニューバーで、Data + AI > Data Transmission (DTS) > データ移行 を選択します。

    3. データ移行タスク の右側で、移行インスタンスが配置されているリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページに移動します。

  3. ソースおよびターゲットデータベースを設定します。

    警告

    ソースおよびターゲットインスタンスを選択した後は、ページ上部に表示される制限事項を慎重に確認することを推奨します。確認しないと、タスクが失敗したり、データの不整合が発生したりする可能性があります。

    セクション

    パラメーター

    説明

    該当なし

    タスク名

    DTS が自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    移行元データベース

    既存の接続情報の選択

    • システムに追加済み(作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストから目的のデータベースインスタンスを選択します。以下のデータベース情報が自動的に設定されます。

      説明

      DMS コンソールでは、このパラメーターの名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、以下でデータベース情報を手動で設定してください。

    データベースタイプ

    MongoDB を選択します。

    アクセス方法

    クラウドインスタンス を選択します。

    インスタンスリージョン

    ソースの ApsaraDB for MongoDB インスタンスが配置されているリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントのデータベースインスタンスを使用します。× を選択します。

    アーキテクチャ

    ソースがスタンドアロンインスタンスであっても、アーキテクチャ設定では レプリカセット を選択します。

    • レプリカセット:複数のノードタイプをデプロイすることで高可用性および読み書き分離を提供します。詳細については、「レプリカセットアーキテクチャ」をご参照ください。

    • シャードクラスター:Mongos、シャード、ConfigServer コンポーネントで構成されます。Mongos およびシャードノードの数と構成をカスタマイズできます。詳細については、「シャードクラスターアーキテクチャ」をご参照ください。

    移行方法

    スタンドアロンのソースインスタンスは増分移行をサポートしていません。DTS ではスタンドアロンソースでもこの設定が必要なため、移行方法はデフォルトの Oplog のままにしてください。

    Instance ID

    ソースの ApsaraDB for MongoDB インスタンスの ID を選択します。

    認証データベース

    ソースの ApsaraDB for MongoDB インスタンスの認証データベース名を入力します。デフォルトは admin です。

    データベースアカウント

    ソースの ApsaraDB for MongoDB インスタンスのデータベースアカウントを入力します。権限要件については、「データベースアカウントに必要な権限」をご参照ください。

    データベースパスワード

    データベースアカウントのパスワードを入力します。

    暗号化

    DTS は 3 種類の接続方法をサポートしています:非暗号化、SSL 暗号化、および Mongo Atlas SSL。暗号化 のオプションは、選択した アクセス方法 および アーキテクチャ によって異なります。コンソールに表示されるオプションが優先されます。

    説明
    • アーキテクチャ が シャードクラスター で、移行方法 が Oplog の MongoDB データベースは、SSL 暗号化 をサポートしていません。

    • ソースが自己管理 MongoDB データベース(アクセス方法 が Alibaba Cloud インスタンス 以外)で、レプリカセット アーキテクチャの場合、SSL 暗号化 を選択すると、DTS では CA 証明書をアップロードして接続を検証することも可能です。

    宛先データベース

    既存の接続情報の選択

    • システムに追加済み(作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストから目的のデータベースインスタンスを選択します。以下のデータベース情報が自動的に設定されます。

      説明

      DMS コンソールでは、このパラメーターの名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、以下でデータベース情報を手動で設定してください。

    データベースタイプ

    MongoDB を選択します。

    アクセス方法

    クラウドインスタンス を選択します。

    インスタンスリージョン

    ターゲットの ApsaraDB for MongoDB インスタンスが配置されているリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントのデータベースインスタンスを使用します。× を選択します。

    アーキテクチャ

    ビジネス要件に基づいてアーキテクチャを選択します。

    • レプリカセット:複数のノードタイプをデプロイすることで高可用性および読み書き分離を提供します。詳細については、「レプリカセットアーキテクチャ」をご参照ください。

    • シャードクラスター:Mongos、シャード、ConfigServer コンポーネントで構成されます。Mongos およびシャードノードの数と構成をカスタマイズできます。詳細については、「シャードクラスターアーキテクチャ」をご参照ください。

    Instance ID

    ターゲットの ApsaraDB for MongoDB インスタンスの ID を選択します。

    認証データベース

    ターゲットの ApsaraDB for MongoDB インスタンスの認証データベース名を入力します。デフォルトは admin です。

    データベースアカウント

    ターゲットの ApsaraDB for MongoDB インスタンスのデータベースアカウントを入力します。権限要件については、「データベースアカウントに必要な権限」をご参照ください。

    データベースパスワード

    データベースアカウントのパスワードを入力します。

    暗号化

    DTS は 3 種類の接続方法をサポートしています:非暗号化、SSL 暗号化、および Mongo Atlas SSL。暗号化 のオプションは、選択した アクセス方法 および アーキテクチャ によって異なります。コンソールに表示されるオプションが優先されます。

    説明
    • アーキテクチャ が シャードクラスター の MongoDB データベースは、SSL 暗号化 をサポートしていません。

    • ターゲットが自己管理 MongoDB データベース(アクセス方法 が Alibaba Cloud インスタンス 以外)で、レプリカセット アーキテクチャの場合、SSL 暗号化 を選択すると、DTS では CA 証明書をアップロードして接続を検証することも可能です。

  4. 設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明
    • DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サービスの IP アドレスセグメントを自動または手動で追加していることを確認してください。詳細については、「DTS サーバーの IP アドレスをホワイトリストに追加」をご参照ください。

    • ソースまたはターゲットデータベースが自己管理データベース(アクセス方法 が Alibaba Cloud インスタンス 以外)の場合、表示される DTS サーバーの CIDR ブロック ダイアログボックス内で 接続テスト をクリックする必要があります。

  5. タスクオブジェクトを設定します。

    1. オブジェクト設定 ページで、移行対象のオブジェクトを設定します。

      パラメーター

      説明

      移行タイプ

      スキーマ移行 および 完全データ移行 の両方を選択します。

      説明

      このシナリオでは増分移行はサポートされていません。データ整合性を確保するため、データ移行中はソースインスタンスに新しいデータを書き込まないでください。

      詳細については、「移行タイプ」をご参照ください。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:ターゲットデータベースに同名のコレクションが存在するかどうかをチェックします。同名のコレクションが存在しない場合、事前チェックは合格します。同名のコレクションが存在する場合、事前チェック中にエラーが報告され、データ移行タスクは開始されません。

        説明

        ターゲットデータベースのコレクションが同名であるにもかかわらず、簡単に削除または名前変更できない場合は、ターゲットデータベースのコレクション名を変更できます。詳細については、「オブジェクト名マッピング」をご参照ください。

      • エラーを無視して続行:同名のコレクションのチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合やビジネスリスクが発生する可能性があります。例えば、次のような問題が考えられます。

        • ターゲットデータベースのレコードがソースデータベースのレコードと同じプライマリキー値を持つ場合、ターゲットデータベースのレコードが保持されます。ソースデータベースのレコードはターゲットデータベースに移行されません。

        • データ初期化が失敗する、一部のデータのみが移行される、または移行が失敗する可能性があります。

      移行先インスタンスでのオブジェクト名の大文字化

      ターゲットインスタンスでのデータベースおよびコレクション名の大文字小文字の扱いを設定します。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースまたはターゲットのデフォルトポリシーに合わせることも可能です。詳細については、「ターゲットインスタンスでのオブジェクト名の大文字小文字の扱い」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで移行対象のオブジェクトをクリックし、Right arrow をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      データベースまたはコレクションレベルでオブジェクトを選択します。

      選択中のオブジェクト

      • ターゲットインスタンスでの移行オブジェクトの名前を設定する場合、またはターゲットインスタンスでデータを受信するオブジェクトを指定する場合は、選択中のオブジェクト ボックス内の移行オブジェクトを右クリックして変更します。詳細については、「オブジェクト名マッピング」をご参照ください。

      • 選択済みの移行オブジェクトを削除する場合は、選択中のオブジェクト ボックスでオブジェクトをクリックし、image をクリックして ソースオブジェクト ボックスに移動させます。

      説明
      • 完全なデータ移行中に条件に基づいてデータをフィルターする場合は、選択中のオブジェクト ボックス内のコレクションを右クリックし、表示されるダイアログボックスでフィルターを設定します。詳細については、「フィルター条件の設定」をご参照ください。

      • オブジェクト名マッピングを使用してデータベースまたはコレクションを再ターゲットすると、依存オブジェクトの移行が失敗する可能性があります。

    2. 詳細設定へ をクリックして、詳細パラメーターを設定します。

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジュールします。選択する必要はありません。より安定したタスクを希望する場合は、DTS 移行タスクを実行するための専用クラスターを購入できます。

      失敗した接続の再試行時間

      移行タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、すぐに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1440 分の範囲で再試行時間をカスタマイズできます。30 分以上に設定することを推奨します。指定された時間内に DTS がソースおよびターゲットデータベースに再接続できた場合、移行タスクは自動的に再開されます。それ以外の場合は、タスクが失敗します。

      説明
      • 同じソースまたはターゲットを共有する複数の DTS インスタンスの場合、ネットワーク再試行時間は最後に作成されたタスクの設定によって決まります。

      • 接続再試行期間中もタスクに対して課金されるため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後はできるだけ早く DTS インスタンスを解放することを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      移行タスク開始後、DDL または DML 実行例外などの接続以外の問題がソースまたはターゲットデータベースで発生した場合、DTS はエラーを報告し、すぐに操作の再試行を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1440 分の範囲で再試行時間をカスタマイズできます。10 分以上に設定することを推奨します。指定された再試行時間内に関連操作が成功した場合、移行タスクは自動的に再開されます。それ以外の場合は、タスクが失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。

      完全移行率を制限するかどうか

      完全移行中、DTS はソースおよびターゲットデータベースの読み取りおよび書き込みリソースを消費するため、データベース負荷が増加する可能性があります。必要に応じて、完全移行タスクの速度制限を有効化できます。1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS を設定して、ターゲットデータベースの負荷を軽減できます。

      説明
      • この設定項目は、移行タイプ で 完全データ移行 を選択した場合にのみ利用可能です。

      • 移行インスタンスの実行後も、完全移行速度を調整 できます。

      同期するデータのうち、同一テーブル内のプライマリキー_id のデータ型が一意かどうか

      移行対象データにおいて、プライマリキー _id のデータ型は、単一のコレクション内で統一されていますか?

      重要
      • 要件に基づいてオプションを選択してください。選択しないと、データ損失が発生する可能性があります。

      • このパラメーターは、移行タイプ で 完全データ移行 を選択した場合にのみ利用可能です。

      • ○:データ型は一意です。完全なデータ移行中、DTS はソースデータのプライマリキーのデータ型をスキャンしません。単一のコレクションについて、DTS は 1 つのプライマリキーのデータ型に対応するデータのみを移行します。

      • ×:データ型は一意ではありません。完全なデータ移行中、DTS はソースデータのプライマリキーのデータ型をスキャンし、すべてのデータを移行します。

      環境タグ

      必要に応じて、インスタンスを識別するための環境タグを選択します。

      ETL 機能の設定

      ビジネスニーズに基づいて、データを処理するためにETL 機能を設定するかどうかを選択します。

      • ○:ETL 機能を設定します。また、テキストボックスにデータ処理文を入力する必要があります。

      • ×:ETL 機能を設定しません。

      監視アラート

      ビジネスニーズに基づいて、アラートを設定し、アラート通知を受信するかどうかを選択します。

      • ×:アラートを設定しません。

      • ○:アラートのしきい値 および アラート通知を設定してアラートを構成します。移行が失敗した場合や遅延がしきい値を超えた場合、システムがアラート通知を送信します。

    3. 次へ:データ検証 をクリックして、データ検証タスクを設定します。

      データ検証機能の詳細については、「データ検証の設定」をご参照ください。

  6. タスクを保存して事前チェックを実行します。

    • API オペレーションを呼び出す際にこのインスタンスを設定するためのパラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにポインターを合わせ、表示される吹き出し内の OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターを表示する必要がない場合、または表示が完了した場合は、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 移行タスク開始前に、DTS が事前チェックを実行します。事前チェックに合格した後にのみ、タスクが開始されます。

    • 事前チェックが失敗した場合は、失敗したチェック項目の横にある 詳細を表示 をクリックし、プロンプトに基づいて問題を修正した後、再度事前チェックを実行してください。

    • 事前チェック中に警告が報告された場合:

      • 無視できないチェック項目の場合は、失敗した項目の横にある 詳細を表示 をクリックし、プロンプトに基づいて問題を修正した後、再度事前チェックを実行してください。

      • 無視可能なチェック項目の場合は、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 をクリックして、アラート項目をスキップし、再度事前チェックを実行できます。警告を無視することを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  7. インスタンスを購入します。

    1. 成功率 が 100 % になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ移行インスタンスのリンク仕様を選択します。詳細については、次の表をご参照ください。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      リソースグループの設定

      インスタンスが属するリソースグループを選択します。デフォルト値は default resource group です。詳細については、「Resource Management とは」をご参照ください。

      インスタンスクラス

      DTS は、さまざまなパフォーマンスレベルの移行仕様を提供しています。リンク仕様は移行速度に影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ移行リンク仕様」をご参照ください。

    3. 設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。表示される OK ダイアログボックスで、OK をクリックします。

      データ移行タスク リストページで、移行タスクの進行状況を確認できます。

      説明
      • 移行タスクに増分移行が含まれていない場合、完全移行が完了すると自動的に停止します。タスクが停止すると、ステータス は 完了 に変化します。

      • 移行タスクに増分移行が含まれている場合、自動的には停止しません。増分移行タスクは継続して実行されます。増分移行タスクが実行中の間、タスクの ステータス は 実行中 になります。