すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:StopInstances

最終更新日:Sep 15, 2026

1 つ以上の ECS インスタンスを停止します。異なる停止方法、停止モード、およびバッチ操作モードを指定できます。

操作説明

これは非同期操作です。呼び出しが成功しても、インスタンスはすぐには停止されません。呼び出しが成功すると、インスタンスは Stopping 状態になります。 DescribeInstanceStatus を呼び出して、インスタンスステータスをクエリできます。返されるステータスが Stopped の場合、インスタンスは停止されています。

開始する前に

  • インスタンスが停止されると、そのインスタンスは使用できなくなります。インスタンスの停止がビジネスに影響を与えないことを確認してください。 StartInstance または StartInstances を呼び出して、インスタンスを起動できます。

  • セキュリティ上の理由でロック済みのインスタンスは、この操作を呼び出しても停止できません。詳細については、「API 操作に対するリソースセキュリティロックの影響」を参照してください。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:StopInstances

update

*Instance。

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

DryRun

boolean

任意

ドライランリクエストを送信するかどうかを指定します。有効な値:

  • true: インスタンスを停止せずにドライランリクエストを送信します。システムは、必須パラメーター、リクエスト初期化、およびインスタンスステータスをチェックします。チェックに失敗した場合、対応するエラーが返されます。チェックに成功した場合、DRYRUN.SUCCESS が返されます。

説明

BatchOptimization パラメーターが SuccessFirst にセットされている場合、DryRun=true のドライラン結果は DRYRUN.SUCCESS のみを返します。

  • false: 通常のリクエストを送信します。リクエストがチェックに合格すると、インスタンスが停止されます。

デフォルト値: false。

false

RegionId

string

必須

インスタンスのリージョン ID。 DescribeRegions を呼び出して、最新のリージョンリストをクエリできます。

cn-hangzhou

ForceStop

boolean

任意

インスタンスを強制的に停止するかどうかを指定します。有効な値:

  • true: インスタンスを強制的に停止します。
    説明

    <警告>強制停止は仕事率オフと同等です。オペレーティングシステム内のディスクに書き込まれていないデータが失われる可能性があります。注意して実行してください。></警告>

  • false: インスタンスを通常通り停止します。

デフォルト値: false。

false

StoppedMode

string

任意

停止モード。有効な値:

  • StopCharging: 節約モード。節約モードが有効になると:

    • コンピューティングリソース (vCPU、メモリ、GPU)、イメージライセンス料金、および静的パブリック IP アドレスの固定帯域幅の課金が停止されます。

    • システムディスク、データディスク、および EIP の固定帯域幅の課金は継続されます。

    • コンピューティングリソースがリリースされるため、リソース不足によりインスタンスの起動に失敗する可能性があります。後でもう一度試すか、インスタンスタイプを変更してください。

    • インスタンスが停止される前に EIP がインスタンスに関連付けられている場合、インスタンスの再起動後も IP アドレスは変更されません。それ以外の場合、静的パブリック IP アドレスは変更される可能性がありますが、非公開 IP アドレスは変更されません。

    詳細については、「節約モード」を参照してください。

    重要 インスタンスが節約モードをサポートしていない場合、API はエラーを返しません。システムはインスタンスの停止を優先します。節約モードをサポートしていないインスタンスタイプには、ローカル SSD を備えたインスタンスやサブスクリプションインスタンスが含まれます。

  • KeepCharging: 標準停止モード。インスタンスが停止された後、インスタンスリソースは保持され、課金は継続されます。ECS インスタンスタイプの在庫とパブリック IP アドレスも保持されます。オペレーティングシステムを置き換える、ディスクを再初期化する、インスタンスタイプを変更する、または非公開 IP アドレスを変更するためにインスタンスを停止する場合は、起動の失敗を回避するためにこのモードを選択してください。

デフォルト値: VPC 接続インスタンスの節約モードを有効にし、条件を満たしている場合、デフォルト値は StopCharging です。それ以外の場合、デフォルト値は KeepCharging です。

KeepCharging

BatchOptimization

string

任意

バッチ操作モード。有効な値:

  • AllTogether: バッチ操作全体が成功したとみなされるには、すべての操作が成功する必要があります。いずれかの操作が失敗した場合、バッチ操作全体が失敗したとみなされ、実行されたすべての操作が操作前の状態にロールバックされます。

  • SuccessFirst: バッチ内の各操作は独立して実行されます。操作が失敗しても、他の操作は引き続き実行され、成功として確認できます。このモードでは、成功した操作はコミットされ、失敗した操作は他の操作の結果に影響を与えずに失敗としてマークされます。

デフォルト値: AllTogether。

AllTogether

InstanceId

array

必須

インスタンス ID 配列。配列の長さ: 1~100。

i-bp67acfmxazb4p****

string

任意

インスタンス ID

i-bp67acfmxazb4p****

レスポンスフィールド

フィールド

型

説明

例

object

InstanceResponses

object

InstanceResponse

array<object>

操作の前後のステータスと各インスタンスの操作結果を含む InstanceResponse オブジェクトの配列。

object

Code

string

インスタンス操作結果のエラーコード。戻り値 200 は成功を示します。詳細については、エラーコードセクションを参照してください。

200

CurrentStatus

string

インスタンスの現在のステータス。

Stopping

InstanceId

string

インスタンス ID

i-bp67acfmxazb4p****

Message

string

インスタンス操作に対して返されるエラーメッセージ。戻り値 success は、操作が成功したことを示します。詳細については、エラーコードセクションを参照してください。

success

PreviousStatus

string

操作前のインスタンスのステータス。

Running

RequestId

string

リクエスト ID

1C488B66-B819-4D14-8711-C4EAAA13AC01

例

成功レスポンス

JSONJSON

{
  "InstanceResponses": {
    "InstanceResponse": [
      {
        "Code": "200",
        "CurrentStatus": "Stopping",
        "InstanceId": "i-bp67acfmxazb4p****",
        "Message": "success",
        "PreviousStatus": "Running"
      }
    ]
  },
  "RequestId": "1C488B66-B819-4D14-8711-C4EAAA13AC01"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidParameter.KMSKeyId.CMKNotEnabled The CMK needs to be added ECS tag
400 InvalidParameter.KMSKeyId.KMSUnauthorized ECS service account have no right to access your KMS. ECS に Key Management Service (KMS) サービスへのアクセス権限がありません。
400 DRYRUN.SUCCESS This request is a dryrun request with successful result. ドライランリクエストのチェックが完了し、合格しました。
400 InvalidParameter.Encrypted.KmsNotEnable The operation failed because KMS is not activated. Please activate KMS in the KMS console and try again.
500 InternalError The request processing has failed due to some unknown error.
403 InvalidInstanceId.NotFound InstanceId should not be null.
403 InvalidParameter.TooManyInstanceIds Instance ids cannot be more than 100. InstanceIds リストの長さが 100 を超えています。
403 Abs.InvalidInstanceIds.MalFormed The specified instanceIds is not valid. 指定された InstanceId パラメーターが無効です。
403 InstanceLockedForSecurity %s
403 InstanceExpiredOrInArrears %s
403 IncorrectInstanceStatus %s 現在のインスタンスステータスでは、この操作はサポートされていません。
403 InvalidInstanceId.NotSupport %s
403 InsufficientBalance Your account does not have enough balance.
403 InstanceNotReady The specified instance is not ready for use.
403 InvalidOperation.KMSKeyIdNotFound The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region.
403 InvalidOperation.KMSServiceNotOpen KMS service is currently not open. Key Management Service (KMS) サービスが有効化されていません。
403 OperationDenied.SystemInstanceNotSupport The system instance does not support the %s operation because %s.
403 OperationDenied.KMSKeyUnauthorized The operation is denied due to missing KMS key authorization. Please check the KMS key permissions and ensure the key is properly authorized for this operation.
404 InvalidInstanceId.NotFound %s
404 InvalidInstanceIds.NotFound The specified InstanceIds does not exist. 指定された InstanceId が存在しません。InstanceId パラメーター値が正しいかどうかを確認してください。DescribeInstances を呼び出して、指定されたインスタンスのステータスをクエリできます。
503 LimitedOperation.ServiceUnavailable The service is currently unavailable. Please try again later. サービスは現在ご利用いただけません。後でもう一度お試しください。
409 InvalidOperation.Conflict Request was denied due to conflict with a previous request, please try again later. タスクの競合が発生しているため、この操作は実行できません。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。