すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:StartInstance

最終更新日:Sep 15, 2026

ECS インスタンスを起動します。インスタンス ID を指定し、必要に応じて InitLocalDisk などのパラメーターを設定してインスタンスを起動できます。

操作説明

これは非同期操作です。呼び出しが成功しても、インスタンスはすぐには起動しません。インスタンスは最初に Starting 状態になります。 DescribeInstanceStatus を呼び出して、インスタンスステータスをクエリしてください。返されるステータスが Running である場合、インスタンスは起動しています。

始める前に

  • セキュリティ上の理由でロック済みのインスタンスは、この操作では起動できません。詳細については、「中国サイト (API 呼び出しに対するリソースセキュリティロックの影響)」を参照してください。

  • ECS インスタンスは Stopped (Stopped) 状態である必要があります。

  • 節約モードのインスタンスは、リソース不足により起動に失敗する場合があります。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:StartInstance

update

*Instance。

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

InstanceId

string

必須

起動するインスタンスの ID。

i-bp67acfmxazb4p****

InitLocalDisk

boolean

任意

ローカルディスクに障害が発生した際に、インスタンスを初期の正常な状態に回復するかどうかを指定します。このパラメーターは、d1、i1、i2 インスタンスファミリーのインスタンスなど、ローカルディスクを使用するインスタンスに適用されます。有効な値:

  • true: インスタンスを初期の正常な状態に回復します。

説明

<警告>インスタンスのローカルディスクに保存されているすべてのデータが失われます。></警告>

  • false: 何も操作を行わず、現在の状態を維持します。

デフォルト値: false。

true

DryRun

boolean

任意

実際のリクエストを実行せずに、ドライランのみを実行するかどうかを指定します。有効な値:

  • true: ドライランのみを実行します。インスタンスは起動しません。システムは、リクエストパラメーターが有効かどうか、Resource Access Management (RAM) ユーザーに必要な権限付与があるかどうか、および必須パラメーターが指定されているかどうかを確認します。確認に失敗した場合、対応するエラーが返されます。確認に成功した場合、DryRunOperation エラーコードが返されます。

  • false: 通常のリクエストを送信します。確認に成功した場合、2XX HTTP 状態コードが返され、インスタンスが起動します。

デフォルト値: false。

true

レスポンスフィールド

フィールド

型

説明

例

object

RequestId

string

リクエスト ID

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

例

成功レスポンス

JSONJSON

{
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 LackResource There's no enough resource on the specified capacity reservation.
400 InvalidDedicatedHost.NotEnoughResource The specified dedicated host has not enough resource due to host affinity.
400 InvalidInstance.NotFoundSystemDisk The specified instance does not have system disk.
400 Invalid.PrivatePoolOptions.NoStock The PrivatePool has been used up. 指定された非公開プール (エラスティシティ保証またはリソース予約) の容量がすべて使用されています。
500 InstanceNotReady The specified instance is not ready for use.
500 InternalError The request processing has failed due to an internal error and you may retry later or contact support with the request ID.
403 InvalidParameter.KMSKeyId.NotFound The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region.
403 IncorrectInstanceStatus The current status of the resource does not support this operation.
403 InstanceLockedForSecurity The specified operation is denied as your instance is locked for security reasons. ディスクがアタッチされているインスタンスは、セキュリティ上の理由によりロック済みです。
403 InsufficientBalance Your account does not have enough balance.
403 DiskError IncorrectDiskStatus.
403 InstanceExpired The postPaid instance has been expired.Please ensure your account have enough balance. サブスクリプションインスタンスが有効期限切れです。この操作を実行する前にインスタンスを更新してください。
403 InstanceNotReady The specified instance is not ready for use.
403 DiskInArrears The specified operation is denied as your disk has expired.
403 OperationDenied.SpotPriceLowerThanPublicPrice The spot instance price is lower than public price. スポットインスタンスの入札価格は、公開価格より低くすることはできません。
403 InvalidParameter.KMSKeyId.CMKUnauthorized The CMK needs to be added ECS tag. ECS タグをカスタマーマスターキー (CMK) に追加する必要があります。
403 InvalidParameter.KMSKeyId.CMKNotEnabled The CMK needs to be enabled.
403 InvalidParameter.KMSKeyId.KMSUnauthorized The ECS service is not authorized to access your KMS key. Please grant the ECS service permission to use the key and try again.
403 QuotaExceed.ElasticQuota No additional quota is available for the specified ECS instance type. 現在のリージョンで選択したインスタンスタイプで作成されるインスタンスの数がクォータを超えているか、またはすべてのインスタンスタイプの合計 vCPU クォータを超えました。ECS コンソールまたはクォータセンターにアクセスしてクォータの引き上げをリクエストできます。
403 OperationDenied.HostRepairing The specified operation is denied as the host of ECS instance is being repaired. ECS インスタンスが存在する物理マシンがメンテナンス中のため、指定された操作は許可されていません。
403 OperationDenied.NoStock The requested resource is sold out in the specified zone, try other types of resources or other regions and zones. 指定されたディスクカテゴリが指定されたゾーンまたはクラスターに存在しないか、指定されたゾーンがクラスターと一致しません。
403 OperationDenied.KMSKeyUnauthorized The operation is denied due to missing KMS key authorization. Please check the KMS key permissions and ensure the key is properly authorized for this operation.
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。
404 InvalidCapacityReservationId.NotFound The specified capacity reservation does not exist.
503 ServiceUnavailable The request has failed due to a temporary failure of the server. バックエンドリクエストがタイムアウトしました。後でもう一度お試しください。
503 LimitedOperation.ServiceUnavailable The service is currently unavailable. Please try again later. サービスは現在ご利用いただけません。後でもう一度お試しください。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。