ディスクスナップショットを使用して、ディスクを以前の状態にロールバックします。
操作説明
この操作の呼び出し前に、スナップショットを使用したディスクのロールバック をお読みください。
この操作の呼び出しの際は、以下の点にご注意ください。
ディスクは、使用中 (In_use) または使用可能 (Available) 状態である必要があります。
ディスクがアタッチされているインスタンスは、停止 (Stopped) 状態である必要があります。 StopInstances の呼び出しにより、インスタンスを停止できます。
指定する SnapshotId パラメーターは、DiskId で指定されたディスクから作成された過去のスナップショットである必要があります。
DescribeInstances の呼び出しにより ECS インスタンス情報をクエリした際、応答に {"OperationLocks": {"LockReason" : "セキュリティ"}} が含まれている場合、そのインスタンスに対するすべての操作が禁止されています。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:ResetDisk |
update |
*Disk。
*Snapshot。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| DiskId |
string |
必須 |
ロールバックするディスクの ID。 |
d-bp199lyny9b3**** |
| SnapshotId |
string |
必須 |
ディスクのロールバックに使用するスナップショットの ID。 |
s-bp199lyny9b3**** |
| DryRun |
boolean |
任意 |
ドライランを実行するかどうかを指定します。有効な値:
デフォルト値: false。 |
false |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| RequestId |
string |
リクエスト ID |
F3CD6886-D8D0-4FEE-B93E-1B732396**** |
例
成功レスポンス
JSONJSON
{
"RequestId": "F3CD6886-D8D0-4FEE-B93E-1B732396****"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | DiskCategory.OperationNotSupported | The operation is not supported to the specified disk due to its disk category. | 現在のディスクタイプはこの操作をサポートしていません。 |
| 400 | InvalidRegionId.MalFormed | The specified RegionId is not valid. | |
| 400 | DryRunOperation | Request validation has been passed with DryRun flag set. | ドライランチェックに合格しました。リクエストは有効です。 |
| 400 | InternalError | The requested services is not available now. Please try again later. | 内部エラーが発生しました。もう一度お試しください。 |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectDiskStatus | The current disk status does not support this operation. | |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | InstanceLockedForSecurity | The instance is locked due to security. | ディスクがアタッチされているインスタンスは、セキュリティ上の理由によりロック済みです。 |
| 403 | InvalidParameter.Mismatch | The specified snapshot is not created from the specified disk. | |
| 403 | InvalidSnapshot.TooOld | The snapshot was created before 2013-07-15 and cannot be restored since the disk was first detached. | |
| 403 | InstanceExpiredOrInArrears | The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode). | |
| 403 | OperationDenied | The specified snapshot dees not support ResetDisk. | |
| 403 | InvalidSnapshotId.NotReady | The specified snapshot has not completed yet. | |
| 403 | InvalidAccountStatus.NotEnoughBalance | Your account does not have enough balance. | |
| 403 | InvalidAccountStatus.SnapshotServiceUnavailable | Snapshot service has not been opened yet. | スナップショットサービスが有効化されていません。操作を実行できません。 |
| 403 | Operation.Conflict | The operation may conflict with others. Please retry later. | |
| 403 | UserNotInTheWhiteList | The user is not in disk white list. | ユーザーは共有ブロックストレージのホワイトリストに含まれていません。ホワイトリストへの登録を申請するには、チケットを起票してください。 |
| 403 | InvalidParameter.KMSKeyId.CMKUnauthorized | The CMK has not authorized the ECS service to perform the KMS TagResource and UntagResource operations. Please verify the authorization and try again. | |
| 403 | InvalidParameter.KMSKeyId.CMKNotEnabled | The CMK needs to be enabled. | |
| 403 | InvalidParameter.KMSKeyId.KMSUnauthorized | ECS service does not have permission to access your KMS key. Please verify that the specified KMS key has authorized the ECS service. | |
| 403 | IncorrectDiskStatus.HasUnfinishedSnapshot | The current disk has unfinished snapshot. | 指定されたディスクには未完了のスナップショットがあります。 |
| 403 | InvalidOperation.DiskResetInProgress | The operation cannot be performed because the disk has an ongoing reset task. Please try again later. | |
| 404 | InvalidParameter.KMSKeyId.NotFound | The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region. | |
| 404 | InvalidDiskId.NotFound | The specified disk does not exist. | 指定されたディスクが存在しません。ディスク ID が正しいかどうかを確認してください。 |
| 404 | Disk.NotFound | The specified disk does not exist. | 指定されたディスクが存在しません。ディスクが正しいかどうかを確認してください。 |
| 404 | InvalidSnapshotId.NotFound | The specified SnapshotId does not exist. | |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。