ディスクを専用ブロックストレージクラスターへ移行、専用ブロックストレージクラスターから移行、または専用ブロックストレージクラスター間で移行します。
操作説明
専用ブロックストレージクラスターの特徴は、中国 (杭州)、中国 (上海)、中国 (北京)、中国 (張家口)、中国 (ウランチャブ)、中国 (深セン)、中国 (河源)、インドネシア (ジャカルタ)、ドイツ (フランクフルト)、および中国南部 1 金融リージョンでサポートされています。
この操作の呼び出し前に、ディスクおよび専用ブロックストレージクラスターの支払い方法と料金、専用ブロックストレージクラスターが期限切れでないこと、およびアカウントに支払い遅延がないことを十分にご理解ください。詳細については、「専用ブロックストレージクラスターの課金」および「ブロックストレージの課金」をご参照ください。
この操作の呼び出しの際は、以下の項目にご注意ください。
ディスクと専用ブロックストレージクラスターは同じゾーンにある必要があります。
従量課金ディスクのみがサポートされています。サブスクリプションディスクは、まず従量課金ディスクに変換する必要があります。詳細については、「ディスクの支払い方法の変更」をご参照ください。
ディスクタイプは、送信先クラスターでサポートされているディスクタイプと一致している必要があります。異なる専用ブロックストレージクラスター間で移行する場合は、送信先クラスターでサポートされているディスクタイプに一致するようにディスクタイプを変更できます。
ディスクは 使用中 (In_use) または 利用可能 (Available) 状態である必要があります。
ディスクが ECS インスタンスにアタッチされている場合、インスタンスは 実行中 (Running) または 停止 (Stopped) 状態である必要があります。ECS インスタンスは期限切れであってはなりません。
ESSD (エンタープライズ SSD) のパフォーマンスレベルは容量によって制限されるため、パフォーマンスレベル (PL) をアップグレードできない場合は、ディスクを拡張して再試行できます。詳細については、「 ResizeDisk 」および「 ESSD 」をご参照ください。
単一アカウントに対して、同じリージョン内で同じ時間に実行できるディスク移行タスクは最大値 5 です。
移行中は、移行のキャンセル、スナップショットの作成、スペックアップ/スペックダウン、拡張、アタッチ、デタッチ、またはディスクの再初期化などの操作は許可されていません。
ディスクの移行後、送信先クラスターの支払い方法、ディスクタイプ、および機能は、操作の呼び出し直後に効果が適用されます。Alibaba Cloud は、新しいディスクタイプとパフォーマンスレベル (PL) に基づいて課金します。詳細については、「専用ブロックストレージクラスターの課金」および「ブロックストレージの課金」をご参照ください。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:ModifyDiskDeployment |
update |
*Disk。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| DiskId |
string |
必須 |
ディスクの ID。 |
d-bp131n0q38u3a4zi**** |
| DiskCategory |
string |
任意 |
変更先のクラウドディスクのディスクタイプ。このパラメーターは、専用ブロックストレージクラスター間でデータを移行する場合にのみ効果が適用されます。現在、cloud_essd (ESSD (エンタープライズ SSD)) のみがサポートされています。 デフォルト値: 空。クラウドディスクのディスクタイプが変更されないことを示します。 |
cloud_essd |
| PerformanceLevel |
string |
任意 |
標準 SSD のパフォーマンスレベル (PL)。このパラメーターは、異なる専用ブロックストレージクラスター間でディスクを移行する場合にのみ効果が適用されます。有効な値:
デフォルト値: 空。移行中にパフォーマンスレベル (PL) が変更されないことを示します。 |
PL1 |
| StorageClusterId |
string |
任意 |
専用ブロックストレージクラスターの ID。
デフォルト値: 空。ディスクがパブリッククラウドブロックストレージクラスターに移行されることを示します。 |
dbsc-cn-c4d2uea**** |
| DryRun |
boolean |
任意 |
ドライランのみを実行するかどうかを指定します。有効な値:
デフォルト値: false |
false |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
レスポンスのスキーマ。 |
||
| RequestId |
string |
リクエスト ID |
D69846D9-F17F-51C0-8AC6-B4B71777**** |
| TaskId |
string |
ディスク移行のタスク ID。 |
t-bp67acfmxazb4p**** |
例
成功レスポンス
JSONJSON
{
"RequestId": "D69846D9-F17F-51C0-8AC6-B4B71777****",
"TaskId": "t-bp67acfmxazb4p****"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidDiskSpec.Malformed | The specified parameter DiskCategory or PerformanceLevel is not supported. | 指定された DiskCategory または PerformanceLevel パラメーターのフォームはサポートされていません。 |
| 400 | AccountInArrears | The account is in arrears. | アカウントに支払い遅延があります。 |
| 400 | InvalidStorageClusterId.DiskAlreadyInDestination | The specified disk is already in destination. | 指定されたディスクは既に送信先に存在します。 |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectDiskStatus | The current disk status does not support this operation. | |
| 403 | DiskCreatingSnapshot | The operation is denied due to a snapshot of the specified disk is not completed yet. | |
| 403 | InvalidOperation.DiskTypeUnsupported | The type of the disk does not support this operation. | このディスクタイプでは、この操作はサポートされていません。 |
| 403 | InvalidOperation.DiskCategoryUnsupported | The current category of the disk does not support this operation. | |
| 403 | InvalidOperation.ChargeTypeUnsupported | The charge type of the disk does not support this operation. | ディスクの支払い方法では、この操作はサポートされていません。 |
| 403 | InvalidPerformanceLevel.DiskSizeUnsupported | The specified parameter PerformanceLevel does not match the disk size. | 指定された PerformanceLevel パラメーターのフォームがディスクサイズと一致しません。 |
| 403 | DiskLimitExceeded | The number of migrated disks at the same time exceeds the limit. | 同時移行されるディスク数が上限を超えています。 |
| 403 | OperationDenied.NoStock | The requested resource is sold out in the specified zone; try other types of resources or other regions and zones. | 指定されたディスクカテゴリが指定されたゾーンまたはクラスターに存在しないか、指定されたゾーンがクラスターと一致しません。 |
| 403 | InvalidOperation.MultiAttachDisk | Multi attach disk does not support this operation. | マルチアタッチが有効なディスクはこの操作をサポートしていません。 |
| 403 | InvalidDisk.DetachedSystemDisk | The specified resource is/has a detached system disk %s , not support current operation. | 指定されたディスクはデタッチされたシステムディスクであり、現在の操作をサポートしていません。 |
| 403 | InvalidOperation.NoPermission | You are not authorized to do this action. | 現在の操作を実行する権限がありません。チケットを起票してサポートをご依頼ください。 |
| 403 | InvalidOperation.LimitQosUnsupported | The specified disk has performance limits on bps or iops. This operation is not supported. | |
| 403 | InvalidOperation.AcrossRegionsOrZonesUnsupported | Migration across regions or available zones is not supported. | クロスリージョンまたはクロスゾーンの移行はサポートされていません。 |
| 403 | InvalidOperation.AttachedShareDisk | Attached share disk does not support this operation. | アタッチ済みの共有ディスクでは、この操作はサポートされていません。 |
| 403 | InvalidDiskCategory.NotSupported | The specified storage category is not supported. Please choose a category such as cloud_essd PL0 or PL1 and try again. | |
| 404 | InvalidDiskId.NotFound | The specified disk does not exist. | 指定されたディスクが存在しません。ディスク ID が正しいかどうかを確認してください。 |
| 404 | InvalidStorageClusterId.CategoryNotMatch | The current dedicated storage cluster cannot create this category of disk. | |
| 404 | InvalidStorageClusterId.NotFound | The specified dedicated block storage cluster does not exist. | 指定された専用ブロックストレージクラスターが存在しません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。