すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:ModifyDiskChargeType

最終更新日:Sep 24, 2026

サブスクリプション ECS インスタンスにアタッチされているデータディスクの支払い方法を、従量課金とサブスクリプション間で変更します。

操作説明

データディスクの支払い方法を変更する前に、ディスクの支払い方法の変更 を参照してください。

この API オペレーションを呼び出す際は、以下の項目に注意してください。

  • 従量課金インスタンスにアタッチされているデータディスクの支払い方法は変更できません。従量課金インスタンスでは、従量課金ディスクのみがサポートされます。

  • データディスクがアタッチされているインスタンスは、期限切れで停止した状態であってはなりません。

  • 支払い方法の変更前後の差額は、元の支払方法に返金されます。使用済みのクーポンは返金できません。

  • ディスクの支払い方法が正常に変更された後、5 分以内は再度変更できません。

支払い方法の変更後、自動支払いが有効になります。アカウントの残高が十分であることを確認してください。残高が不足している場合、異常な注文が生成され、その注文を無効にすることしかできません。アカウントの残高が不足している場合は、AutoPay パラメーターを false に設定できます。この場合、未払いの注文が生成されます。Alibaba Cloud の [費用とコスト] コンソールにログインし、注文リスト ページに移動して支払いを完了できます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:ModifyDiskChargeType

update

*Instance。

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

InstanceId

string

必須

ディスクがアタッチされているインスタンスのインスタンス ID。

i-bp1i778bq705cvx1****

RegionId

string

必須

インスタンスのリージョン ID。 DescribeRegions を呼び出して、最新のリージョンリストを取得できます。

cn-hangzhou

DiskIds

string

必須

ディスク ID のリスト。値は、最大 16 個の ID をカンマ (,) で区切った JSON 配列です。

["d-bp67acfmxazb4ph****", "d-bp67acfmxazb4pi****", … "d-bp67acfmxazb4pj****"]

AutoPay

boolean

任意

自動支払いを有効にするかどうかを指定します。有効な値:

  • true (デフォルト): 自動支払いが有効になります。アカウントの残高が十分であることを確認してください。アカウントの残高が不足している場合、異常な注文が生成され、その注文を無効にすることしかできません。

  • false: 支払いなしで注文のみが生成されます。アカウントの残高が不足している場合、未払いの注文が生成されます。Alibaba Cloud の [費用とコスト] コンソールにログインし、注文リスト ページに移動して支払いを完了できます。

true

ClientToken

string

任意

リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認してください。ClientToken の値には ASCII 文字のみを使用でき、長さは 64 文字以下にする必要があります。詳細については、「べき等性を確保する方法」を参照してください。

123e4567-e89b-12d3-a456-426655440000

DiskChargeType

string

任意

ディスクの支払い方法。有効な値:

  • PrePaid (デフォルト): 従量課金データディスクをサブスクリプションデータディスクに変更します。

  • PostPaid: サブスクリプションデータディスクを従量課金データディスクに変更します。

説明

従量課金ディスクをサブスクリプションに変更する場合、容量料金の課金サイクルは、関連付けられた ECS インスタンスと自動的に同期されます。

PostPaid

レスポンスフィールド

フィールド

型

説明

例

object

OrderId

string

注文 ID。

123456****

RequestId

string

リクエスト ID

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

例

成功レスポンス

JSONJSON

{
  "OrderId": "123456****",
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidInstanceType.ValueUnauthorized The specified InstanceType is not authorized.
400 InvalidInstanceType.ValueNotSupported The specified InstanceType is not supported. 指定されたインスタンスタイプは利用可能な範囲外のため、無効です。
400 MissingParameter.RegionId RegionId should not be null. RegionId パラメーターは空にできません。
400 MissingParameter.InstanceIdNotSupported InstanceId should not be null. InstanceId パラメーターは空にできません。
400 ChargeTypeViolation The operation is not permitted due to charge type of the instance. 支払い方法ではこの操作はサポートされていません。インスタンスの支払い方法がこの操作と競合していないか確認してください。
400 InvalidInstanceId.Released The specified Instance is not exist. 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。
400 InvalidInstance.PurchaseNotFound The specified Instance has no purchase. 指定されたインスタンスは購入できません。
400 InvalidInstance.UnPaidOrder The specified Instance has unpaid order. 指定されたインスタンスに未払いの注文があります。続行する前にお支払いを完了してください。
400 InvalidClientToken.ValueNotSupported The ClientToken provided is invalid. 指定された ClientToken は無効です。
400 Account.Arrearage Your account has been in arrears. アカウント残高が不足しています。続行する前にアカウントに入金してください。
400 Idempotence.SignatureMismatch There is a idempotence signature mismatch between this and last request. 前のリクエストと同じ冪等性パラメーターを持つリクエストであるため、他のすべてのパラメーターも完全に一致している必要があります。
400 OrderCreationFailed Order creation failed. Please check your parameters and try again later.
400 Throttling Request was denied due to request throttling. Please try again after 5 minutes.
400 InstanceDowngrade.QuotaExceed Quota of instance downgrade is exceed. インスタンスのスペックダウンクォータを超過しています。この操作は実行できません。
400 InvalidInstanceId.NotFound The specified InstanceId does not exist.
400 InvalidDisk.DetachedSystemDisk The specified disk is a detached system disk. This operation is not supported.
400 LastOrderProcessing The previous order is still processing. Please try again later. 注文は処理中です。後でもう一度お試しください。
400 InvalidAction.WithActiveElasticUpgrade The instance has active Elastic Upgrade.
400 DISK_IN_DEDICATED_BLOCK_STORAGE_CLUSTER The disk in dedicated block storage cluster is not allowed to do this operation.
400 NoPermission.Price The operation requires price permission. Please either apply for permission from your main account or set the parameter AutoPay to true.
400 NoPermission.Refund The operation requires refund permission. Please apply for permission from your main account. アカウントに払い戻しを実行する権限がありません。プライマリアカウントから払い戻し関連の権限を付与される必要があります。
400 InvalidOperation.DiskMustAttachedToInstance The specified data disks must have been attached to this instance. 指定されたディスクは、すでにこのインスタンスにアタッチされている必要があります。
400 InstanceExpiredOrInArrears The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode). インスタンスが有効期限切れになっているか、支払い遅延が発生しています。この操作を実行する前に、インスタンスを更新するか、支払い遅延を解消してください。
400 InvalidOrder.Overdue The specified account has overdue orders. 未払いの請求があるため、購入できません。まず未払いの請求をお支払いいただき、その後でもう一度お試しください。
400 IncorrectInstanceStatus The current status of the instance does not support this operation. 現在のインスタンスステータスでは、この操作はサポートされていません。
400 InvalidOperation.RenewDowngradeNotEffective The current instance has a renewal downgrade record that has not yet taken effect. 現在のインスタンスには、まだ効果が現れていない更新およびスペックダウンの保留 Record があります。
500 InternalError The request processing has failed due to some unknown error.
403 InvalidInstanceType.ValueNotSupported The specified InstanceType is not supported.
403 InvalidAccountStatus.NotEnoughBalance Your account does not have enough balance.
403 Throttling Request was denied due to request throttling. Please try again after 5 minutes.
403 InvalidInstanceChargeType.NotFound The chargeType of the instance does not support this operation. 指定されたインスタンスの支払い方法が存在しません。
403 InvalidOperation.MultiAttachDisk Multi attach disk does not support this operation. マルチアタッチが有効なディスクでは、この操作はサポートされていません。
403 InvalidOperation.UnpaidOrder The specified instance has unpaid orders and does not support the current operation. 指定されたインスタンスに未払いの注文があります。現在の操作はサポートされていません。
403 OperationDenied The specified InstanceType or Zone is not available or not authorized. 指定されたスナップショットでは、データボリュームの作成が許可されていません。
403 IncorrectDiskStatus The operation is not supported in this status. 現在のディスクでは、この操作はサポートされていません。ディスクが正常に使用されており、支払い遅延がないことを確認してください。
404 InvalidRegionId.NotFound The RegionId provided does not exist. 指定された RegionId は存在しません。このリージョンでプロダクトが利用可能かどうかを確認してください。
404 PaymentMethodNotFound No billing method has been registered on the account. アカウントに支払い方法が登録されていません。
404 InvalidZoneId.NotFound The ZoneId provided does not exist in our records.
404 InvalidRamRole.NotFound The specified parameter "RAMRoleName" does not exist. 指定された RAM ロール名が存在しません。
404 InvalidDiskIds.NotFound Some of the specified data disks do not exist. 指定されたディスクは存在しません。
404 InvalidDiskIds.NotPortable The specified DiskId is not portable.
404 InvalidDataDiskSize.ValueNotSupported The specified parameter "Size" is not supported.
404 InvalidAction.NotSupported The specified action is not supported. 指定された API オペレーションはサポートされていません。
404 InvalidInstanceStatus.NotSupported The status of the specified instance is invalid. インスタンスの現在のステータスでは、この操作はサポートされていません。
404 InvalidInstanceId.NOT_FOUND The specified instance is not exist. 指定されたインスタンスが存在しません。
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。