ローカルイメージファイルを Elastic Compute Service (ECS) にカスタムイメージとしてインポートし、指定されたリージョンに表示します。インポートしたイメージを使用して、ECS インスタンスの作成 (RunInstances) やインスタンスのシステムディスクの置き換え (ReplaceSystemDisk) を実行できます。
操作説明
操作の説明。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:ImportImage |
update |
*Image。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
必須 |
ソースカスタムイメージのリージョン ID。 DescribeRegions を呼び出して最新のリージョンリストをクエリできます。 |
cn-hangzhou。 |
| ImageName |
string |
任意 |
イメージ名。名前は 2~128 文字である必要があります。英字または漢字で始まる必要があり、 |
ImageTestName。 |
| Description |
string |
任意 |
イメージの説明。説明は 2~256 文字である必要があり、 |
TestDescription。 |
| Architecture |
string |
任意 |
システムアーキテクチャー。有効な値: |
x86_64 |
| OSType |
string |
任意 |
オペレーティングシステムタイプ。有効な値: |
linux。 |
| Platform |
string |
任意 |
オペレーティングシステムのディストリビューション。有効な値: |
Aliyun。 |
| BootMode |
string |
任意 |
イメージのブートモード。有効な値: |
BIOS。 |
| RoleName |
string |
任意 |
イメージのインポートに使用する RAM ロールの名前。 |
AliyunECSImageImportDefaultRole。 |
| LicenseType |
string |
任意 |
ライセンスタイプ。このパラメーターは、このイメージを使用して RunInstances を呼び出しインスタンスを作成する際の権限付与モードを指定します。この値は Windows Server イメージに対してのみ効果があります。有効な値: |
BYOL。 |
| ResourceGroupId |
string |
任意 |
インポートされたイメージが属するエンタープライズリソースグループの ID。 |
rg-bp67acfmxazb4p**** |
| DiskDeviceMapping |
array<object> |
任意 |
作成するカスタムイメージの情報リスト。 |
|
|
object |
任意 |
作成するカスタムイメージの情報リスト。 |
||
| DiskImSize |
integer |
任意 |
カスタムイメージのサイズ。単位: GiB。 |
80 |
| Device |
string |
任意 |
カスタムイメージ内の DiskDeviceMapping.N.Device のデバイス名。 |
null。 |
| OSSBucket |
string |
任意 |
イメージファイルが保存されている OSS バケット。 |
ecsimageos |
| Format |
string |
任意 |
イメージ形式。有効な値: |
QCOW2 |
| OSSObject |
string |
任意 |
イメージが OSS にアップロードされた後、OSS バケットに保存されるイメージファイルの名前 (キー)。 |
CentOS_5.4_32.raw。 |
| DiskImageSize |
integer |
任意 |
イメージのインポート後のカスタムイメージのディスク領域サイズ。 |
80 |
| Tag |
array<object> |
任意 |
イメージのタグリスト。 |
|
|
object |
任意 |
イメージのタグリスト。 |
||
| Key |
string |
任意 |
イメージのタグキー。N の有効値: 1~20。タグキーを空文字列にすることはできません。タグキーの長さは最大 128 文字で、 |
TestKey。 |
| Value |
string |
任意 |
イメージのタグ値。N の有効値: 1~20。タグ値は空文字列でも構いません。タグ値の長さは最大 128 文字で、 |
TestValue。 |
| DetectionStrategy |
string |
任意 |
イメージ検出戦略。このパラメーターが指定されていない場合、検出はトリガーされません。標準検出モードのみサポートされています。 |
標準 |
| StorageLocationArn |
string |
任意 |
CloudBox の Amazon リソースネーム (ARN)。クラウドストレージの場所を一意に識別します。 |
arn:acs:cloudbox:cn-hangzhou:123456:cloudbox/cb-xx***123 |
| DryRun |
boolean |
任意 |
ドライランのみを実行するかどうかを指定します。有効な値: |
false。 |
| Features |
object |
任意 |
イメージ特徴関連のプロパティ。 |
|
| NvmeSupport |
string |
任意 |
イメージが NVMe をサポートするかどうかを指定します。 |
supported。 |
| ImdsSupport |
string |
任意 |
イメージのメタデータアクセスモード。有効な値: |
v2 |
| ClientToken |
string |
任意 |
リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認してください。ClientToken 値には ASCII 文字のみを含めることができ、長さは 64 文字を超えることはできません。詳細については、「べき等性を確保する方法」をご参照ください。 |
123e4567-e89b-12d3-a456-426655440000 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| RequestId |
string |
リクエスト ID |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3**** |
| ImageId |
string |
イメージ ID |
m-bp67acfmxazb4p**** |
| TaskId |
string |
イメージのインポートタスクの ID。 |
t-bp67acfmxazb4p**** |
| RegionId |
string |
リージョン ID。 |
cn-hangzhou。 |
例
成功レスポンス
JSONJSON
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3****",
"ImageId": "m-bp67acfmxazb4p****",
"TaskId": "t-bp67acfmxazb4p****",
"RegionId": "cn-hangzhou。"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | UnsupportedSuffix.OSSObject | The specified OSS object suffix is not supported. | 指定された OSS オブジェクトのサフィックスはサポートされていません。 |
| 400 | MissingParameter | An input parameter "RegionId" that is mandatory for processing the request is not supplied. | |
| 400 | InvalidImageName.Malformed | The specified Image name is wrongly formed. | 指定されたイメージ名の形式が無効です。長さは 2 ~ 128 文字で、先頭は大文字または小文字の英字、または漢字である必要があります。後続の文字には、数字、"."、"_"、"-" を使うことができます。 |
| 400 | InvalidOSSObject.Malformed | The specified OSS object is wrongly formed. | 指定された OSS オブジェクトが無効です。 |
| 400 | InvalidOSSBucket.Malformed | The specified OSS bucket is wrongly formed. | |
| 400 | InvalidOSSObject.Size | The specified OSS object size is zero. | 指定された OSSObject が空です。 |
| 400 | InvalidDescription.Malformed | The specified Image description is wrongly formed. | 指定された description パラメーターが無効です。 |
| 400 | InvalidArchitecture.Malformed | The specified Architecture is wrongly formed. | 指定された Architecture パラメーターが無効です。このパラメーターのフォーマットが正しいかどうかを確認してください。 |
| 400 | InvalidPlatform.Malformed | The specified Platform is wrongly formed. | 指定されたプラットフォームが無効です。 |
| 400 | InvalidOSType.Malformed | The specified OSType is wrongly formed. | 形式が無効です。 |
| 400 | InvalidImageName.Duplicated | The destination image is exist. | |
| 400 | InvalidImageSize | %s | イメージサイズが要件を満たしていません。 |
| 400 | InvalidDataDiskSize | The specified DiskDeviceMapping.N.DiskImSize should be in the specified range. | 指定された DiskDeviceMapping.N.DiskImSize が有効値の範囲外です。 |
| 400 | InvalidImageFormat.Malformed | The specified Image Format is wrongly formed. | 指定されたイメージの初期化フォームが無効です。有効な形式を指定してください。 |
| 400 | InvalidRegionId.NotFound | The specified RegionId does not exist. | |
| 400 | InvalidRegion.NotSupport | The specified region does not support image import or export. | このリージョンでは Bring Your Own Key (BYOK) はサポートされていません。 |
| 400 | InvalidOSSBucket.NotFound | The specified OSS bucket does not exist in this region. | 指定されたバケットが存在しません。 |
| 400 | InvalidOSSObject.NotFound | The specified OSS object does not exist in this region. | |
| 400 | InvalidOSSObject.NeedRestore | The specified OSS object is a archive object, need restore first. | |
| 400 | InvalidOSSBucket.NotMatched | The specified OSS bucket is incorrect, %s. | 指定された OSS バケットが無効です。詳細については、返された実際のエラーメッセージを参照してください。 |
| 400 | InvalidLicenseType.NotSupported | The specified LicenseType is not supported. | |
| 400 | InvalidLicenseType.BYOLOnly | Only BYOL LicenseType is supported for the current platform provided. | |
| 400 | InvalidOSSBucket.FlowLimit | %s | |
| 400 | InvalidImageFormat.RegionNotSupported | The specified image format is not supported in current region. | |
| 400 | InvalidBootMode.Malformed | The specified parameter "BootMode" is malformed. | |
| 400 | InvalidParameter.DetectionStrategy | The specified parameter DetectionStrategy is invalid. | |
| 400 | InvalidBootMode.NotSupport | The specified parameter BootMode is not supported for current image architecture. | 現在のイメージアーキテクチャでは、このブートモードの設定はサポートされていません。 |
| 400 | DRYRUN.SUCCESS | This request is a dryrun request with successful result. | このリクエストは DryRun リクエスト (シミュレーション実行) です。このエラーコードは、リクエストが検証に合格したことを示します。 |
| 400 | InvalidClientToken.Malformed | The specified parameter clientToken is not valid. | 指定された ClientToken パラメーターが形式要件を満たしていません。パラメーターには ASCII 文字のみを含める必要があり、長さは 64 文字を超えることはできません。 |
| 400 | InvalidParameter.FeaturesImdsSupport | The specified parameter Features.ImdsSupport is not supported. | 指定された Features.ImdsSupport パラメーターはサポートされていません。 |
| 400 | Account.Arrearage | Your account has an outstanding payment. | アカウントに未払いがあります。 |
| 403 | ImageIsImporting | The specified Image is importing. | |
| 403 | QuotaExceed.Image | The Image Quota exceeds. | |
| 403 | ImportImageFailed | Importing image is failed, Please contact the administrator. | イメージのインポートに失敗しました。トラブルシューティングについてはシステム管理者にお問い合わせください。 |
| 403 | UserNotInTheWhiteList | The user is not in the white list of importing image. | |
| 403 | NoSetRoletoECSServiceAcount | ECS service account Have no right to access your OSS.please attach a role of access your oss to ECS service account. | |
| 403 | InvalidParameter.Malformed | The specified parameter "DiskDeviceMapping.n.Device " is not valid. | |
| 403 | MissingParameter.DiskDeviceMapping | The specified parameter DiskDeviceMapping is not supplied. | DiskDeviceMapping パラメーターを空にすることはできません。 |
| 403 | InvalidOSS.NotAuthorized | The specified OSS bucket or object is not allowed to access. | 指定された OSS バケットおよびオブジェクトにアクセスする権限がありません。 |
| 403 | InvalidBlockSize.NotSupport | %s | イメージファイルのパーティションサイズはサポートされていません。 |
| 403 | InvalidImageFormat.Malformed | %s | |
| 403 | ImageCheckUnsupported.WindowsImage | Image check is unsupported for windows image. | |
| 403 | InvalidVHDImage.IncorrectSize | The specified size of the VHD image does not meet the 'header.MaxTableEntries * header.BlockSize' specification. | 指定された VHD イメージのサイズが 'ヘッダー.MaxTableEntries * ヘッダー.BlockSize' の形式に準拠していません。 |
| 403 | InvalidOSSBucket.EncryptUnsupported | Accessing objects from encrypted OSS bucket is not supported. | 暗号化する OSS バケットからのオブジェクトの読み取りはサポートされていません。 |
| 403 | InvalidArchitecture.PlatformUnsupported | The OS platform you selected does not support the specified architecture. | 選択したオペレーティングシステムプラットフォームは、指定されたアーキテクチャタイプをサポートしていません。 |
| 403 | InvalidAccountStatus.OSSDisabled | OSS is disabled due to invalid account status. | アカウントのステータスが無効なため、OSS が無効化されています。 |
| 403 | InvalidStorageLocation.NotFound | The specified cloud box storage location %s could not be found. | 指定された CloudBox ストレージロケーションが見つかりません。 |
| 403 | InvalidOperation.CloudBoxImageImportRoleRequired | The role for cloud box image import is not set to the ECS service. | CloudBox イメージをインポートするためのロールが ECS サービスに割り当てられていません。 |
| 403 | InvalidOperation.CloudBoxImageImportUnsupported | Importing cloud box images is not supported. | CloudBox イメージのインポートはサポートされていません。 |
| 403 | TagKey.Duplication | The TagKey has duplication with others, case-insensitive. | 指定された Tag.N.Key パラメーターに重複する値が含まれています。このパラメーターの値は大文字と小文字が区別されません。重複するパラメーター値が指定されていないか確認してください。 |
| 404 | InvalidResourceGroup.NotFound | The ResourceGroup provided does not exist in our records. | 対応するリソースグループが見つかりません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。