ECS インスタンスにパブリック IP アドレスを割り当てます。パブリック IP アドレスを割り当てるには、ModifyInstanceNetworkSpec オペレーションを呼び出します。
操作説明
開始前に
-
パブリック IP アドレスを割り当てる前に、インスタンスが 実行中 (
Running) または 停止済み (Stopped) の状態である必要があります。 -
セキュリティ上の理由 でロック済みのインスタンスの
OperationLocksに"LockReason" : "security"が含まれている場合、そのインスタンスにパブリック IP アドレスを割り当てることはできません。 -
このオペレーションを呼び出す前に、インスタンスのパブリック帯域幅が 0 より大きいことを確認してください。帯域幅を調整するには、 ModifyInstanceNetworkSpec オペレーションを呼び出せます。
注意事項
-
ホワイトリストに登録されたユーザーのみが
IpAddressパラメーターを使用してパブリック IP アドレスを指定できます。パブリック帯域幅が 0 より大きい場合、InstanceIdをセットしてランダムなパブリック IP アドレスを割り当てることができます。パブリック帯域幅が 0 の場合は、このオペレーションを呼び出してパブリック IP アドレスを割り当てる前に、 ModifyInstanceNetworkSpec オペレーションを呼び出して帯域幅を調整してください。 -
インスタンスに割り当てられるパブリック IP アドレスは 1 つだけです。インスタンスにすでにパブリック IP アドレスがある場合、既存の関連付けられたパブリック IP アドレス
IpAddressが返されます。 -
新しいパブリック IP アドレスは、インスタンスの再起動 ( RebootInstance ) またはインスタンスの起動 ( StartInstance ) 後に効果が適用されます。
パブリック IP アドレスの割り当てに加えて、VPC に接続された ECS インスタンスに Elastic IP Address (EIP) を関連付けることもできます。詳細については、 AssociateEipAddress を参照してください。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:AllocatePublicIpAddress |
create |
*Instance。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| InstanceId |
string |
必須 |
パブリック IP アドレスを割り当てるインスタンスの ID。 説明
インスタンスのパブリック帯域幅は 0 より大きい必要があります。 |
i-bp1gtjxuuvwj17zr**** |
| IpAddress |
string |
任意 |
インスタンスのパブリック IP アドレス。このパラメーターが空の場合、システムはランダムに IP アドレスを割り当てます。 説明
ホワイトリストに登録されたユーザーのみがこのパラメーターを指定できます。一般ユーザーは IP アドレスを指定できません。 |
112.124.**.** |
| VlanId |
string |
任意 |
インスタンスの VLAN ID。 説明
このパラメーターは非推奨となります。互換性を高めるため、他のパラメーターを使用してください。 |
720 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| IpAddress |
string |
インスタンスのパブリック IP アドレス。 |
112.124.**.** |
| RequestId |
string |
リクエスト ID |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E |
例
成功レスポンス
JSONJSON
{
"IpAddress": "112.124.**.**",
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidOperation.AllocateFailed | The current instance failed to allocate public IP, please try again later. | |
| 400 | InvalidIpAddress.Malformed | The specified parameter "IpAddress" is not valid. | |
| 400 | OperationDenied | Specified operation is denied as your instance is in VPC. | 指定された EIP は利用できないか、権限が付与されていません。 |
| 400 | InsufficientPublicIp | Ip address not found. | |
| 400 | AllocateIpInvalidInstanceBandwidth | OperationDenied The InternetMaxBandwidthOut of the specified instance cannot be less than 0. | 現在の操作は無効です。最大アウトバウンド帯域幅が 0 より大きいことを確認してください。 |
| 400 | OperationDenied.CloudboxNotSupport | This operation is denied, because the specified ECS instance which is in the Cloudbox dose not support PublicIp or Eip. | |
| 400 | OperationDenied.DedicatedRegionNotSupported | This operation is denied, because the specified ECS instance which is in the dedicated region dose not support PublicIp or Eip. | この API オペレーションは専用クラウドではサポートされていません。 |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 500 | InvalidOperation.AllocateIpFailed | Failed to allocate the specific IP, please ensure the IP is available. | 指定された IP アドレスの割り当てに失敗しました。IP アドレスが利用可能であることを確認してください。 |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | InstanceLockedForSecurity | The specified operation is denied as your instance is locked for security reasons. | インスタンスはセキュリティ上の理由によりロック済みです。テクニカルサポートにお問い合わせください。 |
| 403 | InstanceExpiredOrInArrears | The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode). | |
| 403 | IpInUse | The specified IP is already in use. | 指定された IP アドレスは、すでに別のインスタンスで使用されています。 |
| 403 | AllocatedAlready | There is an IpAddress allocated already for the specified instance. | 指定された IP アドレスでインスタンスをバインドしようとしましたが、インスタンスにはすでに別の IP アドレスが割り当てられています。 |
| 403 | AllocateIp.Fail | The specified instance fails to allocate ip, please try again. | |
| 403 | NAT_PUBLIC_IP_BINDING_FAILED | Binding nat public ip failed. | |
| 403 | NAT_PUBLIC_IP_ALLOCATE_FAILED | Nat public ip binding failed. | パブリック IP アドレスのバインドに失敗しました。 |
| 403 | InvalidIpAddress.NotPublic | The specified IP is not public address. | |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | 指定されたインスタンス ID が無効です。 |
| 404 | InvalidVlanId.NotFound | The VlanId provided does not exist in our records. | 指定された仮想ローカルエリアネットワーク ID が存在しません。 |
| 404 | InvalidIpAddress.NotFound | The specified IP is not in the specified vlan. | 指定された IP アドレスはリリース済みです。 |
| 409 | OperationConflict | Request was denied due to conflict with a previous request,please try again later. | リクエストされたリソースが以前のリクエストと競合しています。 |
| 409 | TokenProcessing | The previous token request is still processing. Please try again later. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。