すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:ModifyInstanceNetworkSpec

最終更新日:Sep 02, 2026

ECS インスタンスの帯域幅構成を変更し、パブリック IP アドレスを割り当てるか、ネットワークの課金メソッドを変換します。スペックアップとスペックダウンの両方がサポートされています。

操作説明

  • サブスクリプション (PrePaid) インスタンスの帯域幅構成を変更し、アウトバウンドパブリック帯域幅 (InternetMaxBandwidthOut) が 0 Mbit/s から 0 以外の値にスペックアップされる場合、パブリック IP アドレスが自動的に割り当てられます。

  • 従量課金 (PostPaid) インスタンスの帯域幅構成を変更し、アウトバウンドパブリック帯域幅 (InternetMaxBandwidthOut) が 0 Mbit/s から 0 以外の値にスペックアップされる場合、パブリック IP アドレスは自動的に割り当てられません。パブリック IP アドレスを割り当てるには、AllocatePublicIp パラメーターを true に設定します。

説明

単一のリージョンにおいて、単一の Alibaba Cloud アカウントに対する帯域幅課金のインターネットパブリック帯域幅の合計ピーク値には制限があります。詳細については、「パブリック帯域幅の制限」を参照してください。

  • 料金:

    • 帯域幅のスペックアップ後、デフォルトで料金が自動的に差し引かれます。支払方法に十分な残高があることを確認してください。残高が不足している場合、異常な注文が生成され、その注文を無効にすることしかできません。アカウント残高が不足している場合は、AutoPay パラメーターを false に設定します。通常の未払い注文が生成され、ECS コンソールにログインして支払いを完了できます。

    • 帯域幅のスペックダウン後、差額は元の支払方法に返金されます。使用済みのバウチャーは返金されません。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:ModifyInstanceNetworkSpec

update

*Instance

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

  • ecs:AssociatePublicIpAddress
なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

InstanceId

string

必須

ネットワーク構成を変更するインスタンスの ID。

i-bp67acfmxazb4****

InternetMaxBandwidthOut

integer

任意

アウトバウンドパブリック帯域幅の最大値。単位: Mbit/s (メガビット/秒)。有効な値:

  • トラフィック課金: 0~100。

  • 帯域幅課金:

    • サブスクリプションインスタンス: 0~200。

    • 従量課金インスタンス: 0~100。

説明

単一インスタンスのアウトバウンド帯域幅の最大値は、ECS インスタンスタイプの ネットワーク帯域幅ベースライン/バースト (Gbit/s) メトリックによっても制限されます。詳細については、「インスタンスファミリー」を参照してください。

10

InternetMaxBandwidthIn

integer

任意

インバウンドパブリック帯域幅の最大値。単位: Mbit/s (メガビット/秒)。有効な値:

  • 購入したアウトバウンドパブリック帯域幅が 10 Mbit/s 以下の場合: 1~10。デフォルト値: 10。

  • 購入したアウトバウンドパブリック帯域幅が 10 Mbit/s より大きい場合: 1~InternetMaxBandwidthOut の値。デフォルト値: InternetMaxBandwidthOut の値。

10

ISP

string

任意

説明

このパラメーターは招待プレビュー中であり、一般公開されていません。

null

NetworkChargeType

string

任意

ネットワークの課金メソッドを変換します。有効な値:

  • PayByBandwidth: 帯域幅課金。

  • PayByTraffic: トラフィック課金。

説明

トラフィック課金 モードでは、インバウンドおよびアウトバウンドの帯域幅ピーク値はいずれも上限値であり、保証されません。リソース競合が発生した場合、帯域幅ピーク値がスロットリングされる可能性があります。ワークロードに保証された帯域幅が必要な場合は、帯域幅課金 モードを使用してください。

PayByTraffic

AllocatePublicIp

boolean

任意

パブリック IP アドレスを割り当てるかどうかを指定します。有効な値:

  • true: パブリック IP アドレスが割り当てられます。

  • false: パブリック IP アドレスは割り当てられません。

デフォルト値: false。

false

StartTime

string

任意

一時的な帯域幅スペックアップの開始時刻。時刻は ISO 8601 標準の yyyy-MM-ddTHH:mmZ 形式で初期化します。時刻は協定世界時 (UTC)+0 でなければなりません。値は 分 (mm) 単位で正確です。

2017-12-05T22:40Z

EndTime

string

任意

一時的な帯域幅スペックアップの終了時刻。時刻は ISO 8601 標準の yyyy-MM-ddTHHZ 形式で初期化します。時刻は協定世界時 (UTC)+0 でなければなりません。値は 時間 (HH) 単位で正確です。

説明

一時的な帯域幅スペックアップの終了時刻と開始時刻の間隔は 3 時間以上である必要があります。

2017-12-06T22Z

AutoPay

boolean

任意

支払いを自動的に完了するかどうかを指定します。有効な値:

  • true: 帯域幅構成の変更後、支払いが自動的に完了されます。アカウント残高が十分であることを確認してください。残高が不足している場合、異常な注文が生成されます。この注文に対して ECS コンソールで支払いを行うことはできません。注文を無効にすることしかできません。

  • false: 帯域幅構成の変更後、注文は生成されますが支払いは完了されません。支払方法の残高が不足している場合は、Autopay パラメーターを false にセットして自動支払いをキャンセルします。この場合、通常の未払い注文が生成されます。ECS コンソール にログインして支払いを完了できます。

デフォルト値: true。

true

ClientToken

string

任意

リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認してください。ClientToken の値には ASCII 文字のみを含めることができ、長さは 64 文字を超えることはできません。詳細については、「べき等性を確保する方法」を参照してください。

123e4567-e89b-12d3-a456-426655440000

レスポンスフィールド

フィールド

型

説明

例

object

OrderId

string

注文 ID。このパラメーターは、サブスクリプション (PrePaid) インスタンスの帯域幅構成を変更した場合にのみ返されます。

123457890

RequestId

string

リクエスト ID

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

例

成功レスポンス

JSONJSON

{
  "OrderId": "123457890",
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidInternetMaxBandwidthIn.ValueNotSupported The specified InternetMaxBandwidthIn is beyond the permitted range. 指定された InternetMaxBandwidthIn パラメーターがインターネットの最大値を超えています。
400 InvalidInternetMaxBandwidthOut.ValueNotSupported The specified InternetMaxBandwidthOut is beyond the permitted range. 指定された仮想マシンの帯域幅が有効ではありません。
400 OperationDenied Specified instance is in VPC. 指定されたスナップショットではデータボリュームの作成が許可されていません。
400 InvalidParameter.Conflict %s パラメーターが競合しています。
400 InvalidStartTime.ValueNotSupported The specified StartTime is out of the permitted range.
400 InvalidEndTime.ValueNotSupported The specified EndTime is out of the permitted range.
400 ChargeTypeViolation The operation is not permitted due to billing method of the instance. 支払い方法がこの操作をサポートしていません。インスタンスの支払い方法がこの操作と競合していないか確認してください。
400 Account.Arrearage Your account has an outstanding payment. アカウント残高が不足しています。続行する前にアカウントにチャージしてください。
400 InvalidInternetChargeType.ValueNotSupported The specified InternetChargeType is invalid. 指定されたネットワーク課金メソッドが無効です。
400 DecreasedBandwidthNotAllowed %s 帯域幅のスペックダウンは許可されていません。
400 BandwidthUpgradeDenied.EipBoundInstance The specified VPC instance has bound EIP, temporary bandwidth upgrade is denied. 指定された VPC インスタンスはすでに EIP に関連付けられています。
400 InvalidClientToken.ValueNotSupported The ClientToken provided is invalid. 指定された ClientToken が無効です。
400 Throttling Request was denied due to request throttling, please try again after 5 minutes. リクエストがスロットルされました。
400 InvalidInstanceStatus.NotStopped The specified Instance status is not Stopped.
400 InvalidAction Specified action is not valid. 操作は有効ではありません。
400 IpAllocationError Allocate public ip failed. パブリック IP アドレスの割り当てに失敗しました。
400 InvalidParam.AllocatePublicIp The specified param AllocatePublicIp is invalid. 指定された AllocatePublicIp が無効です。
400 InstanceDowngrade.QuotaExceed Quota of instance downgrade is exceed. インスタンスのスペックダウンクォータを超えました。この操作は実行できません。
400 InvalidBandwidth.ValueNotSupported Instance upgrade bandwidth of temporary not allow less then existed. 指定された帯域幅の値はサポートされていません。
400 InvalidInstanceStatus The specified instance status does not support this action. インスタンスの現在のステータスでは、この操作はサポートされていません。
400 InvalidInstance.UnPaidOrder Unpaid order exists in your account, please complete or cancel the payment in the expense center. 指定されたインスタンスに未払いの注文があります。続行する前に支払いを完了してください。
400 LastOrderProcessing The previous order is still processing, please try again later. 注文がプロセス中です。後でもう一度お試しください。
400 LastRequestProcessing The previous request is still processing, please try again later.
400 InvalidStartTime.BeyondLifeCycle The specified start time exceeds the expiration time. 指定された StartTime がリソースの有効期限より後の時間です。
400 InvalidEndTime.BeyondLifeCycle The specified end time exceeds the expiration time. EndTime パラメーターがリソースのライフサイクルを超えています。
400 InvalidPayMethod.SyncPaymentNotSupport Synchronous payment is not supported. Use another payment method.
400 InvalidBandwidthOut.LessThanZero The bandwidth must be larger than 0 when specifying isp.
400 InvalidParameter.BandwidthBiggerThanBaseBandwidth %s
400 InvalidAction.WithActiveElasticUpgrade The instance has active Elastic Upgrade.
400 InvalidParameter.CloudboxNotSupported %s
400 InvalidParameter.Bandwidth %s 帯域幅パラメーターが有効ではありません。
400 NoPermission.Price The operation requires price permission. Please either apply for permission from your main account, or set the parameter AutoPay as true. この操作には課金に関する権限が必要です。プライマリアカウントから権限を付与するか、AutoPay パラメーターを true に設定して自動支払いを行ってください。
400 NoPermission.Refund The operation requires refund permission. Please apply for permission from your main account. このアカウントには返金を実行する権限がありません。プライマリアカウントが返金関連のフォームを付与する必要があります。
400 InvalidParameter.DedicatedRegionNotSupported The specified action is rejected because the specified ECS instance in the dedicated region does not support public IP. 専用クラウドではこのパラメーターは有効ではありません。
400 InvalidOperation.InstanceStatusUnsupported The specified instance status is not supported for this operation, expect status is Running or Stopped. 現在のインスタンスステータスでは、CPU トポロジータイプの変更はサポートされていません。
400 QuotaExceeded.InternetBandwidth %s. アカウント内の従量課金 ECS インスタンスの帯域幅課金パブリック帯域幅が、合計帯域幅クォータ制限を超えています。
400 UnsupportedIspNetworkChargeType The network charge type is not supported when specifying ISP. このインスタンスのネットワーク課金タイプでは ISP の指定はサポートされていません。
400 IncorrectInstanceStatus Current instance status does not support this operation. 現在のインスタンスステータスでは、この操作はサポートされていません。
400 TaskConflict The operation is too frequent, please wait a moment and try again. EIP の操作が頻繁すぎます。
400 InvalidOperation.InternetMaxBandwidthOutUnsupported The InternetMaxBandwidthOut is not allowed to modify. アカウントで支払い遅延が発生しているため、アウトバウンドパブリック帯域幅の最大値を変更できません。
500 InternalError The request processing has failed due to some unknown error.
500 Image.OrderFailed Create marketplace image order failed. Alibaba Cloud マーケットプレイスの注文作成に失敗しました。
403 IncorrectInstanceStatus The current status of the instance does not support this operation.
403 InstanceLockedForSecurity The specified operation is denied as your instance is locked for security reasons. ディスクがアタッチされているインスタンスが、セキュリティ上の理由によりロック済みです。
403 InstanceExpiredOrInArrears The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode).
403 ChargeTypeViolation The operation is not permitted due to billing method of the instance.
403 OperationDenied The operation is denied due to the instance is PrePaid. 指定されたスナップショットではデータボリュームの作成が許可されていません。
403 InvalidAccountStatus.NotEnoughBalance Your account does not have enough balance.
403 InvalidInstance.UnPaidOrder The specified Instance has unpaid order.
403 Throttling Request was denied due to request throttling, please try again after 5 minutes.
403 InvalidInstance.InstanceNotSupported The special vpc instance with eip not need bandwidth. EIP に関連付けられている VPC タイプのインスタンスには、パブリック帯域幅を指定する必要はありません。
403 InstanceDowngrade.QuotaExceed Quota of instance downgrade is exceed.
403 InvalidInstanceStatus The current status of the instance does not support this operation. インスタンスの現在のステータスでは、この操作はサポートされていません。
403 InvalidOperation.StarterPackage StarterPackage not support modification.
403 NAT_PUBLIC_IP_BINDING_FAILED Binding nat public ip failed.
403 InvalidInstance.EipNotSupport The specified instance with eip is not supported, please unassociate eip first. EIP に関連付けられているインスタンスでは、この操作はサポートされていません。先に EIP の関連付けを解除してください。
403 InvalidInstance.NatPortMapNotSupport The special instance with nat port map not support operate, please remove nat port map first.
403 OperationDenied.UnpaidOrder The specified instance has unpaid order. 指定されたインスタンス ID に対して未払いの注文がすでに存在します。ECS コンソールにログインして支払いを完了できます。
403 Mayi.InternalError The request processing has failed due to some unknown error.
403 InvalidNetworkType.ValueNotSupported The specified parameter NetworkType is not valid.
403 OperationDenied.ImageNotValid The specified marketplace image is not authorized. Please verify the marketplace image authorization and try again.
403 InvalidInstanceChargeType.ValueNotSupported The specified parameter ChargeType is not valid. 指定されたインスタンスの支払い方法が存在しません。
403 InvalidIspType.ValueNotSupported %s
403 UnsupportedIspChargeType %s 指定された支払い方法では Isp パラメーターがサポートされていません。
403 UnsupportedIspClassicNetwork %s
403 InvalidIspBandwidthOut %s
403 UnsupportedChangeIsp %s
403 InvalidIspUID %s
403 UnsupportedIspRegion %s
403 BandIncreaseNotSupportIsp %s ISP インスタンスは一時的な帯域幅のスペックアップをサポートしていません。
403 SecurityRisk.3DVerification We have detected a security risk with your default credit or debit card. Please proceed with verification via the link in your email. デフォルトのクレジットカードまたはデビットカードでセキュリティリスクが検出されました。メール内のリンクを使用して ID を確認してください。
403 InvalidOperation.PublicIpAddressNoStock The public IP address for the specified Region or ChargeType of the instance is out of stock. Please try another Region or ChargeType. 指定されたリージョンまたは支払い方法に対するパブリック IP アドレスの在庫が不足しています。別のリージョンまたは支払い方法をお試しください。
403 InvalidOperation.NetworkTypeUnsupported The specified network type is not supported in this region. 指定されたネットワークタイプはこのリージョンではサポートされていません。
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。
409 OperationConflict Request was denied due to conflict with a previous request,please try again later. リクエストの競合が発生しました。しばらく待ってから再試行するか、チケットを提出してください。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。