すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:Db2 for LUW から ApsaraDB RDS for MySQL への同期

最終更新日:Aug 27, 2026

Data Transmission Service (DTS) を使用すると、Db2 for LUW データベースから ApsaraDB RDS for MySQL インスタンスへデータを同期できます。

前提条件

  • ターゲットの ApsaraDB RDS for MySQL インスタンスが作成済みであること。詳細については、「ApsaraDB RDS for MySQL インスタンスの作成」をご参照ください。

  • 完全同期を実行する場合、ターゲットデータベースのストレージ容量は、ソースデータベースの使用容量より大きい必要があります。

Limitations

Limit type

Description

Limits on the source database

  • The server that hosts the source database must have sufficient outbound bandwidth. Otherwise, the data synchronization speed decreases.

  • The tables to be synchronized must have PRIMARY KEY or UNIQUE constraints, and all fields must be unique. Otherwise, the destination database may contain duplicate data records.

  • If you select tables as the objects to be synchronized and you want to modify the tables in the destination database, such as renaming tables or columns, you can synchronize up to 5,000 tables in a single task. If you synchronize more than 5,000 tables, a request error occurs. In this case, we recommend that you split the tables across multiple tasks or synchronize the entire database.

  • The data logging feature must be enabled. Otherwise, error messages are returned during precheck, and the data synchronization task cannot be started.

    説明

    If you perform only incremental data synchronization, the data logs of the source database must be retained for more than 24 hours. If you perform both full and incremental data synchronization, the data logs must be retained for at least seven days. Otherwise, DTS may fail to obtain the data logs and the task may fail. In exceptional circumstances, data inconsistency or loss may occur. After full data synchronization is complete, you can set the retention period to more than 24 hours. Make sure that you set the retention period based on these requirements. Otherwise, the service reliability or performance stated in the SLA of DTS cannot be guaranteed.

  • During schema synchronization and full data synchronization, do not perform DDL operations that change the database or table schema. Otherwise, the data synchronization instance fails.

Other limits

  • DTS synchronizes incremental data from a Db2 for LUW database to the destination database based on the CDC replication technology of Db2 for LUW. The CDC replication technology has its own limits. For more information, see General data restrictions for SQL Replication.

  • Evaluate the impact of data synchronization on the performance of the source and destination databases before you start. We recommend that you synchronize data during off-peak hours. During initial full data synchronization, DTS uses read and write resources of the source and destination databases, which may increase the load on the database servers.

  • During initial full data synchronization, concurrent INSERT operations cause fragmentation in the destination tables. After full data synchronization is complete, the used tablespace of the destination database is larger than that of the source database.

  • If your data includes four-byte characters—such as rare Chinese characters or emojis—the destination database and table must use the utf8mb4 charset.

    説明

    If you use DTS to synchronize table schemas, set the character_set_server parameter at the instance level in the destination database to utf8mb4.

  • During data synchronization, we recommend that you use only DTS to write data to the destination database to prevent data inconsistency. After data synchronization is complete, you can use DMS to execute DDL statements online. For more information, see Perform lock-free DDL operations.

  • If DDL statements fail to be executed in the destination database, the data synchronization task continues to run. You can view the DDL statements that fail to be executed in the task logs. For more information about how to view the task logs, see View task logs.

  • If you write columns with names that differ only in case to the same table in the destination MySQL database, unexpected results may occur because MySQL column names are case-insensitive.

  • After data synchronization completes (the instance's [ステータス] is [完了]), you should use the ANALYZE TABLE <table_name> command to confirm that all data is written to the target table. For example, after the HA failover mechanism is triggered in the target MySQL database, data might be written only to memory, which can cause data loss.

  • If a task fails, DTS support staff will attempt to restore it within eight hours. During restoration, they may restart the task or adjust its parameters.

    説明

    Only DTS task parameters are modified—not database parameters. Parameters that may be adjusted include those listed in Modify instance parameters.

Special cases

The source Db2 for LUW database is a self-managed database. When you synchronize data from the Db2 for LUW database, note the following items:

  • If you perform a primary/secondary switchover on the source database while the data synchronization task is running, the task fails.

  • DTS calculates synchronization latency based on the timestamp of the latest synchronized data record in the destination database and the current timestamp in the source database. If no DML operation is performed on the source database for a long time, the synchronization latency may be inaccurate. If the synchronization latency is too high, you can perform a DML operation on the source database to update the latency.

    説明

    If you select an entire database as the object to be synchronized, you can create a heartbeat table. The heartbeat table is updated or receives data every second.

課金

同期タイプ

料金

全量データ同期

無料

増分データ同期

有料。詳細は課金概要をご参照ください。

対応同期トポロジー

  • 1 対 1 の一方向同期

  • 1 対多の一方向同期

  • カスケード一方向同期

  • 多対 1 の一方向同期

同期トポロジーとその考慮事項の詳細については、「データ同期トポロジー」をご参照ください。

サポート対象の SQL 操作

操作タイプ

SQL ステートメント

DML

INSERT, UPDATE, DELETE

準備

操作手順

  1. 宛先リージョンの同期タスクリストページに移動します。次の 2 つの方法のいずれかを使用できます。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソールにログインします。

    2. 左側のナビゲーションペインで、データ同期 をクリックします。

    3. ページの左上隅で、同期インスタンスがあるリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードとレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。

    1. Data Management (DMS) にログインします。

    2. 上部のメニューで、[Data + AI] > [Data Transmission (DTS)] > [データ同期] を選択します。

    3. データ同期タスク の右側で、同期インスタンスがあるリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページを開きます。

  3. オプション: ページの右上隅にある 新バージョンの設定ページを試してみる をクリックします。

    説明
    • 右上隅のボタンが 旧バージョンの設定ページに戻る の場合、この手順をスキップできます。

    • 新旧の設定ページではパラメータが異なります。新しい設定ページを使用することを推奨します。

  4. ソースデータベースと宛先データベースを設定します。

    セクション

    パラメータ

    説明

    該当なし

    [タスク名]

    DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    [移行元データベース]

    既存の接続情報の選択

    • システムに登録済みのデータベースインスタンス (新規作成または保存済み) を使用するには、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目は DMS データベースインスタンスの選択 という名前です。

    • データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、次のデータベース情報を手動で設定します。

    [データベースタイプ]

    DB2 for LUW を選択します。

    [接続タイプ]

    ソースデータベースのデプロイ場所に基づいて値を選択します。このトピックでは、ECS 上の自己管理データベース を例として使用します。

    説明

    ソースインスタンスが自己管理データベースの場合は、必要な準備も完了する必要があります。詳細については、「自己管理データベースへの接続の準備」をご参照ください。

    [インスタンスリージョン]

    Db2 for LUW データベースがあるリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントのデータベースインスタンスを使用します。× を選択します。

    ECS インスタンス ID

    Db2 for LUW データベースをホストする ECS インスタンスの ID を入力します。

    ポート

    Db2 for LUW データベースのサービスポートを入力します。デフォルト値は 50000 です。

    データベース名

    ソース Db2 for LUW インスタンス内の、同期対象のオブジェクトを含むデータベースの名前を入力します。

    [データベースアカウント]

    Db2 for LUW データベースのデータベースアカウントを入力します。権限要件については、「アカウントの作成と権限の付与」をご参照ください。

    [データベースパスワード]

    データベースアカウントに対応するパスワードを入力します。

    [移行先データベース]

    既存の接続情報の選択

    • システムに登録済みのデータベースインスタンス (新規作成または保存済み) を使用するには、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目は DMS データベースインスタンスの選択 という名前です。

    • データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、次のデータベース情報を手動で設定します。

    [データベースタイプ]

    MySQL を選択します。

    [接続タイプ]

    Alibaba Cloud インスタンス を選択します。

    [インスタンスリージョン]

    宛先 ApsaraDB RDS for MySQL インスタンスがあるリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントのデータベースインスタンスを使用します。× を選択します。

    RDS インスタンス ID

    宛先 ApsaraDB RDS for MySQL インスタンスの ID を選択します。

    [データベースアカウント]

    宛先 ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。権限要件については、「アカウントの作成と権限の付与」をご参照ください。

    [データベースパスワード]

    データベースアカウントに対応するパスワードを入力します。

    [接続方法]

    必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合は、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にする必要があります。詳細については、「クラウド証明書を使用して SSL 暗号化を迅速に有効化」をご参照ください。

  5. 設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。DTS サーバーの CIDR ブロック ダイアログボックスで、接続テスト をクリックします。

    説明

    DTS サーバーからのアクセスを許可するために、DTS サーバーの IP アドレス CIDR ブロックがソースデータベースと宛先データベースのセキュリティ設定に追加されていることを確認してください。これは自動または手動で実行できます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。

  6. タスクオブジェクトを設定します。

    1. オブジェクト設定 ページで、同期するオブジェクトを設定します。

      パラメータ

      説明

      同期タイプ

      同期タイプです。デフォルトでは、[増分データ同期] が選択されています。[スキーマ同期] と [完全データ同期] も選択する必要があります。事前チェックの完了後、DTS は選択したオブジェクトの履歴データをソースデータベースから宛先クラスターに同期します。履歴データは、その後の増分同期の基礎となります。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告: DTS は宛先データベース内で同じ名前のテーブルをチェックします。競合が存在する場合、DTS は事前チェック中にエラーを報告し、タスクを開始しません。

        説明

        競合するテーブルを削除または名前変更することが現実的でない場合は、テーブルを別の名前にマッピングできます。詳細については、「オブジェクト名のマッピング」をご参照ください。

      • エラーを無視して続行: 宛先データベース内の同じ名前のテーブルのチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生する可能性があります。例:

        • テーブルスキーマが一致している場合、ソースレコードと同じプライマリキーまたは一意キーを持つ宛先レコードは上書きされます。

        • テーブルスキーマが一致していない場合、タスクが失敗するか、データの一部のみが同期される可能性があります。慎重に操作してください。

      ソースオブジェクト

      ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動します。

      説明

      同期オブジェクトとして、データベース、テーブル、および列を選択できます。テーブルまたは列を選択した場合、ビュー、トリガー、ストアドプロシージャなどの他のオブジェクトは宛先データベースに同期されません。

      選択中のオブジェクト

      説明
      • データベースまたはテーブルレベルで同期する SQL 操作を選択するには、選択中のオブジェクト ボックス内のオブジェクトを右クリックし、ダイアログボックスで目的の SQL 操作を選択します。

      • WHERE 句を設定してデータをフィルタリングするには、選択中のオブジェクト ボックス内のテーブルを右クリックし、ダイアログボックスでフィルター条件を設定します。手順については、「フィルター条件の設定」をご参照ください。

    2. 詳細設定へ をクリックして、詳細パラメータを設定します。

      パラメータ

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジュールするため、クラスターを選択する必要はありません。より安定したパフォーマンスを得るために、DTS 同期タスクを実行する専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      失敗した接続の再試行時間

      同期タスクの開始後、ソースデータベースまたは宛先データベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続を再試行します。デフォルトの再試行時間は 720 分です。10 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースに正常に再接続できた場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。

      説明
      • 同じソースまたは宛先を共有する複数の DTS インスタンス (例: インスタンス A とインスタンス B) があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中のタスク実行時間に対して課金するため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースデータベースインスタンスと宛先データベースインスタンスがリリースされた後、できるだけ早く DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスクの開始後、ソースデータベースまたは宛先データベースで接続以外の問題 (DDL または DML 実行例外など) が発生した場合、DTS はエラーを報告し、直ちに再試行を継続します。デフォルトの再試行時間は 10 分です。1 分から 1,440 分の範囲で再試行時間をカスタマイズすることもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連する操作が成功した場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値よりも小さい必要があります。

      完全同期レートを制限するかどうか

      完全同期段階では、DTS はソースデータベースと宛先データベースの読み取りおよび書き込みリソースを消費し、データベースの負荷を増加させる可能性があります。ソースデータベースと宛先データベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメータを設定することで、完全同期タスクのレートを制限できます。

      説明
      • この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ使用できます。

      • 同期インスタンスの実行後に、完全同期レートを調整することもできます。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限を設定することもできます。宛先データベースへの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定します。

      環境タグ

      インスタンスを識別するために環境タグを選択できます。この例では必須ではありません。

      ETL 機能の設定

      抽出、変換、ロード (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効な値:

      監視アラート

      アラートを設定するかどうかを指定します。同期が失敗した場合、または遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

      • ×: アラートは設定されません。

      • ○: アラートしきい値を設定し、アラート通知を指定してアラートを設定します。詳細については、「タスク設定中の監視とアラートの設定」をご参照ください。

    3. [次へ: データ検証] をクリックして、データ検証タスクを設定します。

      データ検証機能を使用する場合は、設定手順について「データ検証の設定」をご参照ください。

  7. タスクを保存して事前チェックを実行します。

    • このインスタンスを設定するための API パラメータを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、吹き出し内の OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメータの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期タスクが開始される前に、DTS は事前チェックを実行します。すべての事前チェック項目に合格した後にのみ、タスクを開始できます。

    • 事前チェックが失敗した場合は、失敗した項目の 詳細を表示 をクリックします。プロンプトに従って問題を修正し、事前チェックを再度実行します。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、事前チェックを再度実行します。

      • 無視できるチェック項目については、アラートの詳細を確認、無視、OK、再度事前チェックを実行 の順にクリックして、警告をスキップして事前チェックを再実行できます。警告項目を無視することを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  8. インスタンスを購入します。

    1. 成功率 が 100% になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法とリンク仕様を選択します。パラメータの詳細は次の表を参照してください。

      カテゴリ

      パラメータ

      説明

      [新しいインスタンスクラス]

      [課金方法]

      • サブスクリプション: インスタンスの作成時にお支払いいただきます。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。

      • 従量課金: 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースして、コストを節約できます。

      [リソースグループ設定]

      インスタンスが属するリソースグループ。デフォルトはデフォルトリソースグループです。詳細については、「リソース管理とは」をご参照ください。

      [リンク仕様]

      DTS は、異なるパフォーマンスレベルの同期仕様を提供します。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      [サブスクリプション期間]

      サブスクリプションモードでは、サブスクリプションインスタンスの期間と数量を選択します。1 か月から 9 か月までの月額サブスクリプション、または 1 年、2 年、3 年、5 年の年額サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ使用できます。

    3. 設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、選択します。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、[OK] をクリックします。

      データ同期ページでタスクの進行状況を確認できます。