Data Transmission Service (DTS) を使用すると、Db2 for LUW データベースから ApsaraDB RDS for MySQL インスタンスへデータを同期できます。
前提条件
ターゲットの ApsaraDB RDS for MySQL インスタンスが作成済みであること。詳細については、「ApsaraDB RDS for MySQL インスタンスの作成」をご参照ください。
完全同期を実行する場合、ターゲットデータベースのストレージ容量は、ソースデータベースの使用容量より大きい必要があります。
Limitations
Limit type | Description |
Limits on the source database |
|
Other limits |
|
Special cases | The source Db2 for LUW database is a self-managed database. When you synchronize data from the Db2 for LUW database, note the following items:
|
課金
同期タイプ | 料金 |
全量データ同期 | 無料 |
増分データ同期 | 有料。詳細は課金概要をご参照ください。 |
対応同期トポロジー
1 対 1 の一方向同期
1 対多の一方向同期
カスケード一方向同期
多対 1 の一方向同期
同期トポロジーとその考慮事項の詳細については、「データ同期トポロジー」をご参照ください。
サポート対象の SQL 操作
操作タイプ | SQL ステートメント |
DML | INSERT, UPDATE, DELETE |
準備
アカウントの作成と権限の付与
データベース
必要な権限
参考
Db2 for LUW
DBADM 権限
ApsaraDB RDS for MySQL
移行先データベース内の同期オブジェクトに対する読み取りおよび書き込み権限
Db2 for LUW データベースのログアーカイブ機能を有効にします。詳細については、「logarchmeth1 - Primary log archive method configuration parameter」および「logarchmeth2 - Secondary log archive method configuration parameter」をご参照ください。
操作手順
宛先リージョンの同期タスクリストページに移動します。次の 2 つの方法のいずれかを使用できます。
DTS コンソールから
左側のナビゲーションペインで、データ同期 をクリックします。
ページの左上隅で、同期インスタンスがあるリージョンを選択します。
DMS コンソールから
説明実際の操作は、DMS コンソールのモードとレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。
Data Management (DMS) にログインします。
上部のメニューで、 を選択します。
データ同期タスク の右側で、同期インスタンスがあるリージョンを選択します。
タスクの作成 をクリックして、タスク設定ページを開きます。
オプション: ページの右上隅にある 新バージョンの設定ページを試してみる をクリックします。
説明右上隅のボタンが 旧バージョンの設定ページに戻る の場合、この手順をスキップできます。
新旧の設定ページではパラメータが異なります。新しい設定ページを使用することを推奨します。
ソースデータベースと宛先データベースを設定します。
セクション
パラメータ
説明
該当なし
[タスク名]
DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。
[移行元データベース]
既存の接続情報の選択
システムに登録済みのデータベースインスタンス (新規作成または保存済み) を使用するには、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。
説明DMS コンソールでは、この設定項目は DMS データベースインスタンスの選択 という名前です。
データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、次のデータベース情報を手動で設定します。
[データベースタイプ]
DB2 for LUW を選択します。
[接続タイプ]
ソースデータベースのデプロイ場所に基づいて値を選択します。このトピックでは、ECS 上の自己管理データベース を例として使用します。
説明ソースインスタンスが自己管理データベースの場合は、必要な準備も完了する必要があります。詳細については、「自己管理データベースへの接続の準備」をご参照ください。
[インスタンスリージョン]
Db2 for LUW データベースがあるリージョンを選択します。
Alibaba Cloud アカウント間でデータを複製
この例では、現在の Alibaba Cloud アカウントのデータベースインスタンスを使用します。× を選択します。
ECS インスタンス ID
Db2 for LUW データベースをホストする ECS インスタンスの ID を入力します。
ポート
Db2 for LUW データベースのサービスポートを入力します。デフォルト値は 50000 です。
データベース名
ソース Db2 for LUW インスタンス内の、同期対象のオブジェクトを含むデータベースの名前を入力します。
[データベースアカウント]
Db2 for LUW データベースのデータベースアカウントを入力します。権限要件については、「アカウントの作成と権限の付与」をご参照ください。
[データベースパスワード]
データベースアカウントに対応するパスワードを入力します。
[移行先データベース]
既存の接続情報の選択
システムに登録済みのデータベースインスタンス (新規作成または保存済み) を使用するには、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。
説明DMS コンソールでは、この設定項目は DMS データベースインスタンスの選択 という名前です。
データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、次のデータベース情報を手動で設定します。
[データベースタイプ]
MySQL を選択します。
[接続タイプ]
Alibaba Cloud インスタンス を選択します。
[インスタンスリージョン]
宛先 ApsaraDB RDS for MySQL インスタンスがあるリージョンを選択します。
Alibaba Cloud アカウント間でデータを複製
この例では、現在の Alibaba Cloud アカウントのデータベースインスタンスを使用します。× を選択します。
RDS インスタンス ID
宛先 ApsaraDB RDS for MySQL インスタンスの ID を選択します。
[データベースアカウント]
宛先 ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。権限要件については、「アカウントの作成と権限の付与」をご参照ください。
[データベースパスワード]
データベースアカウントに対応するパスワードを入力します。
[接続方法]
必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合は、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にする必要があります。詳細については、「クラウド証明書を使用して SSL 暗号化を迅速に有効化」をご参照ください。
設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。DTS サーバーの CIDR ブロック ダイアログボックスで、接続テスト をクリックします。
説明DTS サーバーからのアクセスを許可するために、DTS サーバーの IP アドレス CIDR ブロックがソースデータベースと宛先データベースのセキュリティ設定に追加されていることを確認してください。これは自動または手動で実行できます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。
タスクオブジェクトを設定します。
オブジェクト設定 ページで、同期するオブジェクトを設定します。
パラメータ
説明
同期タイプ
同期タイプです。デフォルトでは、[増分データ同期] が選択されています。[スキーマ同期] と [完全データ同期] も選択する必要があります。事前チェックの完了後、DTS は選択したオブジェクトの履歴データをソースデータベースから宛先クラスターに同期します。履歴データは、その後の増分同期の基礎となります。
競合するテーブルの処理モード
エラーの事前チェックと報告: DTS は宛先データベース内で同じ名前のテーブルをチェックします。競合が存在する場合、DTS は事前チェック中にエラーを報告し、タスクを開始しません。
説明競合するテーブルを削除または名前変更することが現実的でない場合は、テーブルを別の名前にマッピングできます。詳細については、「オブジェクト名のマッピング」をご参照ください。
エラーを無視して続行: 宛先データベース内の同じ名前のテーブルのチェックをスキップします。
警告エラーを無視して続行 を選択すると、データの不整合が発生する可能性があります。例:
テーブルスキーマが一致している場合、ソースレコードと同じプライマリキーまたは一意キーを持つ宛先レコードは上書きされます。
テーブルスキーマが一致していない場合、タスクが失敗するか、データの一部のみが同期される可能性があります。慎重に操作してください。
ソースオブジェクト
ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、
をクリックして 選択中のオブジェクト ボックスに移動します。説明同期オブジェクトとして、データベース、テーブル、および列を選択できます。テーブルまたは列を選択した場合、ビュー、トリガー、ストアドプロシージャなどの他のオブジェクトは宛先データベースに同期されません。
選択中のオブジェクト
宛先インスタンス内のオブジェクトの名前を変更するには、選択中のオブジェクト ボックス内の同期オブジェクトを右クリックします。設定手順については、「単一のスキーマ、テーブル、または列名のマッピング」をご参照ください。
宛先インスタンス内の複数のオブジェクトの名前を一度に変更するには、選択中のオブジェクト ボックスの右上隅にある 一括編集 をクリックします。設定手順については、「スキーマ、テーブル、および列名の一括マッピング」をご参照ください。
説明データベースまたはテーブルレベルで同期する SQL 操作を選択するには、選択中のオブジェクト ボックス内のオブジェクトを右クリックし、ダイアログボックスで目的の SQL 操作を選択します。
WHERE 句を設定してデータをフィルタリングするには、選択中のオブジェクト ボックス内のテーブルを右クリックし、ダイアログボックスでフィルター条件を設定します。手順については、「フィルター条件の設定」をご参照ください。
詳細設定へ をクリックして、詳細パラメータを設定します。
パラメータ
説明
タスクのスケジュールに使用する専用クラスターの選択
デフォルトでは、DTS は共有クラスター上でタスクをスケジュールするため、クラスターを選択する必要はありません。より安定したパフォーマンスを得るために、DTS 同期タスクを実行する専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。
失敗した接続の再試行時間
同期タスクの開始後、ソースデータベースまたは宛先データベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続を再試行します。デフォルトの再試行時間は 720 分です。10 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースに正常に再接続できた場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。
説明同じソースまたは宛先を共有する複数の DTS インスタンス (例: インスタンス A とインスタンス B) があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。
DTS は接続再試行期間中のタスク実行時間に対して課金するため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースデータベースインスタンスと宛先データベースインスタンスがリリースされた後、できるだけ早く DTS インスタンスをリリースすることを推奨します。
移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。
同期タスクの開始後、ソースデータベースまたは宛先データベースで接続以外の問題 (DDL または DML 実行例外など) が発生した場合、DTS はエラーを報告し、直ちに再試行を継続します。デフォルトの再試行時間は 10 分です。1 分から 1,440 分の範囲で再試行時間をカスタマイズすることもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連する操作が成功した場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。
重要移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値よりも小さい必要があります。
完全同期レートを制限するかどうか
完全同期段階では、DTS はソースデータベースと宛先データベースの読み取りおよび書き込みリソースを消費し、データベースの負荷を増加させる可能性があります。ソースデータベースと宛先データベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメータを設定することで、完全同期タスクのレートを制限できます。
説明この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ使用できます。
同期インスタンスの実行後に、完全同期レートを調整することもできます。
増分同期率を制限するかどうか
増分同期タスクのレート制限を設定することもできます。宛先データベースへの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定します。
環境タグ
インスタンスを識別するために環境タグを選択できます。この例では必須ではありません。
ETL 機能の設定
抽出、変換、ロード (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効な値:
○: ETL 機能を有効にします。コードエディタでデータ処理ステートメントを入力します。詳細については、「データ移行またはデータ同期タスクでの ETL の設定」をご参照ください。
×: ETL 機能を無効にします。
監視アラート
アラートを設定するかどうかを指定します。同期が失敗した場合、または遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。
×: アラートは設定されません。
○: アラートしきい値を設定し、アラート通知を指定してアラートを設定します。詳細については、「タスク設定中の監視とアラートの設定」をご参照ください。
[次へ: データ検証] をクリックして、データ検証タスクを設定します。
データ検証機能を使用する場合は、設定手順について「データ検証の設定」をご参照ください。
タスクを保存して事前チェックを実行します。
このインスタンスを設定するための API パラメータを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、吹き出し内の OpenAPI パラメーターのプレビュー をクリックします。
API パラメータの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。
説明同期タスクが開始される前に、DTS は事前チェックを実行します。すべての事前チェック項目に合格した後にのみ、タスクを開始できます。
事前チェックが失敗した場合は、失敗した項目の 詳細を表示 をクリックします。プロンプトに従って問題を修正し、事前チェックを再度実行します。
事前チェックで警告が返された場合:
チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、事前チェックを再度実行します。
無視できるチェック項目については、アラートの詳細を確認、無視、OK、再度事前チェックを実行 の順にクリックして、警告をスキップして事前チェックを再実行できます。警告項目を無視することを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。
インスタンスを購入します。
成功率 が 100% になったら、次:インスタンスの購入 をクリックします。
購入 ページで、データ同期インスタンスの課金方法とリンク仕様を選択します。パラメータの詳細は次の表を参照してください。
カテゴリ
パラメータ
説明
[新しいインスタンスクラス]
[課金方法]
サブスクリプション: インスタンスの作成時にお支払いいただきます。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。
従量課金: 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースして、コストを節約できます。
[リソースグループ設定]
インスタンスが属するリソースグループ。デフォルトはデフォルトリソースグループです。詳細については、「リソース管理とは」をご参照ください。
[リンク仕様]
DTS は、異なるパフォーマンスレベルの同期仕様を提供します。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。
[サブスクリプション期間]
サブスクリプションモードでは、サブスクリプションインスタンスの期間と数量を選択します。1 か月から 9 か月までの月額サブスクリプション、または 1 年、2 年、3 年、5 年の年額サブスクリプションを選択できます。
説明このオプションは、課金方法が サブスクリプション の場合にのみ使用できます。
設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、選択します。
購入して起動 をクリックします。OK ダイアログボックスで、[OK] をクリックします。
データ同期ページでタスクの進行状況を確認できます。