Data Transmission Service (DTS) を使用すると、Db2 for LUW データベースから PolarDB for MySQL クラスターへデータを同期できます。
前提条件
-
ソースの Db2 for LUW データベースおよびターゲットの PolarDB for MySQL クラスターが作成済みである必要があります。サポートされているバージョンについては、「同期ソリューションの概要」をご参照ください。
-
ターゲットデータベースのストレージ容量は、ソースデータベースよりも大きくする必要があります。
注意事項
スキーマ同期中に、DTS はソースデータベースの外部キーをターゲットデータベースに同期します。
完全データ同期および増分データ同期中、DTS はセッションレベルで制約チェックおよび外部キーのカスケード操作を一時的に無効化します。同期タスク実行中にソースデータベースでカスケード更新または削除操作を実行すると、データの不整合が発生する可能性があります。
|
制限タイプ |
説明 |
|
ソースデータベースの制限 |
|
|
その他の制限 |
|
|
特殊なケース |
ソースの Db2 for LUW データベースは自己管理データベースです。Db2 for LUW データベースからデータを同期する際は、以下の点にご注意ください。
|
課金
|
同期タイプ |
料金 |
|
スキーマ同期および完全データ同期 |
無料です。 |
|
増分データ同期 |
課金対象です。詳細については、「課金概要」をご参照ください。 |
サポートされる同期トポロジ
-
一方向 1 対 1 同期
-
一方向 1 対多同期
-
一方向カスケード同期
-
一方向多対 1 同期
詳細については、「同期トポロジ」をご参照ください。
サポートされる SQL 操作
|
操作タイプ |
SQL 操作 |
|
DML |
INSERT、UPDATE、DELETE |
事前準備
-
データベースアカウントを作成し、必要な権限を付与します。
データベース
必要な権限
権限付与方法
Db2 for LUW
DBADM 権限
ターゲット PolarDB for MySQL クラスター
ターゲットデータベースに対する読み取りおよび書き込み権限
「データベースアカウントの作成と管理」をご参照ください。
-
Db2 for LUW データベースのログアーカイブ機能を有効にします。詳細については、「logarchmeth1 - Primary log archive method configuration parameter」および「logarchmeth2 - Secondary log archive method configuration parameter」をご参照ください。
操作手順
-
ターゲットリージョンの同期タスクリストページに移動します。次の 2 つの方法のいずれかを使用できます。
DTS コンソールから
-
左側のナビゲーションウィンドウで、データ同期 をクリックします。
-
ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。
DMS コンソールから
説明実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。
-
Data Management (DMS) にログインします。
-
上部のメニューバーで、 を選択します。
-
データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。
-
タスクの作成 をクリックして、タスク設定ページを開きます。
-
オプション: ページ右上隅で、新バージョンの設定ページを試してみる をクリックします。
説明-
右上隅のボタンが 旧バージョンの設定ページに戻る の場合は、この手順をスキップできます。
-
新しい設定ページと古い設定ページではパラメーターが異なります。新しい設定ページの使用を推奨します。
-
-
ソースおよびターゲットデータベースを設定します。
セクション
パラメーター
説明
該当なし
タスク名
DTS が自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。
ソースデータベース
データベースタイプ
DB2 for LUW を選択します。
アクセス方法
Express Connect、VPN Gateway、または Smart Access Gateway を選択します。
インスタンスリージョン
Db2 for LUW データベースが配置されているリージョンを選択します。
Alibaba Cloud アカウント間でデータを複製
同一アカウント内でデータを同期する場合は、× を選択します。
ソースデータベースに接続されているVPC
Db2 for LUW データベースが接続されている VPC ID を選択します。
IP アドレス
Db2 for LUW データベースのサーバー IP アドレスを入力します。
ポート番号
Db2 for LUW データベースのサービスポート番号を入力します。デフォルト:50000。
データベース名
同期対象のオブジェクトを含むソースデータベースの名前を入力します。
データベースアカウント
Db2 for LUW インスタンスのデータベースアカウントを入力します。必要な権限については、「事前準備」をご参照ください。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
宛先データベース
データベースタイプ
PolarDB for MySQL を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスリージョン
ターゲットの PolarDB for MySQL クラスターが配置されているリージョンを選択します。
PolarDB クラスター ID
ターゲットの PolarDB for MySQL クラスターの ID を選択します。
データベースアカウント
ターゲットの PolarDB for MySQL インスタンスのデータベースアカウントを入力します。必要な権限については、「事前準備」をご参照ください。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
暗号化
要件に基づいてオプションを選択します。詳細については、「SSL 暗号化の設定」をご参照ください。
-
設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。DTS サーバーの CIDR ブロック ダイアログボックスで、接続テスト をクリックします。
説明DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加する必要があります。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加する」をご参照ください。
-
タスクオブジェクトを設定します。
-
オブジェクト設定 ページで、同期するオブジェクトを設定します。
パラメーター
説明
同期タイプ
同期タイプです。デフォルトでは、増分データ同期 が選択されています。スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェックが完了すると、DTS は選択したオブジェクトの既存データをソースデータベースからターゲットクラスターに同期します。既存データは、その後の増分同期の基礎となります。
競合テーブルの処理モード
-
エラーの事前チェックと報告:ターゲットデータベースに同名のテーブルが存在するかどうかをチェックします。同名のテーブルが存在しない場合、事前チェックは成功します。同名のテーブルが存在する場合、事前チェックは失敗し、データ同期タスクは開始されません。
説明ターゲットデータベースで同名のテーブルを削除または名前変更できない場合は、別のテーブル名にマッピングできます。詳細については、「テーブル名およびカラム名のマッピング」をご参照ください。
-
エラーを無視して続行:ターゲットデータベースでの重複テーブル名のチェックをスキップします。
警告エラーを無視して続行 を選択すると、データの不整合が発生し、ビジネスにリスクが及ぶ可能性があります。例:
-
テーブルスキーマが同じで、ターゲットデータベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:
-
完全同期中、DTS はターゲットクラスターのレコードを保持します。ソースデータベースの対応するレコードは同期されません。
-
増分同期中、ソースデータベースのレコードがターゲットデータベースのレコードを上書きします。
-
-
テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。これにより、一部のカラムデータのみが同期されるか、同期が完全に失敗する可能性があります。慎重に操作してください。
-
宛先インスタンスでのオブジェクト名の大文字化
ターゲットインスタンスに同期されるデータベース、テーブル、カラムオブジェクト名の大文字・小文字の区別ポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよびターゲットデータベースのデフォルトポリシーを使用することもできます。詳細については、「ターゲットオブジェクト名の大文字・小文字の区別ポリシー」をご参照ください。
ソースオブジェクト
ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、
をクリックして 選択中のオブジェクト ボックスに移動させます。説明同期オブジェクトとしてデータベース、テーブル、カラムを選択できます。テーブルまたはカラムを選択した場合、ビュー、トリガー、ストアドプロシージャなどの他のオブジェクトはターゲットデータベースに同期されません。
[選択済みオブジェクト]
-
ターゲットインスタンスで単一の同期オブジェクトの名前を変更するには、選択中のオブジェクト ボックスでオブジェクトを右クリックします。オブジェクトの名前変更に関する詳細については、「単一のデータベース、テーブル、またはカラムのマッピング」をご参照ください。
-
ターゲットインスタンスで複数の同期オブジェクトの名前を一括で変更するには、選択中のオブジェクト ボックスの右上隅で 一括編集 をクリックします。詳細については、「データベース、テーブル、およびカラムの一括マッピング」をご参照ください。
説明-
オブジェクト名のマッピングにより、依存オブジェクトでデータの不整合や同期失敗が発生する可能性があります。たとえば、部分的なテーブル同期または不一致のテーブルスキーマによるカラムマッピングは、不足しているカラムのデータ損失を引き起こす可能性があります。
-
WHERE 句を使用してデータをフィルターするには、選択中のオブジェクト セクションでテーブルを右クリックし、フィルター条件を設定します。手順については、「フィルター条件の設定」をご参照ください。
-
データベースまたはテーブルレベルで増分同期の SQL 操作を選択するには、選択中のオブジェクト セクションでオブジェクトを右クリックし、ダイアログボックスで SQL 操作を選択します。
-
-
詳細設定へ をクリックして、高度なパラメーターを設定します。
パラメーター
説明
タスクのスケジュールに使用する専用クラスターの選択
デフォルトでは、DTS は共有クラスター上でタスクをスケジュールし、クラスターを選択する必要はありません。より安定したパフォーマンスを得るには、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。
移行先データベースのエンジンタイプを選択します。
ターゲットデータベースのストレージエンジンを選択します。
-
InnoDB:デフォルトのストレージエンジンです。
-
X-Engine:OLTP データベースストレージエンジンです。
失敗した接続の再試行時間
同期タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。
説明-
同じソースまたはターゲットを共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。
-
DTS は接続再試行期間中のタスクランタイムに対して課金されるため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後はできるだけ早く DTS インスタンスをリリースすることを推奨します。
移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。
同期タスク開始後、ソースまたはターゲットデータベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 分から 1,440 分の範囲で再試行時間をカスタマイズすることもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。
重要移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。
完全同期レートを制限するかどうか
完全同期フェーズ中、DTS はソースおよびターゲットデータベースの読み取り・書き込みリソースを消費するため、データベースの負荷が増加します。ソースおよびターゲットデータベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。
説明-
この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。
-
同期インスタンス実行後も、完全同期レートを調整 できます。
増分同期率を制限するかどうか
増分同期タスクのレート制限も設定できます。ターゲットデータベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定します。
環境タグ
インスタンスを識別するための環境タグを選択します。この例ではオプションです。
ETL 機能の設定
監視アラート
アラートを設定するかどうかを指定します。同期が失敗した場合や遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。
-
×:アラートは設定されません。
-
○:アラートのしきい値を設定し、アラート通知 を指定してアラートを設定します。詳細については、「タスク設定中のモニタリングとアラートの設定」をご参照ください。
-
-
次へ:データ検証 をクリックして、データ検証タスクを設定します。
データ検証機能を使用する場合は、「データ検証の設定」をご参照のうえ、設定手順に従ってください。
-
-
タスクを保存して事前チェックを実行します。
-
このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されるバルーンで OpenAPI パラメーターのプレビュー をクリックします。
-
API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。
説明-
同期ジョブ開始前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した後にのみ、ジョブを開始できます。
-
事前チェックが失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。表示された指示に従って問題を修正し、再度事前チェックを実行します。
-
事前チェックで警告が返された場合:
-
チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行します。
-
無視可能なチェック項目については、アラートの詳細を確認、無視、OK、再度事前チェックを実行 の順にクリックして、警告をスキップし、事前チェックを再実行します。警告項目を非表示にすると、データの不整合などの問題が発生し、ビジネスにリスクが及ぶ可能性があります。
-
-
-
インスタンスを購入します。
-
成功率 が 100% の場合、次:インスタンスの購入 をクリックします。
-
購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表に、これらのパラメーターの詳細を示します。
カテゴリ
パラメーター
説明
新しいインスタンスクラス
課金方法
-
サブスクリプション:インスタンス作成時に支払いを行います。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。
-
従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。
リソースグループ構成
インスタンスが属するリソースグループです。デフォルトは default resource group です。詳細については、「Resource Management とは」をご参照ください。
リンク仕様
DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供します。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。
サブスクリプション期間
サブスクリプションモードの場合、サブスクリプションインスタンスの期間および数量を選択します。1~9 ヶ月の月単位サブスクリプション、または 1、2、3、5 年の年単位サブスクリプションを選択できます。
説明このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。
-
-
設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。
-
購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。
データ同期ページでタスクの進捗状況を確認できます。
-