すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:Alibaba Cloud アカウント間での ApsaraDB RDS for MySQL インスタンスの同期

最終更新日:Jul 18, 2026

Data Transmission Service (DTS) は、異なる Alibaba Cloud アカウント間で ApsaraDB RDS for MySQL インスタンス間のデータ同期をサポートします。このトピックでは、ソースインスタンスとターゲットインスタンスが異なる Alibaba Cloud アカウントに属するデータ同期タスクの作成方法について説明します。

前提条件

  • ソースおよびターゲットの ApsaraDB RDS for MySQL インスタンスを作成済みである必要があります。詳細については、「ApsaraDB RDS for MySQL インスタンスの作成」をご参照ください。

  • ターゲットの ApsaraDB RDS for MySQL インスタンスには、ソースインスタンスで使用されているストレージ容量よりも多くの空きストレージ容量が必要です。

注意事項

  • 初期完全同期中、DTS はソースおよびターゲットデータベースの両方で読み取りおよび書き込みリソースを占有するため、データベースの負荷が増加する可能性があります。データベースのパフォーマンスが低く、仕様が小さく、またはワークロードが重い場合(例:ソースデータベースでのスロー SQL ステートメント、プライマリキーを持たないテーブル、ターゲットデータベースでのデッドロックなど)、負荷がさらに増加し、最悪の場合、データベースサービスが利用できなくなる可能性があります。そのため、データ同期を実行する前に、ソースおよびターゲットデータベースのパフォーマンスを評価してください。オフピーク時間帯(例:ソースおよびターゲットデータベースの CPU 負荷が 30 % 未満の時間帯)にデータ同期を実行することを推奨します。

  • 同期対象のソースデータベース内のテーブルにプライマリキーまたは一意制約がない場合、ターゲットデータベースに重複データが発生する可能性があります。

  • 初期完全同期中、同時実行 INSERT 操作により、ターゲットデータベースのテーブルに断片化が発生します。同期完了後、ターゲットデータベースの表領域はソースデータベースよりも大きくなります。

  • Alibaba Cloud アカウント間でのクロスリージョン同期がサポートされています。現在、Alibaba Cloud アカウント間での双方向同期は、ApsaraDB RDS for MySQL インスタンス間でのみサポートされています。

  • 準備作業が完了した後でのみ、ソースおよびターゲットの Alibaba Cloud アカウントからデータベースインスタンス情報を取得できます。

    重要

    クロスアカウントデータ同期が完了したら、準備中に作成した RAM ロールを削除することを推奨します。

  • ソースデータベースのバイナリログ (binlog):

    • ApsaraDB RDS for MariaDB インスタンスでは、デフォルトでバイナリロギングが有効になっています。binlog_row_image パラメーターが full に設定されていることを確認してください。設定されていない場合、事前チェックでエラーが報告され、データ同期タスクが開始されません。パラメーターの設定方法の詳細については、「インスタンスパラメーターの設定」をご参照ください。

    • DTS のサービスレベル契約 (SLA) は、バイナリログの保持期間が不十分なために発生する問題をカバーしていません。増分データ同期タスクの場合、DTS はソースデータベースのローカルバイナリログを少なくとも 24 時間保持することを要求します。完全および増分データ同期を含むタスクの場合、バイナリログは少なくとも 7 日間保持する必要があります。完全データ同期が完了した後、保持期間を 24 時間以上に変更できます。DTS がバイナリログを取得できない場合、タスクが失敗する可能性があります。極端なケースでは、データの不整合や損失が発生する可能性があります。

  • コメント構文で定義されたリゾルバは、同期使用をサポートしていません。

  • ソースデータベースで一時テーブルモードのオンライン DDL 操作(マルチテーブルマージシナリオなどを含むがこれに限定されない)を使用している場合、または一意キー列に関数ベースインデックスを追加している場合、ターゲットデータベースでデータ損失またはタスク失敗が発生する可能性があります。

  • ターゲット MySQL データベースの同一テーブルに、大文字・小文字のみが異なるカラム名を持つカラムを書き込む場合、MySQL のカラム名は大文字・小文字を区別しないため、予期しない結果が発生する可能性があります。

  • データ同期が完了した後(インスタンスの ステータス が 完了 になった後)、ANALYZE TABLE <table_name> コマンドを使用して、すべてのデータがターゲットテーブルに書き込まれていることを確認してください。たとえば、ターゲット MySQL データベースで HA フェールオーバー機構がトリガーされた後、データがメモリにのみ書き込まれる可能性があり、これが原因でデータ損失が発生することがあります。

  • このトピックで言及する Alibaba Cloud アカウントは、すべてメインアカウントを指します。

  • ソースデータベースのみが別の Alibaba Cloud アカウントに属するデータ同期を実行する場合(ソースデータベースの Alibaba Cloud アカウント間でデータを複製 オプションが ○ に設定されている場合)、ターゲットデータベースインスタンスは DTS タスクを作成するために使用された Alibaba Cloud アカウントに属します。

  • ApsaraDB RDS for MySQL インスタンスで Always-Encrypted が有効になっている場合、完全データ同期はサポートされません。

    説明

    TDE (透過的データ暗号化) が有効になっている ApsaraDB RDS for MySQL インスタンスは、スキーマ同期、完全データ同期、および増分データ同期をサポートします。

  • スキーマ同期および完全データ同期中は、データベースまたはテーブルスキーマを変更する DDL 操作を実行しないでください。実行すると、データ同期インスタンスが失敗します。

  • バイナリログに書き込まれない変更によって生成されたデータ(物理バックアップからの復元データやカスケード操作によって作成されたデータなど)は、ターゲットデータベースに同期されません。

    説明

    このような状況が発生した場合は、影響を受けたデータベースまたはテーブルを同期オブジェクトから削除してから再度追加してください。ただし、これはビジネス要件で許容される場合に限ります。詳細については、「同期オブジェクトの変更」をご参照ください。

  • DTS は、ソースデータベース内で定期的に CREATE DATABASE IF NOT EXISTS `test` コマンドを実行して、バイナリログオフセットを進めます。

  • トランザクションログを記録しない ApsaraDB RDS for MySQL インスタンス(例:ApsaraDB RDS for MySQL 5.6 の読み取り専用インスタンス)は、ソースデータベースとして使用できません。

  • データに四バイト文字(例:まれな漢字や絵文字)が含まれる場合、ターゲットデータベースおよびテーブルは utf8mb4 文字セットを使用する必要があります。

    説明

    DTS を使用してテーブルスキーマを同期する場合、ターゲットデータベースのインスタンスレベルで character_set_server パラメーターを utf8mb4 に設定してください。

  • ソースデータベースからアカウントを同期するには、前提条件を満たし、関連する考慮事項を確認する必要があります。詳細については、「データベースアカウントの移行」をご参照ください。

  • タスクが失敗した場合、DTS サポートスタッフは 8 時間以内に復旧を試みます。復旧中、タスクを再起動したり、パラメーターを調整したりする可能性があります。

    説明

    DTS タスクパラメーターのみが変更され、データベースパラメーターは変更されません。 調整対象となるパラメーターには、「インスタンスパラメーターの変更」に記載されているものが含まれます。

  • 同期対象のカラムに、ソースまたはターゲットデータベースの不可視カラムが含まれていないことを確認してください。含まれている場合、DTS タスクが失敗したり、データが失われたりする可能性があります。

    説明

    ALTER TABLE <table_name> ALTER COLUMN <column_name> SET VISIBLE; ステートメントを使用して、不可視カラムを可視にできます。詳細については、「Invisible Columns」をご参照ください。

同期トポロジ

  • 一方向 1 対 1 同期

  • 一方向 1 対多同期

  • 一方向カスケード同期

  • 一方向多対 1 同期

サポートされている同期トポロジとその使用方法の詳細については、「同期トポロジ」をご参照ください。

サポートされる SQL 操作

操作タイプ

SQL ステートメント

DML

INSERT、UPDATE、DELETE、および REPLACE

DDL

  • ALTER TABLE および ALTER VIEW

  • CREATE FUNCTION、CREATE INDEX、CREATE PROCEDURE、CREATE TABLE、および CREATE VIEW

  • DROP INDEX および DROP TABLE

  • RENAME TABLE

    重要

    RENAME TABLE 操作により、ソースおよびターゲットデータベース間でデータの不整合が発生する可能性があります。たとえば、テーブルを同期オブジェクトとして選択し、データ同期中にそのテーブル名を変更した場合、このテーブルのデータはターゲットデータベースに同期されません。このような状況を回避するには、データ同期タスクを構成する際に、このテーブルが属するデータベース全体を同期オブジェクトとして選択してください。RENAME TABLE 操作の前後で、テーブルが属するデータベースが同期オブジェクトに追加されていることを確認してください。

  • TRUNCATE TABLE

データベースアカウント権限

インスタンス

必要な権限

リファレンス

ソース ApsaraDB RDS for MySQL インスタンス

同期対象オブジェクトに対する読み取り専用権限。

「アカウントおよびデータベースの作成」および「ApsaraDB RDS for MySQL インスタンスの標準アカウント権限の変更」をご参照ください。

ターゲット ApsaraDB RDS for MySQL インスタンス

ターゲットデータベースに対する読み取りおよび書き込み権限。

説明

データベースアカウントも同期する場合、ソースおよびターゲットインスタンスの両方のアカウントに追加の権限が必要です。詳細については、「データベースアカウントの移行」をご参照ください。

制限事項

RENAME TABLE 操作により、ソースインスタンスとターゲットデータベース間でデータの不整合が発生する可能性があります。たとえば、同期範囲にテーブル A のみが含まれており、データ同期中にソースインスタンスがテーブル A の名前をテーブル B に変更した場合、テーブル B はターゲットデータベースに同期されません。この問題を回避するには、データ同期タスクを構成する際に、テーブル A およびテーブル B の両方が含まれるデータベース全体を同期オブジェクトとして選択してください。

課金

同期タイプ

料金

完全データ同期

無料

増分データ同期

課金対象です。「課金概要」をご参照ください。

操作手順

説明

このトピックでは、ソースおよびターゲットデータベースが異なる Alibaba Cloud アカウントに属する場合の同期インスタンスの構成方法を示します。詳細については、「クロス Alibaba Cloud アカウントタスクの RAM 認可の構成方法」をご参照ください。

  1. RAM 認可を構成します。詳細については、「シナリオ 3:ソースおよびターゲットデータベースが異なる Alibaba Cloud アカウントに属する場合」をご参照ください。

  2. DTS タスクを作成するために使用した Alibaba Cloud アカウントで DTS コンソールにログインし、ターゲットリージョンの同期タスクリストページに移動します。次のいずれかの方法を使用できます。

    DTS コンソール

    1. DTS コンソールにログインします。DTS コンソール

    2. 左側のナビゲーションウィンドウで、データ同期 をクリックします。

    3. 左上隅で、同期タスクが存在するリージョンを選択します。

    DMS コンソール

    説明

    実際の手順は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。「シンプルモード」および「DMS コンソールのレイアウトおよびスタイルのカスタマイズ」をご参照ください。

    1. DMS コンソールにログインします。DMS コンソール

    2. 上部ナビゲーションバーで、Data + AI にポインターを合わせ、DTS (DTS) > データ同期 の順に選択します。

    3. データ同期タスク の横にあるドロップダウンリストから、インスタンスが存在するリージョンを選択します。

  3. タスクの作成 をクリックして、タスク構成ページを開きます。

  4. ソースおよびターゲットデータベースを構成します。

    警告

    ソースおよびターゲットインスタンスを選択した後、ページ上部の 制限事項 を確認し、タスクが正常に作成および実行できることを保証してください。

    カテゴリ

    パラメーター

    説明

    該当なし

    タスク名

    DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    ソースデータベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に構成されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、次のデータベース情報を手動で構成します。

    データベースタイプ

    MySQL を選択します。

    接続タイプ

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    ソース RDS for MySQL インスタンスが配置されているリージョンを選択します。

    説明

    ソースおよびターゲット RDS インスタンスは、異なるリージョンに配置できます。

    Alibaba Cloud アカウント間でデータを複製

    ○ を選択します。

    Alibaba Cloud アカウント

    ソースデータベースが属する Alibaba Cloud アカウントの ID を入力します。

    説明

    アカウント ID の取得方法については、「ソースデータベースの Alibaba Cloud アカウント ID の取得」をご参照ください。

    RAM ロール名

    ソースデータベースの Alibaba Cloud アカウントで作成した RAM ロールの名前を入力します(例:ram-for-dts)。RAM ロールの作成方法の詳細については、「RAM ロールの作成」をご参照ください。

    重要

    DTS のデフォルトロールである AliyunDTSDefaultRole は入力しないでください。

    RDS インスタンス ID

    ソース RDS for MySQL インスタンスの ID を選択します。

    説明

    RDS インスタンス ID を選択する際にアラートが表示された場合は、指示に従って設定を変更してください。一般的なアラートについては、「一般的なエラー」をご参照ください。

    データベースアカウント

    ソース RDS for MySQL インスタンスのデータベースアカウントを入力します。

    データベースパスワード

    データベースアカウントのパスワードを入力します。

    暗号化

    ニーズに応じて、非暗号化 または SSL 暗号化 を選択します。この例では、非暗号化 を使用します。

    説明

    SSL 暗号化 を選択する場合は、事前に RDS インスタンスで SSL 暗号化を有効にする必要があります。詳細については、「SSL 暗号化の構成」をご参照ください。

    ターゲットデータベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に構成されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、次のデータベース情報を手動で構成します。

    データベースタイプ

    MySQL を選択します。

    接続タイプ

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    ターゲット RDS for MySQL インスタンスが配置されているリージョンを選択します。

    説明

    ソースおよびターゲット RDS for MySQL インスタンスは、異なるリージョンに配置できます。

    Alibaba Cloud アカウント間でデータを複製

    ○ を選択します。

    Alibaba Cloud アカウント

    ターゲットデータベースが属する Alibaba Cloud アカウントの ID を入力します。

    説明

    アカウント ID の取得方法については、「ターゲットデータベースの Alibaba Cloud アカウント ID の取得」をご参照ください。

    RAM ロール名

    ターゲットデータベースの Alibaba Cloud アカウントで作成した RAM ロールの名前を入力します(例:ram-for-dts)。RAM ロールの作成方法の詳細については、「RAM ロールの作成」をご参照ください。

    重要

    DTS のデフォルトロールである AliyunDTSDefaultRole は入力しないでください。

    RDS インスタンス ID

    ターゲット RDS for MySQL インスタンスの ID を選択します。

    説明

    RDS インスタンス ID を選択する際にアラートが表示された場合は、指示に従って設定を変更してください。一般的なアラートについては、「一般的なエラー」をご参照ください。

    データベースアカウント

    ターゲット RDS for MySQL インスタンスのデータベースアカウントを入力します。

    データベースパスワード

    データベースアカウントのパスワードを入力します。

    暗号化

    ニーズに応じて、非暗号化 または SSL 暗号化 を選択します。この例では、非暗号化 を使用します。

    説明

    SSL 暗号化 を選択する場合は、事前に RDS インスタンスで SSL 暗号化を有効にする必要があります。詳細については、「SSL 暗号化の構成」をご参照ください。

  5. 構成が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明
    • DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加していることを確認してください。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。

    • ソースまたはターゲットデータベースが自己管理データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)の場合、DTS サーバーの CIDR ブロック ダイアログボックスで、接続テスト をクリックする必要があります。

  6. タスクオブジェクトを構成します。

    1. オブジェクト設定 ページで、同期するオブジェクトを構成します。

      パラメーター

      説明

      同期タイプ

      デフォルトで 増分データ同期 が選択されています。スキーマ同期 および 完全データ同期 も選択することを推奨します。事前チェックが完了すると、DTS は選択したオブジェクトの完全データ初期化をターゲットインスタンスで実行します。このデータは、その後の増分データ同期のベースラインとして使用されます。

      移行元データベースのトリガーを移行する方法

      ビジネス要件に基づいて、トリガーの同期方法を選択します。同期対象のオブジェクトにトリガーが含まれない場合は、このパラメーターを構成する必要はありません。詳細については、「トリガーの同期または移行方法の構成」をご参照ください。

      説明

      同期タイプ で スキーマ同期 を選択した場合にのみ、このパラメーターを構成できます。

      移行評価の有効化

      ソースおよびターゲットデータベースのスキーマが要件を満たしているかどうかを評価するかどうかを指定します。評価では、インデックス長、ストアドプロシージャ、テーブル依存関係などの項目をチェックします。ビジネス要件に基づいて、[はい] または [いいえ] を選択できます。[はい] を選択すると、事前チェックに時間がかかる可能性があります。事前チェックフェーズ中に評価結果を確認できます。評価結果は事前チェックの結果に影響しません。

      説明
      • 同期タイプ で スキーマ同期 を選択した場合にのみ、このパラメーターを構成できます。

      • ○ を選択すると、事前チェックに時間がかかる可能性があります。事前チェックフェーズ中に 評価結果 を確認できます。評価結果は事前チェックの結果に影響しません。

      同期トポロジ

      この例では、一方向同期 が選択されています。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:DTS はターゲットデータベース内に同名のテーブルがあるかどうかをチェックします。競合が存在する場合、DTS は事前チェック中にエラーを報告し、タスクを開始しません。

        説明

        競合テーブルを削除または名前変更することが現実的でない場合は、テーブルを別の名前にマッピングできます。詳細については、「オブジェクト名のマッピング」をご参照ください。

      • エラーを無視して続行:ターゲットデータベース内に同名のテーブルがあるかどうかのチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生する可能性があります。たとえば:

        • テーブルスキーマが一致している場合、ソースレコードと同じプライマリキーまたは一意キーを持つターゲットレコードが上書きされます。

        • テーブルスキーマが一致していない場合、タスクが失敗するか、データが部分的にしか同期されない可能性があります。慎重に進めてください。

      イベントを移行するかどうか

      ソースデータベースのイベントを移行するかどうかを選択します。○ を選択すると、追加の手順が必要です。「イベントの同期または移行」をご参照ください。

      移行先インスタンスでのオブジェクト名の大文字化

      ターゲットインスタンスに同期されるデータベース、テーブル、カラムオブジェクト名の大文字・小文字の扱いポリシーを構成できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよびターゲットデータベースのデフォルトポリシーを使用することもできます。詳細については、「ターゲットオブジェクト名の大文字・小文字の扱いポリシー」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      同期オブジェクトとしてデータベース、テーブル、カラムを選択できます。テーブルまたはカラムを選択した場合、ビュー、トリガー、ストアドプロシージャなどの他のオブジェクトはターゲットデータベースに同期されません。

      選択中のオブジェクト

      説明
      • データベースまたはテーブルレベルで同期する SQL 操作を選択するには、選択中のオブジェクト ボックス内のオブジェクトを右クリックし、ダイアログボックスで目的の SQL 操作を選択します。サポートされている操作の一覧については、「サポートされる SQL 操作」をご参照ください。

      • WHERE 句を使用してデータをフィルターするには、選択中のオブジェクト ボックス内のテーブルを右クリックし、ダイアログボックスでフィルター条件を指定します。詳細については、「フィルター条件の設定」をご参照ください。

    2. 詳細設定へ をクリックして、詳細パラメーターを構成します。

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジュールし、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するために専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      移行元テーブルで生成された Online DDL ツールの一時テーブルを移行先データベースにコピーします。

      ソースデータベースで Data Management (DMS) または gh-ost を使用してオンライン DDL 変更を実行する場合、オンライン DDL 変更によって生成された一時テーブルのデータを同期するかどうかを選択できます。

      重要
      • DTS タスクは、pt-online-schema-change などのツールを使用したオンライン DDL 変更をサポートしていません。このようなツールを使用すると、DTS タスクが失敗します。

      • 各ステージの処理方法は次のとおりです。 スキーマ同期 および 完全データ同期 ステージでは、データベースまたはテーブルスキーマを変更する DDL 操作を許可しないため、これらのステージはオンライン DDL ポリシーの制御を受けません。

        • スキーマ同期:このステージはオンライン DDL ポリシーの制御を受けません。関連する一時テーブルが作成されます。

        • 完全データ同期:このステージはオンライン DDL ポリシーの制御を受けません。一時テーブルは完全同期オブジェクトに含まれません。正規表現 (^_(.+)_(?:gho|new)$ または ^_(.+)_(?:ghc|del|old)$) に一致するすべてのテーブルが除外されます。

        • 増分データ同期:このステージはオンライン DDL ポリシーの制御を受けます。

          • ○:オンライン DDL 操作によって生成された一時テーブル(例:_table-name_gho)のデータ変更を同期します。

          • いいえ、DMS オンライン DDL に適応 および いいえ、gh-ost に適応:gh-ost などのツールによって生成された一時テーブル(例:_table-name_gho)のデータ変更を、正規表現ルールに基づいて除外します。

      • ○:オンライン DDL 変更によって生成された一時テーブルデータを同期します。

        説明

        オンライン DDL 変更によって生成された一時テーブルデータが大きすぎる場合、同期遅延が発生する可能性があります。

      • いいえ、DMS オンライン DDL に適応:オンライン DDL 操作によって生成された一時テーブルのデータを同期しません。代わりに、ソースデータベースで Data Management (DMS) を使用して実行された元の DDL ステートメントのみを同期します。

        説明

        このオプションにより、ターゲットデータベースでテーブルがロックされます。

      • いいえ、gh-ost に適応:オンライン DDL 変更によって生成された一時テーブルのデータを同期しません。カスタムフィルタールールをサポートしています。DTS は、gh-ost などのツールによって生成された一時テーブル(例:_table-name_gho)のデータ変更を、正規表現ルールに基づいて除外します。必要に応じて、シャドウテーブルおよび不要なテーブルに一致させるためのデフォルトの正規表現を変更できます。

        • シャドウテーブル:^_(.+)_(?:gho|new)$

        • 不要なテーブル:^_(.+)_(?:ghc|del|old)$

        説明

        このオプションにより、ターゲットデータベースでテーブルがロックされます。

      アカウントを移行

      ビジネス要件に基づいて、ソースデータベースからアカウント情報を同期するかどうかを選択します。○ を選択する場合は、同期するアカウントを選択し、その権限を確認する必要があります。

      失敗した接続の再試行時間

      同期タスクが開始された後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、すぐに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。

      説明
      • 同じソースまたはターゲットを共有する複数の DTS インスタンス(例:インスタンス A およびインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B のネットワーク再試行時間を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中のタスクランタイムに対して課金するため、ビジネス要件に基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした直後に DTS インスタンスをできるだけ早くリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスクが開始された後、ソースまたはターゲットデータベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、すぐに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 分から 1,440 分の範囲でカスタム再試行時間を設定することもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 は、失敗した接続の再試行時間 より短くする必要があります。

      完全同期レートを制限するかどうか

      完全同期ステージ中、DTS はソースおよびターゲットデータベースの読み取りおよび書き込みリソースを消費するため、データベースの負荷が増加する可能性があります。ソースおよびターゲットデータベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを構成することで、完全同期タスクのレート制限を設定できます。

      説明
      • この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。

      • 同期インスタンスの実行後にも、完全同期レートを調整 できます。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限を設定することもできます。ターゲットデータベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定します。

      環境タグ

      ビジネス要件に基づいて、インスタンスを識別するための環境タグを選択できます。この例ではタグは不要です。

      ETL 機能の設定

      抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:

      順方向および逆方向タスクのハートビートテーブル SQL を削除

      DTS インスタンスの実行中に、ハートビート SQL 情報をソースデータベースに書き込むかどうかを選択します。

      • ○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。

      • ×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。

      監視アラート

      アラートを構成するかどうかを指定します。同期が失敗した場合、または遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

    3. 次へ:データ検証 をクリックして、データ検証タスクを構成します。

      データ検証機能を使用する場合は、「データ検証の構成」をご参照ください。

  7. タスクを保存し、事前チェックを実行します。

    • このインスタンスを構成するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにポインターを合わせ、バルーン内の OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期ジョブが開始される前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した後でのみ、ジョブを開始できます。

    • 事前チェックが失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

      • 無視可能なチェック項目については、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 の順にクリックして、警告をスキップし、事前チェックを再実行します。警告項目をマスクすることを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  8. インスタンスを購入します。

    1. 成功率 が 100 % になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。次の表に、これらのパラメーターの詳細を示します。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      課金方法

      • サブスクリプション:インスタンス作成時に支払いを行います。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。

      • 従量課金:1 時間ごとに課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースしてコストを節約できます。

      リソースグループ構成

      インスタンスが属するリソースグループ。デフォルトは default resource group です。詳細については、「Resource Management とは」をご参照ください。

      リンク仕様

      DTS は、異なるパフォーマンスレベルを持つ同期仕様を提供します。同期リンク仕様は、同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      サブスクリプション期間

      サブスクリプションモードでは、サブスクリプションインスタンスの期間および数量を選択します。1~9 ヶ月の月額サブスクリプション、または 1、2、3、5 年の年額サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。

    3. 構成が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。

      データ同期ページでタスクの進行状況を確認できます。