すべてのプロダクト
Search
ドキュメントセンター

Data Management:米国インスタンスの移行

最終更新日:Sep 03, 2026

米国リージョンのインスタンスへアクセスする際の安定性を向上させるため、Data Management Service (DMS) は米国で独立してデプロイされるようになりました。その結果、米国以外の DMS サイトでは、米国リージョンのインスタンスの管理がサポートされなくなりました。サービスの中断を防ぐため、これらのインスタンスを DMS 米国サイトに移行する必要があります。米国インスタンス移行機能を使用すると、インスタンスをスムーズに移行できます。

事前準備

作業を開始する前に、次の要件を満たしていることを確認してください。

  • リージョンに関する制限:この機能は、データ処理リージョンが中国 (杭州) であるユーザーのみが利用できます。

  • 権限:移行を開始して実行するには、Alibaba Cloud アカウントに DMS の 管理者 または DBA ロールが必要です。

  • 米国サイトの初期化:移行を開始する前に、DMS 米国サイトでテナントを初期化する必要があります。

    • 移行を開始する前に、Alibaba Cloud アカウントで DMS 米国サイトに少なくとも1回はログインしてください。

    • ログインURL:

    • 目的:この操作によって、米国サイトにテナントが作成されます。これはインスタンスの移行に必要です。この手順を完了しないと、移行を開始できません。

  • 既存タスクの確認:移行する予定の米国リージョンのインスタンスを確認し、データクリーンアップやタスクオーケストレーションなどの DMS タスクが実行中またはスケジュールされていないことを確認してください。移行によって元のサイトにあるインスタンスエンドポイントが無効になるため、依存するタスクはすべて失敗します。

  • 移行範囲:

    項目

    説明

    インスタンスと物理データベース

    米国リージョンのインスタンスとその物理データベースのみが対象です。

    ユーザー情報

    テナント内のすべてのユーザーとロールが含まれます。

    承認プロセス

    [Security and Disaster Recovery] > [Approval Process] 配下にあるすべてのカスタム承認テンプレートとノードです。

    セキュリティルール

    [Security and Disaster Recovery] > [Security Rules] 配下にあるすべてのセキュリティルール設定です。

    ユーザー権限

    テナント内のすべてのユーザー権限、データベース所有者情報、および権限ポリシー設定です。

    データ秘密度ラベル

    米国リージョンのインスタンス内のフィールドに設定されている、すべての既存のデータ秘密度ラベルです。


操作手順

  1. DMSコンソールV5.0 にログインします。

  2. 上部メニューで、[データ資産] > [インスタンス管理] を選択します。

  3. [インスタンス管理] ページで、右上隅の [US instance migration] をクリックします。

  4. 表示された [Important Notice] ダイアログボックスで、[I Understand, Migrate Now] をクリックして移行タスクを作成します。

    この通知には、米国リージョンのインスタンスへアクセスする際の DMS の安定性を向上させるため、2026年2月28日までに移行を完了する必要があることが記載されています。次の点に注意してください。移行を開始できるのは、管理者または DBA のみです。開始する前に、DMS 米国サイトにログインしてテナントを初期化する必要があります。中国サイトで作成された Alibaba Cloud アカウントの場合は dms-us-west-1.aliyun.com を、国際サイトで作成されたアカウントの場合は dms-us-west-1.alibabacloud.com を使用してください。移行後、元のサイトにある既存の米国リージョンインスタンスは自動的に無効になります。開始する前に、米国リージョンのインスタンスで DMS のデータ変更タスクや定期タスクが実行されていないことを確認してください。

  5. 移行タスクには、[成功]、[実行中]、[待機中]、[失敗] など、いくつかのステータスがあります。

    [Migration Task List] ダイアログボックスには、各サブタスクの進行状況が [Task ID][Task Name][Status] といった列を含む表形式で表示されます。たとえば、ユーザー情報、インスタンス、承認プロセスの移行は成功し、セキュリティルールの移行は実行中で、データベース、権限、データ秘密度ラベルの移行は待機中です。

  6. 失敗したタスクは、[再試行]できます。

    [Migration Task List] ダイアログボックスで、ステータスが 失敗 のタスクを見つけ、[タスクの再試行] をクリックして再実行します。


移行後の検証

移行タスクが完了したら、次の手順を実行して結果を検証します。

  1. 米国以外のサイトでインスタンスのステータスを確認します。

    • DMS 米国以外のサイト[Instance List] ページを更新します。

    • 移行されたインスタンスのステータスが [無効] に変更されていることを確認します。米国以外のサイトからこれらのインスタンスでデータベース操作を実行できなくなります。

  2. 米国サイトにログインしてインスタンスにアクセスします。

    • DMS 米国サイト[Instance List] ページに移動します。

    • インスタンスリストで、新しく移行されたインスタンスのいずれかにアクセスします。SQL クエリを実行して、その可用性を確認できます。

  3. (オプション) タスクの再設定:元のインスタンスに定期タスクがある場合は、米国サイトでこれらのタスクを再作成して設定する必要があります。


よくある質問

  • Q: 移行は、データベースで直接実行されるアプリケーションの SQL ステートメントに影響しますか。
    A: いいえ。DMS プラットフォーム上の管理タスク (インスタンスメタデータ、ユーザー情報、承認プロセス、セキュリティルール、ユーザー権限、データ秘密度ラベル) のみが対象です。データベースエンジンは関係ありません。データベースで直接実行される (DMS によってスケジュールされていない) アプリケーションの SQL ステートメントは影響を受けず、移行の前後で正常に実行され続けます。

  • Q: 移行後、米国以外のサイトにある米国インスタンスはどうなりますか。
    A: 自動的に無効になり、読み取り専用になります。そのサイトからそれらのインスタンスで操作を実行できなくなります。今後のすべての管理は、米国サイトから行う必要があります。

  • Q: 移行前に定期タスクを一時停止するのを忘れた場合はどうなりますか。
    A: 米国リージョンのインスタンスを対象とするスケジュールされたタスクは失敗します。移行によって元のサイトでそれらのエンドポイントが無効になるためです。これらのタスクは、DMS 米国サイトで再作成する必要があります。

  • Q: 移行は元に戻せますか。
    A: 移行は一方向の操作です。米国サイトから元のサイトにインスタンスを移行して戻すことはできません。続行する前に、この点を慎重にご検討ください。