Data Management (DMS) にインスタンスを登録した後、インスタンス所有者、DBA、基本情報 (データベースアカウント、セキュリティホスティング、セキュリティルールなど)、または詳細情報 (環境タイプ、ロックフリーのスキーマ変更、クエリタイムアウトおよびエクスポートタイムアウトなど) を編集できます。
このページでは、次のタスクについて説明します。
前提条件
開始する前に、次の条件を満たしていることを確認してください。
DMS で管理者または DBA のシステムロールを保有していること
インスタンス所有者またはDBAの変更
所有権を変更する前に、次の点をご確認ください。
新しいインスタンス所有者は、DMS の登録ユーザーである必要があります。ユーザーを追加する方法については、「ユーザー管理」をご参照ください。
新しい DBA は、DBA システムロールを保有する DMS の登録ユーザーである必要があります。
1 つのインスタンスに複数のインスタンス所有者を設定できますが、DBA は 1 人のみです。
DMS コンソール V5.0 にログインします。
左側のデータベースインスタンス一覧で、対象のインスタンスを見つけます。
インスタンス名を右クリックし、[DBA] または [インスタンスオーナー] を変更します。
セキュリティホスティングの有効化または無効化
「セキュリティホスティングの有効化」をご参照ください。
環境タイプの変更
環境タイプ
インスタンスの環境タイプは、DMS 内でのみ有効です。DMS は、2 つのカテゴリに分類される 8 つの環境タイプを提供しています。
カテゴリ | 環境タイプ | 環境 ID |
テスト | 開発 | dev |
テスト | test | |
SIT | sit | |
UAT | uat | |
性能テスト | pet | |
ステージング | stag | |
本番 | 本番 | product |
準本番 | pre |
手順
DMS コンソール V5.0 にログインします。
左側のデータベースインスタンス一覧で、対象のインスタンスを見つけます。
インスタンス名を右クリックし、[編集] を選択します。
[詳細情報] セクションで [環境タイプ] を見つけ、ドロップダウンリストから対象のタイプを選択します。
[保存] をクリックします。
データエクスポート時の "query execution was interrupted, maximum statement execution time exceeded" エラー
このエラーは、MySQL の max_execution_time パラメーターが原因で発生します。以下の手順で対処してください。
インスタンスに接続し、
SHOW GLOBAL VARIABLES LIKE '%max_execution_time%'を実行してパラメーターの値を確認します。値が 0 の場合は、制限がないことを示します。値が 0 でない場合は、ApsaraDB RDS コンソールにログインしてインスタンス詳細ページを開き、[パラメータ] で
max_execution_timeを 0 に設定し、インスタンスに再接続してから、再度データをエクスポートしてください。左側の DMS インスタンスリストで、対象のインスタンスを右クリックして 編集 を選択し、[詳細情報] でクエリタイムアウトとエクスポートタイムアウトを長くします。
インスタンス構成のエクスポート
コントロールモード、環境タイプ、インスタンスソースなどのインスタンス構成をエクスポートして、オフラインでインスタンスリソースを管理できます。
セキュリティ上の理由から、エクスポートされた構成には、データベースアカウントやパスワードは含まれません。
DMS コンソール V5.0 にログインします。
上部のナビゲーションバーで、[データ資産] > [インスタンス] を選択します。
説明DMS コンソールをシンプルモードで使用している場合、左上隅のアイコンにポインターを合わせ、を選択します。
[インスタンスリスト] タブで、対象のインスタンスを選択します。
[その他] > [設定のエクスポート] を選択します。
instances という名前の Excel ファイルがダウンロードされます。
インスタンス情報の一括編集
DMS コンソール V5.0 にログインします。
トップナビゲーションバーで、[データアセット] > [インスタンス] を選択します。
説明DMS コンソールをシンプルモードで使用している場合は、左上隅のアイコンにポインターを合わせ、を選択します。
[インスタンスリスト] タブで、対象のインスタンスを選択し、[一括編集] をクリックします。
説明選択したすべてのインスタンスは、同じデータベースタイプ (例:すべて MySQL) である必要があります。
ダイアログボックスで、変更する構成項目のチェックボックスをオンにし、インスタンス情報を編集します。
よくある質問
DMS でデータベースを作成するときに "Access denied for user 'example_user'@'%' to database 'example_db'" エラーが発生するのはなぜですか?
データベースアカウントに、データベースを作成する権限がありません。インスタンスコンソールで必要な権限を付与するか、より高い権限を持つアカウントで DMS にログインしてください。詳細については、「アカウント権限の変更」をご参照ください。
VPC タイプのインスタンスの IP アドレスを変更した後、権限が失われるのはなぜですか?
DMS は、IP アドレスではなくインスタンス ID に権限をバインドします。IP アドレスを、以前に削除されたインスタンスで使用されていたアドレスに変更すると、DMS はこの変更を削除されたインスタンスの復元として扱い、現在のインスタンスを「削除済み」としてマークし、履歴インスタンスを再アクティブ化します。再アクティブ化されたインスタンスのインスタンス ID が異なるため、元のインスタンスにバインドされていた権限が失われます。
VPC タイプのインスタンスの IP アドレスを変更した後、DMS インスタンス ID は変更されますか?
新しい IP アドレスが DMS に履歴があるかどうかによって異なります。
DMS に履歴がない新しい IP アドレスの場合: DMS は、現在のインスタンスの IP アドレスを更新します。インスタンス ID と権限は変更されません。
以前に削除されたインスタンスで使用されていた IP アドレスの場合: DMS は履歴インスタンスを復元し、現在のインスタンスを削除します。アクティブなインスタンス ID は履歴インスタンスの ID に変わり、元の権限は失われます。