すべてのプロダクト
Search
ドキュメントセンター

Alibaba Cloud Service Mesh:コントロールプレーンのログ収集とアラート機能の有効化 (新バージョン)

最終更新日:Aug 26, 2026

Alibaba Cloud Service Mesh (ASM) は、ASM コンソールからコントロールプレーンとデータプレーンのログを表示できるログセンターを提供します。ログ収集を有効にすると、ログセンターを使用してコントロールプレーンのログの表示、ログベースのアラートルールの設定、データプレーンのログの表示、および関連ダッシュボードへのアクセスが可能になります。このトピックでは、コントロールプレーンのログ収集とログベースのアラートを有効にする方法について説明します。

前提条件

コントロールプレーンのログ収集の有効化

  1. ASM コンソールにログインします。左側のナビゲーションウィンドウで、サービスメッシュ > メッシュ管理 を選択します。

  2. メッシュ管理 ページで、ASM インスタンスの名前をクリックします。 左側のナビゲーションウィンドウで、オブザーバビリティ管理センター > ログセンターを選択します。

  3. ログセンター ページで、コントロールプレーンログ タブをクリックします。新規 Project の作成 または 既存のProjectを使用 を選択し、関連パラメーターを設定してから、コントロールプレーンログ収集の有効化 をクリックします。確認 ダイアログボックスで、OK をクリックします。

    ログが Simple Log Service (SLS) に収集された後、次の操作を実行できます:

説明

この機能が不要になった場合は、コントロールプレーンログ タブの右上隅にある コントロールプレーンログ収集のシャットダウン をクリックします。確認 ダイアログボックスで、OK をクリックします。

コントロールプレーンログの表示

コントロールプレーンのログ収集を有効にすると、マネージドコントロールプレーンからのログが Simple Log Service (SLS) に収集されます。SLS コンソールまたは ASM コンソールの統合ログブラウザで、コントロールプレーンのログを表示またはクエリできます。

説明

SLS がログのディストリビューションを確立するまでに時間がかかる場合があります。ログ収集を有効にした直後には、コンソールにログが表示されないことがあります。

方法 1:ASM コンソールの使用

  1. ASM コンソールにログインします。左側のナビゲーションウィンドウで、サービスメッシュ > メッシュ管理 を選択します。

  2. メッシュ管理 ページで、ASM インスタンスの名前をクリックします。 左側のナビゲーションウィンドウで、オブザーバビリティ管理センター > ログセンター を選択します。

  3. ログセンター ページで、コントロールプレーンログ タブをクリックすると、ログ情報を表示できます。

方法 2:SLS コンソールの使用

  1. Simple Log Service コンソールにログインします。

  2. プロジェクト一覧 セクションで、対象のクラスターに対応するログサービスプロジェクトの名前をクリックします。

  3. 左側のナビゲーションウィンドウで、目的のLogstoresをクリックします。 表示されるページで、ログ情報を確認します。

コントロールプレーンのログアラートの設定

コントロールプレーンのログ収集を有効にした後、コントロールプレーンのログベースのアラートを設定できます。

  1. ASM コンソールにログインします。左側のナビゲーションウィンドウで、サービスメッシュ > メッシュ管理 を選択します。

  2. メッシュ管理 ページで、ターゲット ASM インスタンスの名前をクリックします。左側のナビゲーションウィンドウで、オブザーバビリティ管理センター > ログセンター を選択します。

  3. ログセンター ページで、コントロールプレーンログ タブをクリックし、次に左上隅にある アラート設定 をクリックします。

  4. コントロールプレーンのログベースのアラート設定項目 ダイアログボックスで、必要に応じて アクションポリシー を選択し、アラートの有効化 をクリックします。ご注意 ダイアログボックスで、確認 をクリックします。

    アクションポリシー は、アラートがトリガーされたときに通知を送信する方法を定義するもので、ASM 組み込みアクションストラテジーとカスタムアクションポリシーの 2 種類がサポートされています。 デフォルトでは、ASM 組み込みアクションポリシーには通知チャネルが設定されていません。 設定.png アイコンをクリックし、手順に従って Simple Log Service アラートセンターを開き、チャンネルを設定できます。 アラートがトリガーされた場合は、ソリューションをご参照ください。

アラート連絡先の設定

アラート通知を受信できるように、組み込みのアラートユーザーグループにメンバーを追加します。

  1. Simple Log Service コンソールにログインします。

  2. [プロジェクト] セクションで、プロジェクト名をクリックします。左側のナビゲーションウィンドウで、[アラート] をクリックします。

  3. [アラートセンター] ページで、[通知オブジェクト] > [ユーザーグループ管理] を選択します。

  4. [ユーザーグループ管理] タブで、sls.app.asm.builtin を探し、[操作] 列の[編集] をクリックします。

  5. [ユーザーグループの編集] ダイアログボックスで、追加するメンバーを選択し、Add アイコンをクリックしてグループに追加し、[OK] をクリックします。

    Edit user group

トリガーされたアラート通知の例

説明

このトピックでは、すべてのアラート項目を網羅することはできません。次の例では、不正な設定を使用して「メッシュコントロールプレーンからの設定プッシュの失敗」アラートをトリガーする方法を示します。

  1. ASM コンソールにログインします。左側のナビゲーションウィンドウで、サービスメッシュ > メッシュ管理 を選択します。

  2. メッシュ管理 ページで、ASM インスタンスの名前をクリックします。左側のナビゲーションウィンドウで、イングレスゲートウェイサービス > ゲートウェイ設定 (Gateway) を選択します。表示されたページで、YAML で作成 をクリックします。

  3. 作成 ページで、対象の名前空間とシナリオテンプレートを選択し、次に YAML を設定します。

    この例では、default 名前空間を使用して ASM ゲートウェイを設定します。以下は YAML 設定のサンプルです:

    apiVersion: networking.istio.io/v1beta1
    kind: Gateway
    metadata:
      name:  gateway-test
      namespace: default
    spec:
      selector:
        istio: ingressgateway
      servers:
        - hosts:
            - '*console.alibabacloud.com'
          port:
            name: https
            number: 443
            protocol: HTTPS
          tls:
            credentialName: not-existing-credential
            mode: SIMPLE
  4. アラート通知を表示します。

    1. ASM コンソールにログインします。左側のナビゲーションウィンドウで、サービスメッシュ > メッシュ管理 を選択します。

    2. メッシュ管理 ページで、ASM インスタンスの名前をクリックします。左側のナビゲーションウィンドウで、オブザーバビリティ管理センター > ログセンター を選択します。

    3. ログセンター ページで、コントロールプレーンログ タブをクリックし、ACK ERROR を検索してアラート情報を表示します。

      アラート連絡先にメールアドレスを設定している場合は、メールでアラート通知を確認することもできます。

ソリューション

メッシュ設定に関する警告

ASM Mesh Diagnosis は、お使いのクラスターでリスクの可能性があるメッシュ構成を検出しました。これらの構成により、ASM で予期しない結果が発生する可能性があります。メッシュ診断 ページに移動してアラートの詳細を表示し、メッシュ診断 ページの推奨事項に従って誤った構成を修正できます。詳細については、「ASM Mesh Diagnosis を使用する」をご参照ください。

メッシュ設定エラー

ASM Mesh Diagnosis が、お使いのクラスターで不正なメッシュ構成を検出しました。これらの構成は、予期しない動作を引き起こす高いリスクを伴います。できるだけ早く メッシュ診断 ページでアラートの詳細を確認し、メッシュ診断 ページのガイダンスに従って構成を修正してください。詳細については、「ASM Mesh Diagnosis の使用」をご参照ください。

無効なメッシュ設定による設定プッシュの失敗

次の表に、データプレーンの同期失敗に関する一般的なエラーメッセージと、対応するソリューションを示します。エラーメッセージが見つからない場合は、チケットを送信してください。

エラーメッセージ

ソリューション

Internal:Error adding/updating listener(s) 0.0.0.0_443: Failed to load certificate chain from <inline>, only P-256 ECDSA certificates are supported

このアラートは、データプレーンクラスターがデータプレーン用に設定された証明書をサポートしていないことを示します。証明書を再設定する必要があります。P-256 ECDSA 証明書のみがサポートされています。詳細については、「ASM ゲートウェイでの HTTPS の有効化」をご参照ください。

Internal:Error adding/updating listener(s) 0.0.0.0_443: Invalid path: ****

このアラートは、データプレーンに設定された証明書パスが正しくないか、証明書が存在しないことを示します。証明書のマウントパスがゲートウェイで設定されたパスと一致することを確認してください。詳細については、「ASM ゲートウェイでの HTTPS の有効化」をご参照ください。

Internal:Error adding/updating listener(s) 0.0.0.0_xx: duplicate listener 0.0.0.0_xx found

このアラートは、ゲートウェイに重複したリスナーポートが設定されていることを示します。ゲートウェイの設定を確認し、重複したポートを削除してください。

Internal:Error adding/updating listener(s) 192.168.33.189_15021: Didn't find a registered implementation for name: '***'

このアラートは、リスナー 15021 の EnvoyFilter パッチ設定で参照されている *** の実装が、サイドカープロキシまたはイングレスゲートウェイで見つからないことを示します。この参照を削除する必要があります。

Internal:Error adding/updating listener(s) 0.0.0.0_80: V2 (and AUTO) xDS transport protocol versions are deprecated in grpc_service ***

このアラートは、データプレーンで使用されている xDS v2 プロトコルが非推奨であることを示します。この問題は通常、データプレーン上のサイドカープロキシのバージョンがコントロールプレーンのバージョンと互換性がない場合に発生します。この問題を解決するには、データプレーンのサイドカープロキシの Pod を削除してアップグレードします。Pod が再作成されると、最新のサイドカープロキシバージョンが自動的に注入されます。

証明書の有効期限切れによるゲートウェイの障害

このアラートは、証明書管理内の証明書の有効期限が切れており、すぐに対応が必要であることを示します。

証明書の有効期限切れ間近

このアラートは、証明書管理内の証明書の有効期限が近づいており、まもなく更新する必要があることを示します。

関連操作

コントロールプレーンのログプロジェクトの変更

  1. ASM コンソールにログインします。左側のナビゲーションウィンドウで、サービスメッシュ > メッシュ管理 を選択します。

  2. メッシュ管理 ページで、ASM インスタンスの名前をクリックします。 左側のナビゲーションウィンドウで、オブザーバビリティ管理センター > ログセンター を選択します。

  3. ログセンター ページで、コントロールプレーンログ タブの下にある LogProject の変更 をクリックします。LogProject の変更 ダイアログボックスで、必要に応じて設定を変更し、確認 をクリックします。