Membuat instans baca-saja untuk instans ApsaraDB RDS.
Deskripsi operasi
Mesin DPI yang didukung
RDS MySQL
RDS PostgreSQL
RDS SQL Server
Dokumentasi fitur terkait
Coba sekarang
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
rds:CreateReadOnlyDBInstance |
create |
*DBInstance
|
|
None |
Parameter permintaan
|
Parameter |
Type |
Required |
Description |
Example |
| ClientToken |
string |
No |
Token klien yang digunakan untuk memastikan idempotensi permintaan. Anda dapat menggunakan klien untuk menghasilkan token, tetapi Anda harus memastikan bahwa token tersebut unik di antara permintaan yang berbeda. Token hanya dapat berisi karakter ASCII dan panjangnya tidak boleh melebihi 64 karakter. |
ETnLKlblzczshOTUbOC**** |
| RegionId |
string |
Yes |
ID wilayah. Instans baca-saja harus berada di wilayah yang sama dengan instans utama. Anda dapat memanggil DescribeRegions untuk mengkueri daftar wilayah terbaru. |
cn-hangzhou |
| ZoneId |
string |
Yes |
ID zona. Anda dapat memanggil DescribeRegions untuk mengkueri daftar zona terbaru.
|
cn-hangzhou-b |
| DBInstanceId |
string |
Yes |
ID instans utama. Anda dapat memanggil DescribeDBInstances untuk mengkueri ID instans. |
rm-uf6wjk5**** |
| DBInstanceClass |
string |
Yes |
Tipe instans. Untuk informasi selengkapnya, lihat Tipe instans baca-saja. Kami menyarankan agar tipe instans baca-saja sama dengan atau lebih tinggi dari instans utama. Jika tipe instans baca-saja lebih kecil dari instans utama, instans baca-saja dapat mengalami latensi tinggi dan beban berat. |
mysqlro.n2.small.1c |
| DBInstanceStorage |
integer |
Yes |
Kapasitas penyimpanan instans. Kapasitas penyimpanan instans baca-saja harus lebih besar dari atau sama dengan instans utama. Untuk informasi selengkapnya, lihat kolom Kapasitas penyimpanan di Tipe instans baca-saja. Nilai dinaikkan dalam kelipatan 5 GB. Unit: GB. |
20 |
| EngineVersion |
string |
Yes |
Versi mesin database. Versi harus sama dengan instans utama.
|
5.6 |
| PayType |
string |
Yes |
Metode penagihan. Nilai valid:
|
Postpaid |
| DBInstanceDescription |
string |
No |
Deskripsi instans. Deskripsi harus memiliki panjang 2 hingga 256 karakter dan dapat berisi huruf, angka, garis bawah (_), dan tanda hubung (-). Deskripsi harus diawali dengan huruf atau karakter Tionghoa. Catatan
Deskripsi tidak dapat diawali dengan http:// atau https://. |
testReadOnly |
| InstanceNetworkType |
string |
No |
Jenis jaringan instans baca-saja. Nilai valid:
Secara default, instans yang terhubung ke VPC akan dibuat. Anda juga harus menentukan VPCId dan VSwitchId. Catatan
Jenis jaringan instans baca-saja dapat berbeda dari instans utama. |
Classic |
| VPCId |
string |
No |
ID VPC instans baca-saja. Parameter ini diperlukan ketika InstanceNetworkType diatur ke VPC atau dikosongkan. Catatan
|
vpc-uf6f7l4fg90**** |
| VSwitchId |
string |
No |
ID vSwitch instans baca-saja. Parameter ini diperlukan ketika InstanceNetworkType diatur ke VPC atau dikosongkan. |
vsw-uf6adz52c2p**** |
| PrivateIpAddress |
string |
No |
Alamat IP internal instans baca-saja. Alamat IP harus berada dalam rentang alamat vSwitch yang ditentukan. Sistem secara otomatis mengalokasikan alamat IP internal berdasarkan nilai VPCId dan VSwitchId secara default. |
172.16.XX.XX |
| ResourceGroupId |
string |
No |
ID kelompok sumber daya. |
rg-acfmy**** |
| Category |
string |
No |
Edisi instans. Nilai valid:
Catatan
Instans baca-saja dari instans cloud disk ApsaraDB RDS for PostgreSQL menggunakan Edisi Dasar. Anda harus mengatur parameter ini ke Basic. |
HighAvailability |
| DBInstanceStorageType |
string |
No |
Tipe penyimpanan instans. Nilai valid:
Catatan
|
local_ssd |
| DedicatedHostGroupId |
string |
No |
ID klaster khusus. Parameter ini diperlukan saat Anda membuat instans baca-saja di klaster khusus. |
dhg-4n**** |
| TargetDedicatedHostIdForMaster |
string |
No |
ID host instans utama di klaster khusus. Parameter ini diperlukan saat Anda membuat instans baca-saja di klaster khusus. |
i-bp**** |
| GdnInstanceName |
string |
No |
Parameter yang dicadangkan. Anda tidak perlu menentukan parameter ini. |
test |
| TddlBizType |
string |
No |
Parameter yang dicadangkan. Anda tidak perlu menentukan parameter ini. |
test |
| TddlRegionConfig |
string |
No |
Parameter yang dicadangkan. Anda tidak perlu menentukan parameter ini. |
test |
| InstructionSetArch |
string |
No |
Parameter yang dicadangkan. Anda tidak perlu menentukan parameter ini. |
test |
| UsedTime |
string |
No |
Durasi langganan. Nilai valid:
Catatan
Parameter ini diperlukan ketika PayType diatur ke Prepaid. |
1 |
| Period |
string |
No |
Tipe langganan instans. Nilai valid:
|
Month |
| AutoRenew |
string |
No |
Apakah akan mengaktifkan perpanjangan otomatis. Parameter ini hanya diperlukan untuk instans langganan. Nilai valid:
Catatan
|
true |
| DeletionProtection |
boolean |
No |
Apakah akan mengaktifkan fitur perlindungan rilis untuk instans. Nilai valid:
Catatan
Fitur ini hanya didukung ketika metode penagihan diatur ke bayar sesuai pemakaian. |
true |
| Port |
string |
No |
Port yang digunakan saat Anda membuat instans baca-saja untuk instans utama ApsaraDB RDS for MySQL. Nilai valid: 1000 hingga 65534. |
3306 |
| BurstingEnabled |
boolean |
No |
Parameter yang tidak digunakan lagi. Anda tidak perlu menentukan parameter ini. |
0 |
| IsAnalyticReadOnlyIns |
boolean |
No |
Apakah akan mengaktifkan fitur I/O burst untuk Premium ESSD. Nilai valid:
|
false |
| AutoPay |
boolean |
No |
Apakah akan membuat instans analitis berbasis DuckDB. Nilai valid:
Catatan
Hanya ApsaraDB RDS for MySQL dan ApsaraDB RDS for PostgreSQL yang mendukung instans analitis berbasis DuckDB. |
false |
| AutoCreateProxy |
boolean |
No |
Apakah akan mengaktifkan pembayaran otomatis. Nilai valid:
Catatan
Nilai default: true. Jika metode pembayaran Anda memiliki saldo yang tidak mencukupi, atur AutoPay ke false. Dalam hal ini, pesanan yang belum dibayar akan dihasilkan. Anda dapat log ke Konsol ApsaraDB RDS untuk menyelesaikan pembayaran. |
false |
| IoAccelerationEnabled |
string |
No |
Apakah akan membuat proksi database secara otomatis. Nilai valid:
|
false |
| AutoUseCoupon |
boolean |
No |
Apakah akan mengaktifkan fitur Buffer Pool Extension (BPE) untuk Premium ESSD. Nilai valid:
|
0 |
| PromotionCode |
string |
No |
Apakah akan menggunakan kupon. Nilai valid:
|
true |
| CustomExtraInfo |
string |
No |
Kode kupon. |
71744626**** |
|
No |
Parameter yang dicadangkan. Anda tidak perlu menentukan parameter ini. |
None |
Elemen respons
|
Element |
Type |
Description |
Example |
|
object |
Parameter tanggapan. |
||
| ConnectionString |
string |
Alamat koneksi database internal instans baca-saja. |
rr-****.mysql.rds.aliyuncs.com |
| DBInstanceId |
string |
ID instans baca-saja. |
rr-uf6wjk5**** |
| OrderId |
string |
ID pesanan. |
10078937**** |
| Port |
string |
Port koneksi database internal instans baca-saja. |
3306 |
| RequestId |
string |
ID permintaan. |
1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC |
Contoh
Respons sukses
JSONformat
{
"ConnectionString": "rr-****.mysql.rds.aliyuncs.com",
"DBInstanceId": "rr-uf6wjk5****",
"OrderId": "10078937****",
"Port": "3306",
"RequestId": "1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC"
}
Kode kesalahan
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidEngineVersion.Malformed | The specified parameter EngineVersion is not valid. | |
| 400 | InvalidNetworkTypeClassicWhenCloudStorage | The Specified InstanceNetworkType value Classic is not valid when choose cloud storage type. | Pengaturan parameter InstanceNetworkType ke Classic tidak valid ketika tipe penyimpanan cloud dipilih. |
| 400 | InvalidSecurityIPList.Malformed | The specified parameter SecurityIPList is not valid. | |
| 400 | InvalidSecurityIPList.Duplicate | The Security IP address is not in the available range or occupied. | Daftar IP keamanan yang ditentukan tidak valid karena berisi nilai duplikat. |
| 400 | InvalidParameter | The specified parameter dbInstanceId is not valid. | |
| 400 | OperationDenied | VPC IP is in use, please check. | Operasi gagal. Terjadi kesalahan pada layanan VPC. Periksa apakah parameter sudah benar. |
| 400 | InvalidZoneId.NotSupported | The Specified vpc Zone not supported. | Zona saat ini tidak mendukung pembuatan instans dengan jenis jaringan VPC. Pilih zona lain untuk membuat instans VPC yang aktif. |
| 400 | InvalidAvZone.NotSupport | Specified availableArea multiZone does not support in RDS. | Area ketersediaan multi-zona yang ditentukan tidak didukung di ApsaraDB RDS. |
| 400 | CDDC.AvailableHostsNotEnoughInZone | Not enough available hosts are in the target zone. | Zona tujuan tidak memiliki Sumber daya host yang cukup. Buat host di zona tersebut. |
| 400 | InvalidReadEngineVersionPattern | The engine versions of the primary instance and the read-only instance do not match. | engineVersion dari instans utama tidak cocok dengan instans read-only. |
| 400 | InvalidDBInstanceClass.Offline | The specified instance type is no longer provided. Please specify another instance type. | Tipe instans yang dipilih telah dihentikan. Tentukan tipe instans lain. |
| 400 | SYSTEM.CONCURRENT_OPERATE | Concurrent operation is detected. | Ada operasi konkuren di sistem. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | Hasil rencana harga tidak ditemukan. |
| 400 | InvalidDBInstanceName.Duplicate | Specified DB instance name already exists in the Aliyun RDS. | Operasi gagal. Nama instans sudah ada. Ubah nama instans. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | Tipe instans saat ini tidak mendukung tipe penyimpanan ini. |
| 400 | InvalidRequestId | The request is copy, check your token. | Permintaan duplikat. Periksa token. |
| 400 | InvalidParam.InstanceNetworkType | Creation of classic network instances is not supported. | Jaringan klasik telah didepresiasi. Pembuatan instans jaringan klasik tidak didukung. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Instans dalam paket tidak dapat dioperasikan secara individual. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Anda belum menyelesaikan verifikasi nama asli dan tidak memenuhi syarat untuk melakukan pembelian. Masuk ke Biaya dan Pengeluaran untuk menyelesaikan verifikasi nama asli. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | Saldo akun Anda kurang dari 0. Isi ulang akun Anda sebelum mencoba melakukan pembelian. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | Panggilan ke layanan komoditas gagal. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Alibaba Cloud berencana mengoptimalkan dan menyesuaikan wilayah saat ini. Layanan cloud di wilayah ini akan menghentikan operasional. Untuk memastikan kelangsungan bisnis dan migrasi data yang lancar, Anda tidak dapat membuat pesanan pembelian baru saat ini. Terima kasih atas pengertian dan dukungan Anda. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | Modul yang Anda beli tidak valid. Beli ulang modul tersebut. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | Wilayah yang ditentukan telah dihentikan operasinya. |
| 400 | Price.CommoditySys | Commodity system call exception. | Terjadi pengecualian saat memanggil sistem komoditas. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | Periode langganan yang dipilih tidak valid. Pilih periode langganan yang berbeda. |
| 400 | pay.noCreditCard | Account not bound to credit card. | Akun tidak terikat dengan kartu kredit. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Terdapat pesanan yang belum dibayar untuk layanan yang Anda pilih. Bayar atau batalkan pesanan yang ada sebelum membuat pesanan baru. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Tidak ada metode pembayaran yang ditentukan untuk akun Anda. Tambahkan metode pembayaran. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Informasi Anda tidak lengkap. Lengkapi informasi Anda sebelum melanjutkan. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Akun Anda mengalami pengecualian. Hubungi layanan pelanggan untuk detailnya. |
| 400 | Api.NotSupport | Specified api is not supported. | Operasi saat ini tidak didukung. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Terdapat tag pemblokiran pesanan. Hubungi distributor Anda untuk menyelesaikan masalah ini. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | Instans yang ditentukan tidak ada. Periksa apakah instans ada dan belum dihapus. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | Operasi gagal. Parameter tidak valid. |
| 400 | KmsApiError | User secret key invalid. | Kunci pengguna tidak valid. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Akun tidak ada. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | Perintah SQL gagal dieksekusi atau mengalami timeout. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | Versi Mesin DPI instans saat ini tidak mendukung pengarsipan data dingin. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | Versi kernel saat ini tidak mendukung pengarsipan data dingin. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | Tipe instans saat ini tidak mendukung operasi ini. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | Nama alamat koneksi duplikat. Tentukan string koneksi yang berbeda. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parameter yang diperlukan hilang. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | Parameter tidak valid. Periksa parameter. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | Pengarsipan data dingin tidak mendukung pencadangan lintas wilayah atau pencadangan snapshot frekuensi tinggi. Periksa kebijakan cadangan. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | Status instans tidak mendukung operasi ini. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | Kebijakan retensi data cadangan terarsip setelah pelepasan instans tidak valid. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | Tipe engine database instans tidak mendukung operasi ini. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Operasi ini tidak didukung untuk instans dengan jenis jaringan VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | Image instans database sudah ada. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | Tipe instans tidak lagi tersedia untuk dibeli. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | Database yang ditentukan tidak ada dalam set cadangan. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Gagal mengkueri produk. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | Instans telah dirilis. Verifikasi instans sebelum melakukan Pesanan. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | Wilayah yang ditentukan telah dihentikan operasinya. |
| 400 | InvalidVSwitchId.Format | The specified vswitch Id format is incorrect. | Format ID vSwitch yang ditentukan tidak valid. |
| 400 | InvalidParameterValue.NotStandard | Invalid parameter format. | Format parameter yang ditentukan tidak valid. |
| 400 | AtLeastThreeVSwitchAvailableIp | The primary vswitch requires at least three available IP addresses. | vSwitch utama harus memiliki setidaknya 3 alamat IP yang tersedia. |
| 400 | AtLeastTwoVSwitchAvailableIp | The primary vswitch requires at least two available IP addresses. | vSwitch utama harus memiliki setidaknya 2 alamat IP yang tersedia. |
| 400 | DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance | Current instance is already attached to another duckdb instance, operation is conflict. | Instans saat ini sudah terkait dengan instans analitis berbasis DuckDB lainnya, yang bertabrakan dengan operasi DuckDB saat ini. |
| 500 | CannotDecreaseEssdPerfLevel | cannot decrease cloud essd performance level. | |
| 500 | InvalidEssdStorageSize | invalid cloud essd storage size. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | Permintaan gagal. Coba lagi nanti. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | Permintaan gagal. Coba lagi nanti atau hubungi dukungan teknis. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | Permintaan gagal karena kegagalan layanan API RDS. |
| 403 | OperationDenied.PrimaryDBInstanceStatus | The operation is not permitted due to status of primary instance. | Operasi gagal. Instans ApsaraDB RDS yang tidak berada dalam status Running dalam Kluster khusus tidak dapat dimigrasikan. |
| 403 | InvalidReadStorageTypePattern | The storage type of the primary instance and the read-only instance do not match. | |
| 403 | IncorrectCharacterType | Current DB instance character type does not support this operation. | Tipe karakter instans saat ini tidak mendukung operasi ini. |
| 403 | InvalidMultiparamZoneInfoList | Zoneinfo list is invaild. | Zona utama saat ini tidak selaras. Instans utama tidak dapat dimigrasikan. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Instans memiliki pesanan yang belum dibayar. Bayar pesanan tersebut dan coba lagi. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | Kapasitas target untuk penurunan skala tidak boleh kurang dari penggunaan penyimpanan saat ini. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Operasi ini tidak didukung untuk disk SSD. Tingkatkan ke ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | Izin pengguna tidak mendukung operasi ini. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | Format VSwitchId yang ditentukan tidak valid atau kosong. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | Versi minor engine saat ini tidak mendukung operasi ini. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Tidak ada zona inventaris yang tersedia. |
| 403 | NotInFlowController | Sorry,no permission. | Operasi ini tidak tersedia untuk pengguna cloud non-perusahaan. Anda tidak memiliki izin yang diperlukan. |
| 403 | InvalidKmsKey | Kms key is disabled. | Kunci KMS dinonaktifkan. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | Operasi gagal. Kode spesifikasi yang ditentukan tidak mendukung jumlah titik akhir yang ditentukan. Periksa jumlah shard dan jumlah titik akhir saat ini. |
| 403 | BasicCategoryNotSupport | The Basic category is not supported. | Edisi Dasar tidak didukung. |
| 403 | GuardDBInstanceNotSupport | Guard instance does not support this operation. | Operasi ini tidak didukung untuk instans pemulihan bencana. |
| 404 | IncorrectDBInstanceConnType | Current DB instance conn type does not support this operation. | |
| 404 | InvalidDBInstance.NotFound | The specified instance does not exist or is not supported. | Instans yang ditentukan tidak ada atau tidak mendukung operasi ini. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | Instans saat ini tidak diotorisasi untuk mengakses Key Management Service. |
| 404 | Request.NotFound | The requested resource is not available. | Sumber daya yang diminta tidak tersedia. |
| 404 | HostInfo.NotFound | The specified host info is not found. | Informasi host yang ditentukan tidak ada. |
Lihat Error Codes untuk daftar lengkap.
Catatan rilis
Lihat Release Notes untuk daftar lengkap.