全部产品
Search
文档中心

Cloud Monitor:Bagaimana cara memperbaiki masalah bahwa kuota API telah habis atau hampir habis?

更新时间:Jul 06, 2025

Kuota gratis untuk panggilan API data metrik adalah satu juta panggilan per bulan. Setelah kuota gratis tercapai, pembatasan kecepatan akan diterapkan. Dokumen ini menjelaskan penyebab dan solusi terkait masalah ini.

Masalah

  • Ketika jumlah panggilan API untuk kueri data metrik mencapai satu juta per bulan, Anda akan menerima email atau pesan teks yang memberitahukan bahwa kuota telah habis pada hari pertama dan keempat, serta pembatasan kecepatan diterapkan pada hari kelima.

  • Jika respons API menampilkan user api quota limit, maka pembatasan kecepatan telah diterapkan.

Penyebab

Kuota panggilan API untuk kueri data metrik dikonsumsi dalam skenario berikut:

Solusi

  • Kami menyarankan Anda memperbaiki masalah dengan melakukan langkah-langkah berikut:

    • Kurangi frekuensi pemanggilan operasi API. Panggil operasi API setiap 5 menit alih-alih setiap 1 menit.

    • Kurangi jumlah sumber daya yang diperoleh dalam satu panggilan API.

      Anda dapat memperoleh hingga 50 sumber daya dalam satu waktu. Sebagai contoh, saat memanggil operasi DescribeMetricLast, atur parameter permintaan Dimensions menjadi [{instanceId:***},{instanceId:***},{instanceId:***}].

    • Aktifkan CloudMonitor Basic (bayar sesuai pemakaian).

      Untuk informasi lebih lanjut, lihat Aktifkan Metode Penagihan Bayar Sesuai Pemakaian.

    • Gunakan fitur cloud monitoring exporter yang disediakan oleh Hybrid Cloud Monitoring. Fitur ini menawarkan biaya rendah, latensi rendah, dan keandalan tinggi.

      Untuk informasi lebih lanjut, lihat Ekspor Data Pemantauan Secara Real-Time.

  • Jika kuota habis karena penggunaan plugin Grafana dari CloudMonitor, kami menyarankan Anda menggunakan dasbor dari Hybrid Cloud Monitoring.

    Untuk informasi lebih lanjut, lihat Kelola Dasbor.