Todos los productos
Search
Centro de documentos

DataWorks:Datos de tablas de Lindorm

Última actualización: Sep 04, 2026

Una vez que vincula una instancia de Lindorm a DataWorks, puede gestionar y consultar los metadatos de las tablas de Lindorm en Data Map.

Requisitos previos

Los parámetros de Spark están configurados en la página de vinculación de recursos de cómputo para recopilar metadatos de Lindorm. Para obtener más información, consulte Set Spark parameters for a Lindorm computing resource.

Ir a Data Map

Inicie sesión en la consola de DataWorks. En la región objetivo, haga clic en Data Governance > Data Map en el panel de navegación izquierdo. En la página que aparece, haga clic en Go to Data Map.

Recopilar metadatos de tablas de Lindorm

En el panel de navegación izquierdo de Data Map, haga clic en el icono image para abrir la página de gestión del recopilador de fuentes de datos. En la sección Data Source Perspective, busque el recopilador de Lindorm y configure un plan de recopilación para obtener los metadatos de las tablas de Lindorm. Para obtener más información, consulte Metadata collection.

Buscar tabla

Una vez que el plan de recopilación de metadatos de Lindorm se ejecuta correctamente, puede consultar los metadatos recopilados mediante los siguientes pasos.

  1. Haga clic en el icono image.png en la barra de menú izquierda para ir a la página de búsqueda.

  2. En el árbol de directorios Type de la izquierda, seleccione Table. En Connection, busque y haga clic en la fuente de datos de Lindorm para abrir la página de lista de tablas de Lindorm.

    Nota

    Si existen varias fuentes de datos, es posible que la lista no se muestre por completo. Aparece More a la derecha de DLF. Haga clic en More para encontrar la fuente de datos de Lindorm.

  3. En el cuadro de búsqueda situado encima de la lista de tablas de Lindorm, introduzca una palabra clave del nombre de la tabla para localizarla.

Consultar detalles de la tabla

En la página de lista de tablas de Lindorm, haga clic en una tabla para abrir su página de detalles.

Feature

Descripción

Referencias

Operaciones rápidas

En la parte superior de la página, use Add to Album, View Added Albums o Add to Favorites.

Table Basic Information

En la sección Table Basic Information, consulte la Database, el Table Type, el Owner, la fecha de creación (Created At) y si la tabla es una Partitioned Table.

View basic information about a table

Información técnica de la tabla

Consulte información como la Path de almacenamiento, el Input Format y el Output Format.

Details

Consulte la Field Information y el Lineage Field de la tabla.

View table details

Linaje

Consulte el linaje de datos entre las tablas de Lindorm.

View table lineage information

Notas de uso

Puede usar Edit para modificar las notas de uso, o bien consultar View Versions para comprender el contexto empresarial de los datos.

View usage notes for a table

Gestionar favoritos de tablas

En la página de detalles de la tabla, agregue o quite una tabla de sus favoritos para acceder rápidamente a ella.

  1. Agregar o quitar de favoritos.

    • Agregar a Mis favoritos: Haga clic en el botón Add to Favorites debajo del nombre de la tabla para agregarla a Mis favoritos.

    • Quitar de Mis favoritos: Haga clic en el botón Remove from Favorites debajo del nombre de la tabla para eliminarla de Mis favoritos.

  2. Consultar sus tablas favoritas.

  3. En el panel de navegación izquierdo de Data Map, haga clic en el icono image. En el árbol de directorios, elija My Data > My Favorites para abrir la página My Favorites. En esta página, establezca Data Type en Lindorm para ver sus tablas favoritas de Lindorm.

Consultar información básica de una tabla

En la parte izquierda de la página de detalles de la tabla, consulte la Table Basic Information, la Technical Information y la Business Information.

  • Table Basic Information: incluye el Table Name, la fecha de creación (Created At) y si es una Partitioned Table.

  • Información técnica de la tabla: incluye la Path de almacenamiento, Input Format y Output Format.

  • Business Information: incluye la Region of Current Workspace y la Instance.

Consultar detalles de la tabla

En la página de detalles de la tabla, haga clic en la pestaña Details.

  1. Consultar información de campos.

    Consulte el nombre y el tipo de dato de cada campo en la tabla.

  2. Buscar campos.

    Si la tabla contiene muchos campos, introduzca el nombre del campo en el cuadro de búsqueda bajo Field Information para localizarlo rápidamente.

  3. Previsualizar descripciones de campos.

    Haga clic en Field Information bajo Recommended Field Desc. Copilot genera una descripción para ayudarle a comprender el significado y la finalidad de cada campo.

  4. Consultar el linaje de campos.

    Haga clic en el icono image en la columna Actions de un campo para consultar su linaje.

Consultar información de linaje de la tabla

El linaje de datos muestra las relaciones entre tablas y campos basándose en flujos de datos reales, como trabajos de programación analizados y sincronización de datos. En la página de linaje, puede consultar los nodos ascendentes y descendentes de una tabla o campo, rastrear el origen de los datos sin procesar e identificar la base de datos de destino de los datos de la tabla. También puede analizar el impacto del linaje en diferentes niveles.

Nota
  • La función de linaje de datos solo está disponible en DataWorks Standard Edition y versiones posteriores.

  • El linaje de tablas y campos se deriva de flujos de datos reales, como trabajos de programación analizados, para mostrar las relaciones entre tablas y campos. Esta es una operación estadística en tiempo real.

  • Si Data Map no puede mostrar adecuadamente el linaje de datos generado al ejecutar sentencias SQL en un nodo de Lindorm Spark SQL, puede configurar manualmente los parámetros de programación relevantes de DataWorks en el código del trabajo de Lindorm Spark SQL. Para obtener más información, consulte Attach a Lindorm computing resource. Las siguientes sentencias SQL pueden generar linaje de datos:

    • insert into /insert overwrite table

    • create as select from table

    • create table

    • create table like

Haga clic en la pestaña Lineage Information en la página de detalles de la tabla. Puede consultar el Table Lineage y el Field Lineage.

  • View Table Lineage

    • Consultar información básica: Pase el puntero del mouse sobre una tabla o tipo de nodo para ver los detalles.

    • Consultar el número de nodos ascendentes y descendentes: En el gráfico de linaje de la tabla, puede ver la cantidad de nodos ascendentes y descendentes de la tabla actual.

    • Expandir o contraer nodos: Según sea necesario, haga clic en el icono image o image en el gráfico de linaje para mostrar u ocultar los nodos ascendentes o descendentes correspondientes.

  • View Field Lineage

    • Change Field: En el área Change Field, puede seleccionar un campo diferente de la tabla actual para consultar su gráfico de linaje.

    • Consultar información básica: Pase el puntero del mouse sobre un campo o tipo de nodo para ver los detalles.

    • Consultar el número de nodos ascendentes y descendentes: En el gráfico de linaje del campo, puede ver la cantidad de nodos ascendentes y descendentes del campo actual.

    • Expandir o contraer nodos: Haga clic en el icono image o image en el gráfico de linaje para mostrar u ocultar los nodos ascendentes o descendentes correspondientes.

Consultar notas de uso de una tabla

Haga clic en la pestaña Instructions en la página de detalles de la tabla para usar Edit y modificar las notas, o bien consultar View Versions para dar seguimiento a la finalidad y el uso de la tabla a lo largo del tiempo.

  1. Editar notas de uso de la tabla.

    Haga clic en Edit. En el cuadro de diálogo que aparece, introduzca las notas de uso de la tabla actual y haga clic en Save.

  2. Consultar versiones históricas de las notas de uso.

    Haga clic en View Versions para ver un historial de todos los cambios. Desde este historial, puede hacer clic en View en la columna Actions de una versión específica para consultar las notas de uso de ese momento.