All Products
Search
Document Center

Elastic Desktop Service:CancelAutoSnapshotPolicy

Last Updated:Aug 28, 2026

Cancels an automatic snapshot policy for cloud computers.

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

No authorization for this operation. If you encounter issues with this operation, contact technical support.

Request parameters

Parameter

Type

Required

Description

Example

RegionId

string

Yes

The region ID. Call the DescribeRegions operation to query the most recent region list.

cn-hangzhou

PolicyId

string

No

The ID of the automatic snapshot policy.

sp-78lhzpe7kjfnd****

DesktopId

array

Yes

The cloud computer IDs. Specify 1 to 50 IDs. Each ID cannot be empty, can be up to 64 characters in length, and cannot contain http:// or https://. IDs cannot start with acs: or aliyun.

string

No

The ID of a cloud computer.

ecd-itcmrhqt01tdl****

Response elements

Element

Type

Description

Example

object

RequestId

string

The ID of the request.

51592A88-0F2C-55E6-AD2C-2AD9C10D****

Examples

Success response

JSON format

{
  "RequestId": "51592A88-0F2C-55E6-AD2C-2AD9C10D****"
}

Error codes

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.