This topic answers frequently asked questions about the client, including login errors, unexpected crashes, and how to report issues.
Index
Category | FAQ |
Installation and Uninstallation | |
Operation and Login | |
Features and Other Questions | Is local disk mapping supported when I use the web client to connect to a cloud computer? |
Installation and uninstallation
Update a terminal
Features and access points can vary by terminal type and client version. Refer to the UI on your device for the most accurate information.
After uninstalling the macOS client, the icon still remains. What should I do?
If the Alibaba Cloud Workspace client icon remains after you uninstall the macOS client, follow these steps to delete it.
Delete the icon from the Finder window or Launchpad.
Open Finder and click Applications in the Finder sidebar. In the search box, enter Alibaba Cloud Workspace. Alternatively, right-click the Alibaba Cloud Workspace icon in the Dock and choose Options > Show in Finder.
Right-click the Alibaba Cloud Workspace icon and click Move to Trash.
Delete the icon from the Trash or empty the Trash to permanently delete the icon.
Restart your Mac, and then uninstall the macOS client again.
Installation error: "The drive or UNC share you selected does not exist or is not accessible. Please select another"
Symptom
The Alibaba Cloud Workspace client installation fails with the error message: The drive or UNC share you selected does not exist or is not accessible. Please select another.
Cause
The client was previously installed on a removable hard drive or another disk that has since been disconnected.
Solution
Delete the relevant entry from the following registry path: \HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\
Operation and login
Error on launch: "VCRUNTIME140.dll was not found"
Symptom
When you open the client on a Windows computer, you receive the error message: The code execution cannot proceed because VCRUNTIME140.dll was not found. Reinstalling the program may fix this problem.
Solution
Manually install VC Runtime 2019.
If the error messageElastic Desktop Service cannot be opened because the identity of the developer cannot be verifiedis displayed when you open the client, what should you do?
Symptom
On a Mac computer (macOS 10.13 or 10.14), after double-clicking the macOS client icon, a dialog box appears with the message: "Alibaba Cloud Workspace" can't be opened because its developer cannot be verified.
Solution
Follow these steps to open the client:
On your Mac, open Finder and go to the Applications folder.
In the Applications folder, find Alibaba Cloud Workspace.
Right-click Alibaba Cloud Workspace and click Open in the context menu.
This issue occurs only the first time you open the client.
When I open the Windows client, it crashes. How can I fix this?
This issue might be caused by port 55556 being blocked. Follow these steps to resolve it:
Open the client installation directory.
By default, the path is
C:\Program Files (x86)\Wuying Cloud Computer.Open the
binfolder, find thesdbus_daemon.conffile, and open it with a text editor.Change the port number.
The default port is 55556. Change it to another unused port. The port number can range from 0 to 65535.
Relaunch the client.
If the issue persists, check whether the root certificate of the Windows operating system on your local computer has expired.
Login error: "Network request timed out"
Run the following command to check if your local network can access Elastic Desktop Service:
ping ecd.region.aliyuncs.comWhen you run the command, replace region with the ID of the region where the cloud computer resides. For example: ping ecd.cn-hangzhou.aliyuncs.com. If the ping command fails, check your local network connection.
What should I do if the error messageThis office network does not allow access from the XX network is displayed when I log on to the client?
This error indicates that your selected connection method is not allowed by the office network. Try a different connection method or contact your administrator to change the allowed connection methods for the office network.
If the error message Login with the office network ID of a RAM user is not supported is displayed when you log in to the client, what can you do?
Alibaba Cloud Workspace client versions 2.0.0 and later do not support logging in with an office network ID (formerly workspace ID) as a RAM user (in the format of ****@****.onaliyun.com). Contact your administrator to create a convenience user account.
Features and other questions
Does the web client support local disk mapping when you connect to a cloud computer?
No, local disk mapping is not supported, even if the policy associated with the cloud computer enables it. This means you cannot read data from or write data to your local disks from within the cloud computer.
You can click the Desktop Assistant on the cloud computer desktop and use the upload and download functions in the menu to transfer files between your local disks and the cloud computer.
If the upload and download functions are not available in the Desktop Assistant menu, contact your administrator to modify the policy for the cloud computer to allow file transfers for the web client.