Creates and binds tags to specified resources.
Operation description
Tags classify instances. Each tag consists of a key-value pair. Before you use tags, note the following limits:
-
The keys of tags that are added to the same instance must be unique.
-
Tags cannot exist without being bound to instances. All tags must be added to instances.
-
Tag information is not shared across regions.
For example, tags created in the China (Hangzhou) region are not visible in the China (Shanghai) region.
-
Virtual private clouds (VPCs), route tables, vSwitches, and elastic IP addresses (EIPs) under the same Alibaba Cloud account in the same region share tag information.
For example, if you add a tag to a VPC, that tag is available to vSwitches, route tables, and EIPs under the same account in the same region. You can select this tag from the editing page without re-entering it. You can modify the key or value of a tag, or remove a tag from an instance. After you delete an instance, all tags bound to it are deleted.
-
You can add up to 20 tags to each instance. The system automatically checks the number of existing tags and returns an error if the maximum is reached.
Try it now
Test
RAM authorization
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| ResourceType |
string |
Yes |
The resource type. Valid values:
|
VPC |
| ResourceId |
array |
Yes |
The resource ID. You can specify at most 20 IDs. |
vpc-bp16qjewdsunr41m1**** |
|
string |
No |
The resource ID. You can specify up to 20 resource IDs. Note
When you call this operation, ResourceId.N is required. |
vpc-bp16qjewdsunr41m1**** |
|
| RegionId |
string |
Yes |
The region ID of the resource. You can call the DescribeRegions operation to query the most recent region list. |
cn-hangzhou |
| Tag |
array<object> |
Yes |
The tag information. |
TagResources |
|
object |
No |
|||
| Key |
string |
No |
The tag key to add to the resource. You can specify up to 20 tag keys. The key cannot exceed 128 characters in length, cannot start with Note
When you call this operation, the Tag.N.Key parameter is required and cannot be an empty string. |
FinanceDept |
| Value |
string |
No |
The tag value to add to the resource. You can specify up to 20 tag values. The value cannot exceed 128 characters in length, cannot start with Note
When you call this operation, the Tag.N.Value parameter is required and can be an empty string. |
FinanceJoshua |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
The request ID. |
C46FF5A8-C5F0-4024-8262-B16B639225A0 |
Examples
Success response
JSON format
{
"RequestId": "C46FF5A8-C5F0-4024-8262-B16B639225A0"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidTagKey | The tag keys are not valid. | The tag index is invalid. |
| 400 | InvalidTagValue | The tag values are not valid. | The tag value is invalid. |
| 400 | MissingParam | %s | |
| 400 | InvalidInstanceType.NotFound | The instance type is not found | The instance type is not found. |
| 400 | InvalidInstanceIds.NotFound | The instanceIds are not found | The instance ID is not found. |
| 400 | Forbidden.TagKeys | The request do not allow to operate the tag keys | You do not have the permissions to set the TagKeys parameter. |
| 400 | QuotaExceeded.TagNum | Custom Tags quota exceeded | The upper limit is reached. |
| 400 | InvalidTagScope.NotFound | The tag scope is not found | The resource scope is invalid. |
| 400 | Forbidden.NotAllowedCategary | The System tag is not valid | The error message returned because the system tag is invalid. |
| 400 | Forbidden.TagKey.Duplicated | The specified tag key already exists. | The tag resources are duplicate. |
| 400 | SizeLimitExceeded.TagNum | The maximum number of tags is exceeded. | The number of tags has reached the upper limit. |
| 400 | SizeLimitExceeded.ResourceId | The maximum number of resource IDs is exceeded. | The number of resource group IDs has reached the upper limit. |
| 400 | MissingParameter.TagValue | The input parameter TagValue that is mandatory for processing this request is not supplied. | The TagValue parameter is not set. |
| 400 | MissingParameter.TagKey | The input parameter TagKey that is mandatory for processing this request is not supplied. | The TagKey parameter is not set. |
| 400 | MissingParam.Tags | You must specify the Tags parameter. | The error message returned because the Tags parameter is not set. |
| 400 | DuplicatedParam.ResourceIds | The parameter of ResourceIds contains duplicate values. | |
| 403 | Forbidden | User not authorized to operate on the specified resource. | You do not have the permissions to manage the specified resource. Apply for the permissions and try again. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.