Creates an IP Address Manager (IPAM) instance.
Operation description
-
Each Alibaba Cloud account supports only one IPAM per region.
-
IPAM supports only IPv4 addresses.
-
When you create an IPAM instance:
-
If no custom resource discovery exists in the region, the system creates a default resource discovery and associates it with the IPAM instance.
-
If a custom resource discovery exists in the region, the system converts it to the default resource discovery and associates it with the IPAM instance.
-
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
vpc:CreateIpam |
create |
*All Resource
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| RegionId |
string |
Yes |
The region ID of the IPAM instance. Call DescribeRegions to query available regions. |
cn-hangzhou |
| IpamName |
string |
No |
The IPAM name. The name must be 1 to 128 characters and cannot start with |
abc |
| OperatingRegionList |
array |
Yes |
The operating regions of the IPAM. |
|
|
string |
No |
The operating region of the IPAM. Note
You can specify one or more regions. |
cn-hangzhou |
|
| IpamDescription |
string |
No |
The IPAM description. Must be 1 to 256 characters. Must start with a letter and cannot start with |
This is my first Ipam |
| ResourceGroupId |
string |
No |
The resource group ID. |
rg-acfmxazb4ph6aiy**** |
| DryRun |
boolean |
No |
Specifies whether to perform a dry run. Valid values:
|
false |
| ClientToken |
string |
No |
The client token that ensures request idempotence. Generate a unique token per request. Only ASCII characters are allowed. Note
If not specified, the system uses the request ID as the client token. The request ID may differ for each request. |
123e4567-e89b-12d3-a456-426655440000 |
| Tag |
array<object> |
No |
The tags. |
|
|
object |
No |
The tags. |
||
| Key |
string |
No |
The tag key. You can specify up to 20 tag keys. Cannot be empty. Maximum 64 characters. Can contain letters, digits, periods (.), underscores (_), and hyphens (-). Must start with a letter and cannot start with |
FinanceDept |
| Value |
string |
No |
The tag value. You can specify up to 20 tag values. Empty strings are allowed. Maximum 128 characters. Cannot contain |
FinanceJoshua |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
The response parameters. |
||
| RequestId |
string |
The request ID. |
0ED8D006-F706-4D23-88ED-E11ED39DCAC0 |
| IpamId |
string |
The ID of the IPAM. |
ipam-ccxbnsbhew0d6t**** |
| PrivateDefaultScopeId |
string |
The ID of the default private scope created with the IPAM. |
ipam-scope-8wiontzmiy6cg0**** |
| PublicDefaultScopeId |
string |
The ID of the default public scope created with the IPAM. |
ipam-scope-r5c5c7bmym1brc**** |
| DefaultResourceDiscoveryId |
string |
The ID of the default resource discovery instance. |
ipam-res-disco-jt5f2af2u6nk2z321**** |
| DefaultResourceDiscoveryAssociationId |
string |
The ID of the default resource discovery association. |
ipam-res-disco-assoc-jt5fac8twugdbbgip**** |
| ResourceDiscoveryAssociationCount |
integer |
The number of discovered resources. |
1 |
Examples
Success response
JSON format
{
"RequestId": "0ED8D006-F706-4D23-88ED-E11ED39DCAC0",
"IpamId": "ipam-ccxbnsbhew0d6t****",
"PrivateDefaultScopeId": "ipam-scope-8wiontzmiy6cg0****",
"PublicDefaultScopeId": "ipam-scope-r5c5c7bmym1brc****",
"DefaultResourceDiscoveryId": "ipam-res-disco-jt5f2af2u6nk2z321****",
"DefaultResourceDiscoveryAssociationId": "ipam-res-disco-assoc-jt5fac8twugdbbgip****",
"ResourceDiscoveryAssociationCount": 1
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | UnsupportedRegion.Ipam | Ipam is not supported in this region. | IPAM is not supported in this region. |
| 400 | QuotaExceeded.IpamQuotaPerRegion | The quota of ipamQuotaPerRegion count is exceeded. | The maximum number allowed by IPAM exceeds the limit. |
| 400 | IllegalParam.OperatingRegion | The operating region is invalid. | The operating region is invalid. |
| 400 | DryRunOperation | Request validation has been passed with DryRun flag set. | |
| 400 | OperationFailed.OperatingRegionsNeedIncludeIpamRegion | The operating regions do not contain IPAM region. | The operating regions do not contain IPAM region. |
| 400 | UnsupportedFeature.Ipam | IPAM is not supported in this region. | The IPAM feature is not supported in this region. |
| 400 | OptInRequired.Ipam | You are not authorized to use the requested service of IPAM. Ensure that you have subscribed to the service you are trying to use. | You are not authorized to use the requested service of IPAM. Ensure that you have subscribed to the service you are trying to use. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.