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Server Migration Center:What do I do if I receive an S10 error code indicating an error during the test to synchronize files stored in disk partitions?

Last Updated:Jan 10, 2025

This topic describes the cause of the "S10_* An error occurred in the test for data synchronization of files in the disk partition." error message that is reported when you use Server Migration Center (SMC) to run a migration job. This topic also describes how to resolve the error.

Problem description

During an SMC migration job, the "S10_* An error occurred in the test for data synchronization of files in the disk partition." error message is reported. The following S10_* error codes may be reported:

  • S10_R255

  • S10_R1

Cause

The error may occur during the test to synchronize files stored in disk partitions due to the following causes:

  • S10_R255: The source server cannot access the IP address of the destination instance by using port 8703.

  • S10_R1: The rsync version of the source server is not supported.

Solution

Resolve the error based on the error code.

  • S10_R255

    Check whether the source server can access the IP address of the destination instance by using port 8703.

    1. Check whether the security group of the destination instance allows inbound traffic from port 8703. If yes, check whether a security group rule forbids inbound traffic from port 8703.

      Note

      By default, an SMC migration job automatically associates a temporary security group with the destination instance to allow inbound traffic from port 8703.

    2. Run the telnet command to test whether the source server can access port 8703 of the destination instance. If the test fails, check the local network configurations or intermediate network devices. For example, check whether the required IP address and port are blocked by the firewall or whether the proxy server forbids outbound traffic to the required IP address and port.

  • S10_R1

    Run the rsync --version command to check the rsync version on the source server.

    We recommend that you use rsync 3.0.6 or later. The latest version of rsync is 3.1.3. In addition, check whether the installed rsync supports ACL preservation. If the return result does not include "ACLs", the installed rsync does not support ACL preservation. You must reinstall rsync and try again.

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After the error is resolved, run the SMC client and retry the migration job. For more information, see Run the SMC client.