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:Import data from CloudMonitor to Simple Log Service

Last Updated:May 28, 2024

This topic describes how to import data from CloudMonitor to a Metricstore in Simple Log Service. After you import data from CloudMonitor to a Metricstore in Simple Log Service, you can query, analyze, and transform the data.

Prerequisites

Create a data import configuration

  1. Log on to the Simple Log Service console.

  2. On the right side of the page that appears, click the Quick Data Import card.

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  3. Click the CloudMonitor Data card and complete the configuration wizard.

  4. Select the project and Logstore. Then, click Next.

  5. In the Import Configuration step, configure the parameters and click Next.

    Parameter

    Description

    Job Name

    The name of the data import configuration.

    Display Name

    The display name of the data import job.

    Job Description

    The description of the data import job.

    Import All

    Select Yes to import all metric data from CloudMonitor to Simple Log Service. For more information, see Predefined metrics.

    Namespace

    If you select No for the Import All parameter, select the metrics that you want to import from the NameSpace drop-down list.

    AccessKey ID

    The AccessKey ID of your Alibaba Cloud account.

    We recommend that you use the AccessKey pair of a Resource Access Management (RAM) user that is granted the AliyunCloudMonitorReadOnlyAccess permission.

    AccessKey Secret

    The AccessKey secret of your Alibaba Cloud account.

View a data import configuration

After you create a data import configuration, you can view the details of the data import configuration and the generated reports in the Simple Log Service console.

  1. In the Projects section, click the project that you want to manage.

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  2. On the Log Storage > Logstores tab, find the Logstore that you want to manage, choose Data Collection > Data Import, and then click the name of the data import configuration.

    image

  3. On the Import Configuration Overview page, view Basic Information and Statistical Report of the data import configuration. You can view reports on the Data Processing Insight dashboard.

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Related operations

In the upper-right corner of the Import Configuration Overview page, you can also perform the following operations:

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Modify the data import configuration.

To modify the data import configuration, click Edit Configurations. For more information, see Create a data import configuration.

Delete the data import configuration.

To delete the data import configuration, click Delete Configuration.

Important

After a data import configuration is deleted, it cannot be restored. Proceed with caution.

Stop the data import job.

To stop the data import job, click Stop.

FAQ

Some metrics cannot be found.

  • Possible cause: If Hybrid Cloud Monitoring API is used to pull data, some virtual metrics cannot be pulled.

  • Solution: If you can query the metrics by calling the DescribeMetricList operation, the issue occurs because the metrics are not supported by Hybrid Cloud Monitoring API. To resolve this issue, submit a ticket to CloudMonitor technical support.

Long data latency exists.

  • Possible causes:

    • Latency exists when metrics are collected from data sources.

    • The API quota of CloudMonitor is exhausted.

    • The network is unstable.

    For more information, see Limits.

  • Solution:

    • For metrics in the acs_global_acceleration namespace, long latency exists when the metrics are reported from data sources to CloudMonitor. Therefore, when the metrics are imported to Simple Log Service, long latency also exists. The latency ranges from 10 to 15 minutes.

    • Reduce the number of namespaces from which data is imported or submit a ticket to CloudMonitor technical support to request an increase in the API quota.

    • Use a Simple Log Service project in regions where CloudMonitor is deployed, such as the China (Hangzhou) and China (Shanghai) regions.

Error handling

Item

Description

Error handling method

After an error occurs, the data import job retries at a regular interval until the job is recovered. You can view the number of errors on the Data Processing Insight dashboard.

If the data import job is recovered within 3 hours, the job continues to pull data from the position at which the job stops pulling data due to the error. Otherwise, the data import job continues to pull data from the latest position regardless of the stop position.