This topic provides examples on how to handle errors for the job monitoring dashboard of a project in CloudLens for SLS.
An Alibaba Cloud account has full permissions on all of its resources. Therefore, you can use your Alibaba Cloud account to manage CloudLens for SLS without the need for additional permissions. If you want to use a RAM user, you must make sure that the RAM user is granted the read-only or read and write permissions on CloudLens for SLS. For more information, see Grant a RAM user the permissions to manage CloudLens for SLS.
Preparations
The job monitoring dashboard of Project A depends on job operational logs. However, the logs may not be stored in Project A. Before you handle errors, you must perform the following steps to determine the project in which the job operational logs are stored:
Log on to the Simple Log Service console.
In the Projects section, click Project A.
In the upper-left corner of the page, click the
icon. On the Service Log tab, click the
icon. In the Modify Service Log Settings panel, view the name of the project where the service logs of Project A are stored in the Log Storage Location section.
ImportantIf the service log feature is not enabled, we recommend that you enable the feature.

Handle an error that is reported on a job monitoring dashboard
Description
When you open the Data Shipping Overview page of a job that belongs to a specific project, the The query failed error message is displayed, and no data is displayed in the report.
Cause
Job operational logs are stored in the Logstore named internal-diagnostic_log of the specified project. If the indexes of the Logstore are deleted or are not updated at the earliest opportunity, Simple Log Service cannot monitor the jobs of the specified project.
Solution
In the CloudLens for SLS application, find the job monitoring dashboard of the project in which job operational logs are stored and reconfigure indexes. For more information about how to determine the project in which job operational logs are stored, see Preparations.
- Log on to the Log Service console.
In the Log Application section, click the Cloud Service Lens tab. Then, click CloudLens for SLS.

In the left-side navigation pane, choose .
In the upper-left corner of the page that appears, find the project that you want to manage.
In the upper-right corner of the page, click Reset Indexes.

In the message that appears, click OK.
Handle the error that no data can be found on a job monitoring dashboard
Description
When you open the Data Shipping Overview page of a job that belongs to a specific project, no data is displayed in the report.
Cause
If the collection feature of job operational logs is disabled for the specified project, Simple Log Service cannot monitor your job data, obtain the operational logs of your job, or display the operational logs on a job monitoring dashboard.
Solution
Find the project and enable the collection feature of job operational logs for the project.
- Log on to the Log Service console.
In the Log Application section, click the Cloud Service Lens tab. Then, click CloudLens for SLS.

The following page is displayed. Click Enable and follow the instruction to enable the collection feature.
