Adds custom IP blocking policies for one or more specific servers based on your requirements.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
yundun-sas:CreateCustomBlockRecord |
create |
*All Resource
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| Uuids |
string |
Yes |
The UUIDs of the asset instances. Separate multiple UUIDs with commas (,). You can call DescribeCloudCenterInstances to obtain the UUIDs of asset instances. |
71c846d6-5c84-4714-acfc-58265bc3****,5013b5e8-1613-43a8-b4de-651db318****,df53f0ad-b3ba-4fe0-9ec7-f42a2ae2**** |
| BlockIp |
string |
Yes |
The IP address to block. Traffic from this IP address to the server is blocked. |
192.168.xx.xx |
| Bound |
string |
Yes |
The direction of traffic to block between the custom IP address and the server. Valid values:
|
in |
| ExpireTime |
integer |
Yes |
The expiration time of the policy. This value is a UNIX timestamp in milliseconds. |
1859094550000 |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
The request ID, which is a unique identifier generated by Alibaba Cloud for the request. You can use this ID to troubleshoot issues. |
30CBF632-109F-596F-97F2-451C8B2A**** |
Examples
Success response
JSON format
{
"RequestId": "30CBF632-109F-596F-97F2-451C8B2A****"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | RuleRecordIsExists | Rule record already exists. | The rule already exists. |
| 500 | ServerError | ServerError | |
| 403 | NoPermission | caller has no permission | You are not authorized to do this operation. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.