This topic describes the possible causes of Ethernet connection failures and provides solutions.

Symptoms

The Ethernet port is not connected.

Causes

  • The device is not powered on or the cable is not fully plugged into the Ethernet port.
  • Overlength of optical fibers or twisted pair cables, or excessive optical losses.
  • The port, port module, SAG device, or peer device is faulty.

Solutions

  1. Check whether both the local and peer SAG devices are powered on, and whether the cable and port module are correctly connected.
  2. Check whether the cable or port module of both devices is faulty.
    If the devices are connected by a twisted pair cable, check the following items.
    Check itemCriteriaSolution
    Use a tester to test whether the twisted pair cable is faulty. The tester shows that the twisted pair cable is working as expected. If the twisted pair cable is faulty, replace it.
    Measure whether the length of the twisted pair cable meets the requirement. The cable between the devices cannot exceed 100 meters in length.
    Note 10/100/1000 Mbit/s electrical ports use RJ45 connectors. Category 5 or later cables support a maximum transmission distance of 100 meters.
    If the twisted pair cable exceeds 100 meters in length, choose one of the following solutions:
    • Shorten the distance between the SAG and peer devices to shorten the length of the twisted pair cable.
    • If you cannot shorten the distance, you can use a repeater, a hub, or a switch to connect the SAG and peer devices in series.
    Check whether you are using the correct type of twisted pair cable. Twisted pair cables are classified into two types: crossover and straight-through cables.
    A straight-through cable is used to connect Ethernet ports of the following devices:
    • A router and a hub.
    • A router and an Ethernet switch.
    • A computer and an Ethernet switch.
    • A computer and a hub.
    A crossover cable is used to connect Ethernet ports of the following devices:
    • Two routers.
    • A router and a computer.
    • Two hubs.
    • A hub and a switch.
    • Two switches.
    • Two computers.
    Use the correct type of twisted pair cable.
    If the devices are connected by an optical fiber, check the following items.
    Check itemCriteriaSolution
    Check whether the optical module matches the optical fiber based on the following rules:
    • A multi-mode optical fiber works with a multi-mode optical module.
    • A single-mode optical fiber works only with a single-mode optical module, and does not work with a multi-mode optical module. A single-mode optical fiber is typically yellow, whereas a multi-mode optical fiber is typically orange.
    • The wavelength of two connected optical modules must be the same.
    Use an optical module and optical fiber that match each other.
    Check whether the length of the optical fiber falls into the transmission distance range supported by the optical module. The length of the optical fiber must be smaller than the transmission distance supported by the optical module. Shorten the length of the optical fiber or use an optical module that supports a longer transmission distance.
    Use a tester to test whether the signal attenuation falls into the valid range. Check whether the attenuation of the optical fiber falls within the valid range. If the attenuation exceeds the valid range, replace the optical fiber. If the issue persists after you replace the optical fiber, shorten the length of the optical fiber.
    Use a tester or perform physical loopback testing to check whether the cable is faulty. When you use a tester, the result shows that the cable is working as expected.

    To perform physical loopback testing, connect both ends of the cable to the same optical module. If the port is enabled, the cable is working as expected.

    If the cable is faulty, replace it. If the issue persists after you replace the cable, replace the optical module.
  3. Check whether the local or peer SAG device is faulty.