Modifies the configuration items of an ApsaraDB RDS instance.
Operation description
Supported engines
ApsaraDB RDS for PostgreSQL
ApsaraDB RDS for SQL Server
Currently supported configuration items include ApsaraDB RDS for PostgreSQL PgBouncer, ApsaraDB RDS for PostgreSQL cloud disk encryption, ApsaraDB RDS for SQL Server cloud disk encryption, and ApsaraDB RDS for SQL Server error log cleanup.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
rds:ModifyDBInstanceConfig |
none |
*DBInstance
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| DBInstanceId |
string |
Yes |
The instance ID. You can call DescribeDBInstances to obtain the instance ID. |
pgm-2ze**** |
| ConfigName |
string |
Yes |
The name of the configuration item to modify. This parameter is used together with ConfigValue. |
pgbouncer |
| ConfigValue |
string |
Yes |
The value of the configuration item to modify. This parameter is used together with ConfigName. |
true |
| ResourceGroupId |
string |
No |
The resource group ID. You can call DescribeDBInstanceAttribute to obtain the resource group ID. |
rg-bp67acfmxazb4p**** |
| ClientToken |
string |
No |
The client token that is used to ensure the idempotence of the request. You can use the client to generate the token, but you must make sure that the token is unique among different requests. The token can contain only ASCII characters and cannot exceed 64 characters in length. |
6000170000591aed949d0f**** |
| SwitchTime |
string |
No |
The time at which the modification takes effect. We recommend that you perform specification changes during off-peak hours. Format: yyyy-MM-ddTHH:mm:ssZ (UTC). |
2025-05-06T09:24:00Z |
| SwitchTimeMode |
string |
No |
The switchover time. Valid values:
|
Immediate |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
The response parameters. |
||
| RequestId |
string |
The request ID. |
76364A52-E0AB-5CC8-9818-CF1DC482C092 |
Examples
Success response
JSON format
{
"RequestId": "76364A52-E0AB-5CC8-9818-CF1DC482C092"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | %s | DB Operation Failed:%s. | |
| 400 | InvalidDBInstanceName.NotFound | The specified DB instance name does not exist. | The instance name does not exist. |
| 400 | MinorVersionNotSupport | The current database minor version does not support the operation. | The current instance kernel iteration does not support this operation. You can upgrade the kernel iteration. |
| 400 | InvalidConfigName | The ConfigName is not valid. | The specified ConfigName is invalid. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | A package instance is not allowed to operate independently. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | Pricing plan price result not found. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | Your account available limit is less than 0, please recharge before trying to purchase. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | Failed to call commodity service return. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | The module you purchased is not legal, please buy it again. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | Hello customer, this area has been abolished. |
| 400 | Price.CommoditySys | Commodity system call exception. | Commodity system call exception. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | Insufficient available balance. |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | There is a problem with the period you selected, please choose again. |
| 400 | pay.noCreditCard | Account not bound to credit card. | The account is not bound to a credit card. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | No payment method has been specified for your account. We recommend that you add a payment method. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Your basic information is not complete, please complete your basic information before operation. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Your account is abnormal, please contact customer service for details. |
| 400 | Api.NotSupport | Specified api is not supported. | The current interface does not support. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | The DBInstanceId provided does not exist. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | The current instance type does not support the specified storage type. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica. |
| 400 | KmsApiError | User secret key invalid. | The user key is invalid. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | A system error occurs when the sales expression is verified. |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | The account does not exist. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL command execution failed or timed out |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | The current instance engine version not support coldDataEnabled. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | The current instance minor version not support coldDataEnabled. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | This operation is not supported by the instance type. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | The link address name is duplicate. Please reset the connection string. |
| 400 | RequiredParam.NotFound | Required input param is not found. | A required parameter is missing. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | Parameter error, please check the parameters. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | The instance status does not support this operation. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | Specified Released Keep Policy is not valid. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | This operation is not supported for the database engine of the instance. |
| 400 | Pay.NoCreditCard | No credit cards. | No credit cards. |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | The vpc network type instance does not support this operation. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | Specified DB instance mirror ins already existed. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | The specified DB instance class stops selling. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | The specified database does not exist in the backup set. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Failed to query product. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | The instance has been released, please verify and place an order. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | The region is no longer supported. |
| 400 | InvalidSourceCategory | specified source category is invalid. | The specified source category is invalid. |
| 400 | InvalidParameter | Invalid parameter. | The values of some parameters are invalid. |
| 400 | InvalidConfigValue | The ConfigValue is not valid. | The operation failed. The values of some parameters are invalid. |
| 400 | InvalidParameters.Format | Specified parameters is not valid. | The values of some parameters are invalid. |
| 400 | DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance | Current instance is already attached to another duckdb instance, operation is conflict. | The current instance is already associated with another DUCKDB instance, which conflicts with the current DUCKDB operation. |
| 400 | KmsServiceLinkedRoleNotGranted | The service linked role is not granted, please check. | The service association role is not authorized. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | The request processing has failed due to external service failure. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | The service request failed. Please try again later or contact service personnel. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | The request failed to be processed due to an RDS API failure. |
| 403 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | The operation failed. The RDS instance is not in a ready state. |
| 403 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | The operation failed. The current instance status does not support this operation. Try again later. |
| 403 | CloudDiskEncryptionNotSupport | The encryption key is not allowed for general-purpose instance. | Universal instances do not support cloud disk encryption. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | The instance has an unpaid order. Please pay first and try again. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | The scale-in target capacity cannot be less than the current storage space usage |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | SSD cloud disks do not support this operation. Upgrade to ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | The user is not authorized to perform this operation. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | The specified VSwitchId is in an invalid format or is empty. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | This operation is not supported for the current minor engine version. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | There is no available zone for inventory. |
| 403 | NotInFlowController | Sorry,no permission. | Sorry,no permission. |
| 403 | InvalidKmsKey | Kms key is disabled. | The KMS key is disabled. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | The specified database instance type does not support this operation. |
| 403 | UnsupportedByBlueGreenDeployment | Operation prohibited due to blue green deployment. | The operation is not allowed because a blue-green deployment exists. |
| 403 | EncryptionKeyNotSupport | The encryption key is not support to generate encryption disk. | This key does not support creating cloud disk encryption instances. |
| 403 | IncorrectDBState | The current DB state does not support this operation. | The operation failed. The RDS instance is not in a ready state. For example, the RDS instance is being created or is receiving data from a migration task. |
| 403 | UnsupportedReadOrBakReadState | Current DB instance has read or bak read running in unsupport states | The current instance is in the unsupported read or bak read state. |
| 403 | IncorrectAccountPrivilegeType | the current account privilege type does not support this operation. | The permission type of the current account does not support this operation. |
| 403 | DBInstanceStatusNotActive | The status of the current instance is not active. | The operation failed. Check the status of the RDS instance. |
| 403 | ReadOnlyInstanceNotSupport | Read-only instance does not support this operation. | This operation is not supported for read-only instances. |
| 403 | Invalid.Parameter | Specified parameters is not valid. | The specified parameter is invalid. |
| 403 | TargetMajorVesionNotSupported | The specified major version is not supported. | Target large version not supported |
| 403 | ReadInstanceNotSupport | Instances with read-only do not support this operation. | Instances with read-only instances do not support this operation. |
| 403 | IncorrectDBInstance | The current DB instance does not support this operation. | The operation failed. The operation is not supported for the RDS instance. |
| 404 | InvalidDBInstance.NotFound | Specified instance does not exist or not support. | The RDS instance cannot be found, is deleted, or does not support the operation. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | The instance does not have permissions to access Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | The requested resources are unavailable. |
| 404 | HostInfo.NotFound | The specified host info is not found. | The specified host information does not exist. |
| 404 | InvalidAccountName.NotFound | The specified account is not found. | The account was not found. If you are creating an account or resetting your password, please specify your account. |
| 404 | InvalidReadDBInstance.NotFound | The specified read only database instance does not exist. | The read-only RDS instance is not created, or the values of the request parameters are invalid. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.