Modifies the retention period of files in the recycle bin of a General-purpose NAS file system.
Operation description
Only General-purpose NAS file systems support this operation.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
nas:UpdateRecycleBinAttribute |
update |
*FileSystem
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| FileSystemId |
string |
Yes |
The ID of the file system. |
1ca404**** |
| ReservedDays |
integer |
Yes |
The retention period of files in the recycle bin, in days. Valid values: 1 to 180. Default value: 3. |
3 |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
The response object. |
||
| RequestId |
string |
The request ID. |
BC7C825C-5F65-4B56-BEF6-98C5****546E |
Examples
Success response
JSON format
{
"RequestId": "BC7C825C-5F65-4B56-BEF6-98C5****546E"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | IllegalCharacters | The parameter contains illegal characters. | The parameter contains illegal characters. |
| 400 | MissingFileSystemId | FileSystemId is mandatory for this action. | |
| 403 | OperationDenied.RecycleBinDisabled | The operation is denied because the recycle bin is disabled. | The operation is denied because the recycle bin is disabled. |
| 404 | InvalidFileSystem.NotFound | The specified file system does not exist. | The specified file system does not exist. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.