Disables and empties the recycle bin of a General-purpose NAS file system.
Operation description
-
Only General-purpose NAS file systems support this operation.
-
Disabling the recycle bin permanently deletes all files in it.
-
If you re-enable the recycle bin after disabling it, the recycle bin is empty and previously deleted files cannot be retrieved.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
nas:DisableAndCleanRecycleBin |
update |
*FileSystem
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| FileSystemId |
string |
Yes |
The ID of the file system. |
1ca404**** |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
Schema of Response |
||
| RequestId |
string |
The request ID. |
9E15E394-38A6-457A-A62A-D9797C9A**** |
Examples
Success response
JSON format
{
"RequestId": "9E15E394-38A6-457A-A62A-D9797C9A****"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | IllegalCharacters | The parameter contains illegal characters. | The parameter contains illegal characters. |
| 400 | MissingFileSystemId | FileSystemId is mandatory for this action. | |
| 403 | OperationDenied.RecycleBinDisabled | The operation is denied because the recycle bin is disabled. | The operation is denied because the recycle bin is disabled. |
| 404 | InvalidFileSystem.NotFound | The specified file system does not exist. | The specified file system does not exist. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.