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Microservices Engine:How do I troubleshoot issues that occur when Microservices Governance is enabled for microservice applications in an ACK cluster

Last Updated:Sep 12, 2023

Problem description

When you enable Microservices Governance for an application in a Container Service for Kubernetes (ACK) cluster, the following issues may occur:

  • No information about the application is displayed in the Microservices Engine (MSE) console.

  • The application name is displayed in the MSE console, but the number of instances is 0.

  • MSE Microservices Governance is enabled for the application, the displayed number of instances is accurate, but the service metadata is missing on the service details page.

Possible causes

The preceding issues may occur due to the following reasons:

  • The operations for enabling Microservices Governance are incorrect.

  • MSE does not support the version of the application for which you want to enable Microservices Governance.

Solution

  1. Check whether MSE supports the application version. If your application is a Spring Cloud application, only Edgware or later is supported.

  2. Check whether the application starts or is called as expected based on the operational logs of the application.

    1. Log on to the ACK console.

    2. In the left-side navigation pane, click Clusters.

    3. On the Clusters page, find the ACK cluster in which your application is deployed, and click the cluster name or click Details in the Actions column.

    4. In the left-side navigation pane of the Cluster Information page, choose Workloads > Deployments.

    5. On the Deployments page, click the name of your application. On the Logs tab, view log details.

      Note

      Select 500 for Lines. This way, you can view all logs.

  3. If no exceptions are found after you perform the preceding operations, check whether the MSE agent is installed on the application. Execute the service_metadata_diagnosis script on the application terminal to perform diagnostics and obtain the diagnostics result.

    wget -O - https://edas-public.oss-cn-hangzhou.aliyuncs.com/oneAgent/service_metadata_diagnosis.sh | sh -s

    • If the Java agent version is not displayed in the diagnostic results, the MSE agent is not installed on the application. In this case, check whether Microservices Governance is enabled for the namespace to which your application belongs. For more information, see Enable Microservices Governance for microservice applications in an ACK cluster.

    • If no relevant files are displayed in the diagnostic results, log files may be missing because the application starts when the MSE agent is not installed on the application. In this case, check the YAML configuration file of the application.

    • If the configurations are correct but no service records are displayed, check whether the application version is supported by MSE.

  4. If the issue persists after you perform the preceding operations, submit a ticket.

    We recommend that you include the following information in your ticket:

    • User account ID.

    • Region. Example: China (Shanghai).

    • Product. Example: MSE or Enterprise Distributed Application Service (EDAS).

    • Issue description.

    • Complete application startup logs

    • Diagnostic results obtained by using the script.

    • Optional. The kubeconfig file of the ACK cluster in which your application is deployed. For more information about how to obtain the kubeconfig file, see Generate a temporary kubeconfig file.