No workers available (no worker available)
Issue description
No workers are available, and the system displays a "no worker available" message.
Cause
This issue may be caused by an incorrect configuration.
Solution
Log on to the worker and check the SchedulerX log. The log is stored in the /${user.home}/logs/schedulerx/worker.log path.
If the process was started by the admin account, the log path is /home/admin/logs/schedulerx/worker.log.
If the process was started by the root account, the log path is /root/logs/schedulerx/worker.log.
Search for the WorkerConfig keyword and check whether the Endpoint, Namespace, and GroupId parameters are configured correctly.
Application release error: DomainNotFoundException
Issue description
Caused by: com.alibaba.schedulerx.worker.exception.DomainNotFoundException: Not found domainName
Cause
The endpoint does not match the environment.
Solution
Check whether online workers use the correct endpoint. Local workers can connect only to the endpoint of the Internet region. For more information about the endpoints that SchedulerX supports, see Endpoints.
Application release error: can not find namespaceId
Issue description
The application reports the following error at startup.
can not find namespaceId, key: d783212a9c-5a00-4d00-b8ca-b7a68824c97f
source:schedulerx domain=schedulerx-test.console.aliyun.comCause
The Namespace parameter is configured incorrectly.
The region of the machine on which the application is deployed is different from the region of the namespace that is created in the SchedulerX console.
For example, the namespace is created in the China (Hangzhou) region, but the access region configured for the current application is the Internet.
Solution
Log on to the MSE SchedulerX console. On the Applications page, click Access Config to verify the information.
How to test local connections in SchedulerX
In the SchedulerX console, switch the region to Internet. Then, create an application in the Internet region and connect to it. For more information, see Connect to SchedulerX over the Internet from an on-premises environment.

What to do if a local SchedulerX proxy cannot connect to the internet
If you have a direct internet connection but cannot connect in proxy mode, you must specify an endpoint. For more information about the regions where you can deploy applications and their corresponding endpoints, see Endpoints.
Domain name resolution fails in a self-managed IDC or office network over a leased line
After you connect over a leased line, you must configure forwarding management. This forwards the DNS requests for internal domain names in your Alibaba Cloud VPC to an external DNS system. Your self-managed Internet Data Center (IDC) or office network can then correctly resolve the domain names.