Deletes media files from ApsaraVideo Media Processing (MPS).
Operation description
Logically deletes a media file. The media file can no longer be processed, but the corresponding objects in the input and output Object Storage Service (OSS) buckets are retained.
QPS limit
You can call this operation up to 100 times per second per account. Requests that exceed this limit are dropped, which may cause service interruptions. For more information, see QPS limit.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
mts:DeleteMedia |
delete |
*All Resource
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| MediaIds |
string |
Yes |
The IDs of the media files that you want to remove. Separate multiple IDs with commas (,). You can remove up to 10 media files at a time. Note
You can obtain the ID of the media file from the response parameters of the AddMedia operation. Alternatively, you can log on to the MPS console. In the left-side navigation pane, choose Media Management > Media List. Find the required video and click Manage in the Actions column. The ID of the video is displayed on the Basics tab. |
3e1cd21131a94525be55acf65888****,3e6149d5a8c944c09b1a8d2dc3e4**** |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
The ID of the request. |
05F8B913-E9F3-4A6F-9922-48CADA0FFAAD |
Examples
Success response
JSON format
{
"RequestId": "05F8B913-E9F3-4A6F-9922-48CADA0FFAAD"
}
Error codes
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.