All Products
Search
Document Center

:Troubleshooting method for IoT Platform to use MQTT to troubleshoot no messages after the platform is successfully published

Last Updated:Jul 15, 2021

Problem description

After IoT Platform uses MQTT, the platform does not receive messages.

Cause

It may be caused by the following reasons:

  • The device is not normally connected to IoT Platform.
  • The error message returned because the TSL parsing log is abnormal.

Solutions

Refer to the following steps for troubleshooting:

  • Ensure that the device is connected to the IoT Platform. For more information, see Use MQTT.fx to connect to IoT Platform.
  • Log on to IoT Platform. In the left-side navigation pane, choose Monitoring Operations > Log Service > Cloud Run Log to check whether the logs are received.
  • TSL parsing logs must be parsed properly for data to be displayed in the running status. For more information, see What is TSL.

Applicable scope

  • IoT Platform