All Products
Search
Document Center

Global Accelerator:UpdateEndpointGroupAttribute

Last Updated:Aug 28, 2026

Modifies the name and description of an endpoint group.

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

The table below describes the authorization required to call this API. You can define it in a Resource Access Management (RAM) policy. The table's columns are detailed below:

  • Action: The actions can be used in the Action element of RAM permission policy statements to grant permissions to perform the operation.

  • API: The API that you can call to perform the action.

  • Access level: The predefined level of access granted for each API. Valid values: create, list, get, update, and delete.

  • Resource type: The type of the resource that supports authorization to perform the action. It indicates if the action supports resource-level permission. The specified resource must be compatible with the action. Otherwise, the policy will be ineffective.

    • For APIs with resource-level permissions, required resource types are marked with an asterisk (*). Specify the corresponding Alibaba Cloud Resource Name (ARN) in the Resource element of the policy.

    • For APIs without resource-level permissions, it is shown as All Resources. Use an asterisk (*) in the Resource element of the policy.

  • Condition key: The condition keys defined by the service. The key allows for granular control, applying to either actions alone or actions associated with specific resources. In addition to service-specific condition keys, Alibaba Cloud provides a set of common condition keys applicable across all RAM-supported services.

  • Dependent action: The dependent actions required to run the action. To complete the action, the RAM user or the RAM role must have the permissions to perform all dependent actions.

Action

Access level

Resource type

Condition key

Dependent action

ga:UpdateEndpointGroupAttribute

update

*EndpointGroup

acs:ga:{#regionId}:{#accountId}:endpointgroup/{#endpointGroupId}

None None

Request parameters

Parameter

Type

Required

Description

Example

RegionId

string

Yes

The ID of the region where the Global Accelerator (GA) instance is deployed. Set the value to cn-hangzhou.

cn-hangzhou

ClientToken

string

No

The client token that ensures the idempotence of the request.

You can use the client to generate the token value, but you must ensure that it is unique across requests. The token can contain only ASCII characters and cannot exceed 64 characters in length.

123e4567-e89b-12d3-a456-426655440000

EndpointGroupId

string

Yes

The ID of the endpoint group.

epg-bp1ple63864a5hyj5****

Name

string

No

The name of the endpoint group.

The name must be 1 to 128 characters in length and can contain letters, digits, periods (.), underscores (_), and hyphens (-). The name must start with a letter.

test

Description

string

No

The description of the endpoint group. The description can be up to 200 characters in length and cannot start with http:// or https://.

testEndpointGroup

Response elements

Element

Type

Description

Example

object

The response parameters.

RequestId

string

The request ID.

6FEA0CF3-D3B9-43E5-A304-D217037876A8

Examples

Success response

JSON format

{
  "RequestId": "6FEA0CF3-D3B9-43E5-A304-D217037876A8"
}

Error codes

HTTP status code

Error code

Error message

Description

400 Resource.QuotaFull The resource quota is exceeded. The number of resources has reached the upper limit.
400 NotExist.EndPointGroup The endpoint group does not exist. The endpoint group does not exist.
400 StateError.EndPointGroup The specified state of endpoint group is invalid. The endpoint group is in an invalid state.
500 UnknownError An error occurred while processing your request. Please try again. If the error persists, please submit a ticket. An error occurred while the request was being processed. Try again later.
403 Forbbiden.SubUser You are not authorized to operate on the specified resource because your account was created by another user. The current account is a RAM user and does not have permissions to manage the specified resources.
403 Forbidden The user is not authorized to operate on the specified resource. The current account does not have permissions to manage the specified resources.

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.