Creates pay-as-you-go or subscription ENS compute instances.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
ens:RunInstances |
create |
*Instance
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| InstanceType |
string |
No |
The instance type. |
ens.sn1.small |
| InstanceChargeType |
string |
No |
The billing method of the instance. Valid values:
Valid values:
|
PostPaid |
| ImageId |
string |
No |
The image ID. This parameter cannot be specified for ARM-based instances. This parameter is required for other instance types. |
m-5si16wo6simkt267p8b7h**** |
| NetDistrictCode |
string |
No |
The region code. Note
This parameter is required for region-level scheduling and is invalid for node-level scheduling. |
350000 |
| Carrier |
string |
No |
The carrier. Note
This parameter is required for region-level scheduling. |
telecom |
| ScheduleAreaLevel |
string |
No |
The scheduling level. Use this parameter to specify node-level or region-level scheduling. Valid values:
|
Region |
| SchedulingStrategy |
string |
No |
The scheduling strategy. Valid values:
Note
For node-level scheduling, the value is Concentrate. For region-level scheduling, select a value based on your requirements. |
Concentrate |
| EnsRegionId |
string |
No |
The node ID. Note
This parameter is required for node-level scheduling and is invalid for region-level scheduling. |
cn-foshan-telecom |
| Password |
string |
No |
The instance password. Note
Specify at least one of Password, KeyPairName, and PasswordInherit. |
testPassword |
| KeyPairName |
string |
No |
The key pair name. Note
Specify at least one of Password, KeyPairName, and PasswordInherit. |
wx2-jumpserver |
| InternetChargeType |
string |
No |
Billable methods for bandwidth. Valid values:
Note
You can select a billing method only for the first purchase. Subsequent purchases use the billing method selected during the first purchase by default. |
BandwidthByDay |
| SystemDisk |
object |
No |
The system cloud disk specifications. |
|
| Size |
integer |
No |
The size of the system cloud disk. Unit: GiB. |
50 |
| Category |
string |
No |
The type of the system cloud disk. |
local_ssd |
| DataDisk |
array<object> |
No |
The data cloud disk specifications. |
|
|
object |
No |
The list of data cloud disks. |
||
| Size |
integer |
No |
The size of the data cloud disk. Unit: GiB. |
20 |
| Category |
string |
No |
The disk category. Valid values:
|
cloud_efficiency |
| Encrypted |
boolean |
No |
Specifies whether to encrypt the cloud disk. Valid values:
|
false |
| KMSKeyId |
string |
No |
The ID of the KMS key used by the cloud disk. Valid values:
Note
If Encrypted is set to true and KMSKeyId is empty, the default service key is used. |
false |
| Period |
integer |
No |
The duration of the purchased resource.
|
1 |
| InternetMaxBandwidthOut |
integer |
No |
The maximum public bandwidth. If the value of this parameter is greater than 0, a public IP address is automatically assigned to the instance. |
1 |
| Amount |
integer |
No |
The number of instances to create. Valid values: 1 to 100. |
1 |
| NetWorkId |
string |
No |
The network ID. Note
This parameter can only be used for node-level scheduling. An error is returned if this parameter is specified for region-level scheduling. If you do not specify vSwitch information, only the validity of the network ID is verified. The actual resource creation does not use this network ID. |
net-id |
| VSwitchId |
string |
No |
The vSwitch ID. Note
This parameter can only be used for node-level scheduling. An error is returned if this parameter is specified for region-level scheduling. |
vsw-5sagnw7m613oulalkd10n**** |
| SecurityId |
string |
No |
The security group ID. |
sg-test |
| HostName |
string |
No |
The hostname. |
test-HostName |
| InstanceName |
string |
No |
The instance name. The name must be 2 to 128 characters in length and must start with a letter or Chinese character. It cannot start with Default value: the InstanceId of the instance. |
TestName |
| UniqueSuffix |
boolean |
No |
Specifies whether to add sequential suffixes to HostName and InstanceName. The sequential suffixes start from 001 and cannot exceed 999. |
True |
| UserData |
string |
No |
The custom user data. Maximum size: 16 KB. You can pass in UserData information. UserData is Base64-encoded. |
ZWtest |
| AutoRenew |
boolean |
No |
Specifies whether to enable auto-renewal. Valid values:
Note
This parameter is invalid for pay-as-you-go instances. |
true |
| SchedulingPriceStrategy |
string |
No |
The scheduling price strategy. Valid values:
Valid values:
|
PriceHighPriority |
| PrivateIpAddress |
string |
No |
The private IP address. Note
This parameter can only be used for node-level scheduling. An error is returned if this parameter is specified for region-level scheduling. If a private IP address is specified, the number of instances can only be 1. The private IP address takes effect only when both the private IP address and vSwitch ID are specified. |
10.0.XX.XX |
| PeriodUnit |
string |
No |
The unit of the purchase duration. Valid values:
Valid values:
|
Month |
| PublicIpIdentification |
boolean |
No |
Specifies whether to enable public IP identification. Valid values:
Default value: true. |
true |
| PasswordInherit |
boolean |
No |
Specifies whether to use the preset password of the image. Valid values:
Note
Specify at least one of Password, KeyPairName, and PasswordInherit. |
false |
| InstanceChargeStrategy |
string |
No |
The instance billing strategy. Valid values:
|
instance |
| BillingCycle |
string |
No |
The billing cycle for instance compute resources. Only instance-level pay-as-you-go is supported. Valid values:
Valid values:
|
Day |
| IpType |
string |
No |
The IP type. Valid values:
Valid values:
|
ipv4 |
| AutoUseCoupon |
string |
No |
Specifies whether to use coupons. Default value: true (AutoUseCoupon=true). |
true |
| Tag |
array<object> |
No |
The tags that are bound to the instance. |
|
|
object |
No |
The array of tag key-value pairs. |
||
| Key |
string |
No |
The custom tag key. |
team |
| Value |
string |
No |
The tag value. The tag value cannot exceed 128 characters in length, and cannot start with |
tagValue |
| AutoReleaseTime |
string |
No |
The automatic release time of the pay-as-you-go instance. Specify the time in the ISO 8601 standard in the
|
2023-06-28T14:38:52Z |
| SpotStrategy |
string |
No |
The bidding policy for the pay-as-you-go instance. This parameter takes effect when the
Default value: NoSpot. Valid values:
|
SpotAsPriceGo |
| SpotDuration |
integer |
No |
The protection period of the spot instance. Unit: hours. |
1 |
| Ipv6AddressCount |
integer |
No |
The number of randomly generated IPv6 addresses to assign to the primary ENI of the private network. |
2 |
| DeletionProtection |
boolean |
No |
The release protection property of the instance. Specifies whether the instance can be released from the console or by calling an API operation. Valid values:
Default value: false. Note
This property applies only to pay-as-you-go instances and can only restrict manual release operations. It does not take effect on system-initiated release operations. |
false |
| LaunchTemplateId |
string |
No |
The ID of the instance launch template. |
lt-test |
| LaunchTemplateName |
string |
No |
The name of the instance launch template. |
lt-test |
| LaunchTemplateVersion |
integer |
No |
The version of the instance launch template. |
2 |
| VpdId |
string |
No |
The VPD network ID. |
vpd-5s7xxxxxxx |
| VpdVSwitchIds |
array |
No |
The list of VPD vSwitch IDs. |
|
|
string |
No |
The list of VPD vSwitch IDs. |
vsw-5s7xxxxxxx |
|
| DeploymentSetId |
string |
No |
The deployment set ID. |
ds-5s1p6x2l3r4b**** |
| AutoInstallCloudAssistant |
boolean |
No |
Specifies whether to automatically install the Cloud Assistant client on the instance. |
|
| CloudAssistantRegion |
string |
No |
The region for Cloud Assistant access. Valid values: cn-zhangjiakou (Zhangjiakou) and ap-southeast-1 (Singapore). Valid values:
|
cn-zhangjiakou |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
The request ID. |
91E4AFBE-4E35-5D2A-A886-BB477C9953D2 |
| InstanceIds |
array |
The list of instance IDs. |
|
|
string |
The list of instance IDs. |
['i-5xxxx26dix05koz15l5413j25o', 'i-5sdmxxxx'] |
|
| OrderId |
string |
The order ID. |
213177957850399 |
Examples
Success response
JSON format
{
"RequestId": "91E4AFBE-4E35-5D2A-A886-BB477C9953D2",
"InstanceIds": [
"['i-5xxxx26dix05koz15l5413j25o', 'i-5sdmxxxx']"
],
"OrderId": "213177957850399"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | Invalid%s | The specified parameter %s is invalid. | |
| 400 | Missing%s | You must specify the parameter %s. | |
| 400 | SaleControlVerificationFailedInstanceDistrict | The regional sales constraint verification failed, please re-match or contact the product. | Regional sales constraint verification failed, please re-match |
| 400 | ens.interface.error | Failed to call API. | |
| 400 | OrderFailed | Order failed, please try again. | Order failed, please try again |
| 400 | SystemUseCouponFailed | Failed to use coupon. | Failed to use coupon |
| 400 | SystemUseStoredCardFailed | Failed to use stored value card. | Failed to use stored value card |
| 400 | System.SystemError | system error. | system error. |
| 400 | SystemCanRefundCheckFailed | The business rule check of the cloud product fails, and this order cannot be refunded. | The business rule check of the cloud product fails, and this order cannot be refunded. |
| 400 | SystemOtsSystem | ots storage error. | ots storage error. |
| 400 | SystemQueryImmortalError | Failed to call Juxiange. | Failed to call Juxiange. |
| 400 | SystemQueryInstanceInfoFailed | Failed to find instance information. | Failed to find instance information |
| 400 | SystemResellerPayCalRefundUnitError | Ecological payment channel calculation unsubscribe information error. | Ecological payment channel calculation unsubscribe information error. |
| 400 | SystemSaleValidateFailed | Sales Expression Validation System Error. | Sales Expression Validation System Error |
| 400 | SystemTransferDeleteOldResourceFailed | Failed to delete the transferred instance in the transfer order. | Failed to delete the transferred instance in the transfer order. |
| 400 | SystemUnSupportOperationType | Unsupported operation type. | Unsupported operation type. |
| 400 | RiskRiskControlRejection | Risk Control Rejection. | Risk Control Rejection. |
| 400 | AuthRamAuthFailed | ram sub-account authentication failed. | |
| 400 | CommodityInvalidComponent | The module you purchased is illegal, please re-select. | The module you purchased is illegal, please re-select. |
| 400 | CommodityInvalidItemCode | Specification code illegal. | Specification code illegal. |
| 400 | PriceHsfTimeoutError | Time out when calling the request for quotation interface. | Time out when calling the request for quotation interface. |
| 400 | PricePatingConfigError | Inquiry related goods configuration error. | Inquiry related goods configuration error. |
| 400 | PricePricingPlanResultNotFound | Pricing plan price result not found. | Pricing plan price result not found. |
| 400 | PriceRatingGetRatingpricingPlan | Obtain a valid pricing plan exception. | Obtain a valid pricing plan exception. |
| 400 | OrderAbnormalResourceStatusForRenew | Invalid resource status for renewal. | Invalid resource status for renewal. |
| 400 | OrderAccountStatusIllegal | Illegal account status. | Illegal account status. |
| 400 | OrderArrearage | User Arrears. | User Arrears. |
| 400 | OrderBidUserOrderForbidden | Bid users cannot buy on the official website. | Bid users cannot buy on the official website. |
| 400 | OrderCaptureFailed | The paid order of the instance has not been deducted successfully. | The paid order of the instance has not been deducted successfully. |
| 400 | OrderExistsReleasedInstances | There are already released instances. | There are already released instances. |
| 400 | OrderGroupOrderSizeOverflow | The quantity of bound combined payment order exceeds the limit. | The quantity of bound combined payment order exceeds the limit. |
| 400 | OrderHomeCurrencyCanNotDowngrade | Users in current currency cannot downgrade. | Users in current currency cannot downgrade. |
| 400 | OrderHomeCurrencyCanNotUpgradeByValueTransfer | Users of current currency cannot upgrade through residual value transfer. | Users of current currency cannot upgrade through residual value transfer. |
| 400 | OrderInstanceHasInactiveChange | Instances exist temporary upgrade. | Instances exist temporary upgrade. |
| 400 | OrderInstHasUnpaidOrder | The instance has an unpaid order. | The instance has an unpaid order. |
| 400 | OrderInstHasUnsettledBills | The instance has an unsettled bill. | The instance has an unsettled bill. |
| 400 | OrderLatestOrderIsHandling | Recent order is being processed, please try again later. | Recent order is being processed, please try again later. |
| 400 | OrderMainOrderSizeOverflow | The quantity of the main order exceeds the limit. | The quantity of the main order exceeds the limit. |
| 400 | OrderMissingModuleInfoError | Module parameter not specified. | Module parameter not specified. |
| 400 | OrderNoRealNameAuthentication | No real-name authentication. | No real-name authentication. |
| 400 | OrderNotFound | The specified order information is not found. | The specified order information is not found. |
| 400 | OrderOpend | You have activated this product. | You have activated this product. |
| 400 | OrderPeriodInvalid | Illegal order cycle. | Illegal order cycle. |
| 400 | OrderQuantityInvalid | Illegal quantity ordered. | Illegal quantity ordered. |
| 400 | OrderQueryInstanceError | Query instance error. | Query instance error. |
| 400 | OrderQueryInstanceNotExists | Instance data does not exist. | Instance data does not exist. |
| 400 | OrderQueryOrderExchangeRateFail | Failed to query order exchange rate information. | Failed to query order exchange rate information. |
| 400 | OrderQueryUserSettleInfoFail | Failed to query user settlement information. | Failed to query user settlement information. |
| 400 | OrderQuotaExceeded | Quantity exceeds limit. | Quantity exceeds limit. |
| 400 | OrderSysConstraintInvalid | System constraint check failed. | System constraint check failed. |
| 400 | OrderTradeCompleteSettleInfoFail | Failed to complete the order settlement currency amount information. | Failed to complete the order settlement currency amount information. |
| 400 | TradeTradeOrderAfterPayCheckError | You have already paid for the subsequent orders of this instance. The current order has been automatically voided and you cannot pay any more. | You have already paid for the subsequent orders of this instance. The current order has been automatically voided and you cannot pay any more. |
| 400 | PurchaseExistRenewchangeProd | There is a renewal change subscription that has not yet taken effect. | There is a renewal change subscription that has not yet taken effect. |
| 400 | PurchaseExistToBeValidProdRuleError | Currently, there are temporary orders that are not in effect, and the upgrade operation cannot be performed. | Currently, there are temporary orders that are not in effect, and the upgrade operation cannot be performed. |
| 400 | PurchaseExistToBeValidRenewChangeProdRuleError | Currently, there is an uneffective renewal change subscription, and temporary upgrade operation cannot be performed. | Currently, there is an uneffective renewal change subscription, and temporary upgrade operation cannot be performed. |
| 400 | PurchaseExistValidProdRuleError | Currently, there is a temporary order in effect, and operations such as upgrade/downgrade/expansion/pre-transfer cannot be performed. | Currently, there is a temporary order in effect, and operations such as upgrade/downgrade/expansion/pre-transfer cannot be performed. |
| 400 | ProductInstanceReleased | Instance released. | Instance released. |
| 400 | ProductInstanceTypeNotSupported | The instance type is not supported. | The instance type is not supported. |
| 400 | PatRiskRejectForTradeData | Payment order problem leads to risk control rejection. | Payment order problem leads to risk control rejection. |
| 400 | PayAccountBookNotExist | There is no insufficient account balance in the account book, please retry after recharging. | There is no insufficient account balance in the account book, please retry after recharging. |
| 400 | PayAmountLimitExceeded | Payment limit exceeded, please resubmit. | Payment limit exceeded, please resubmit. |
| 400 | PayBeforePayRiskRuleValidateFailed | The payment was blocked by risk control, and the payment failed. | The payment was blocked by risk control, and the payment failed. |
| 400 | PayCounponNotExist | Counpon does not exist. | Counpon does not exist. |
| 400 | PayCouponAmountNotEnough | Insufficient voucher balance or expired. | Insufficient voucher balance or expired. |
| 400 | PayCouponNotMeetConsumptionRule | The coupon does not meet the conditions for use. | The coupon does not meet the conditions for use. |
| 400 | PayCurrencyInconsistency | Currency mismatch. | Currency mismatch. |
| 400 | PayCurrencyNotSupported | Currency not supported. | Currency not supported. |
| 400 | PayForbiddenNoReasonFefund | Banned five days no reason refund. | Banned five days no reason refund. |
| 400 | PayHsfTimeoutError | Call payment system timeout. | Call payment system timeout. |
| 400 | PayInsufficientBalance | Account balance is insufficient, please recharge and try again. | Account balance is insufficient, please recharge and try again. |
| 400 | PayInvalidCreditCard | Invalid credit card. | Invalid credit card. |
| 400 | PayInvalidPayMethod | Illegal payment method. | Illegal payment method. |
| 400 | PayMegrePayOrderHasThanOneChagreChannel | Payment failed, please retry or submit work order feedback. | Payment failed, please retry or submit work order feedback. |
| 400 | PayNoCreditCard | No valid payment method, please check the payment method and try again. | No valid payment method, please check the payment method and try again. |
| 400 | PayOrderPayTimeInvalid | Order effective time is invalid. | Order effective time is invalid. |
| 400 | PayPartRefundNotSupport | Not Capture, no partial refund. | Not Capture, no partial refund. |
| 400 | PayPayChannelPayOrderInvalidStatus | Illegal status of payment order in payment channel. | Illegal status of payment order in payment channel. |
| 400 | PayPayChannelPayOrderNotExist | Payment channel payment order does not exist. | Payment channel payment order does not exist. |
| 400 | PayPayerAccountIllegal | Illegal payment account. | Illegal payment account. |
| 400 | PayPayFailedParentRelationchanged | If the financial custody relationship changes, please void the order and place a new order for payment. | If the financial custody relationship changes, please void the order and place a new order for payment. |
| 400 | PayPayForbidUserCoupon | Coupon prohibited for orders. | Coupon prohibited for orders. |
| 400 | PayQueryAvailableAmountFailed | Failed to query user availability, please try again later. | Failed to query user availability, please try again later. |
| 400 | PayQueryAvailableEnduserAmountFailed | Failed to query the availability of quota direct customer main user, please try again later. | Failed to query the availability of quota direct customer main user, please try again later. |
| 400 | PayQueryParentRelationshipFailed | Failed to query current user hosting relationship, please try again later. | Failed to query current user hosting relationship, please try again later. |
| 400 | PayQueryPayChangeChannelNotEqual | Multi-order payment channels are inconsistent, please check whether the original order data payment channel is correct. | Multi-order payment channels are inconsistent, please check whether the original order data payment channel is correct. |
| 400 | PayRefundFailed | Accumulated refund amount exceeds payment order amount. | Accumulated refund amount exceeds payment order amount. |
| 400 | PayResellerPayGetUrlError | Order payment failed, please try again later. | Order payment failed, please try again later. |
| 400 | PayRiskRejectForPayerAccount | Payment account problem leads to risk control rejection. | Payment account problem leads to risk control rejection. |
| 400 | PayStoredCardNotExist | Stored value card does not exist. | Stored value card does not exist. |
| 400 | PaySystemError | Error calling payment system. | Error calling payment system |
| 400 | PayTaxCalcFailed | Failed to get user tax address. | Failed to get user tax address. |
| 400 | PayWithholdingAgreementIllegal | Withholding Agreement Status Illegal. | Withholding Agreement Status Illegal. |
| 400 | AccountAliyunAccountFrozen | Alibaba Cloud account is frozen. | Alibaba Cloud account is frozen. |
| 400 | AccountAliyunAccountNotExist | Alibaba Cloud account does not exist. | Alibaba Cloud account does not exist. |
| 400 | RefundRefundInstanceNotFound | Unable to find instance information. | Unable to find instance information. |
| 400 | RefundRefundNoValidProd | Refund is not available to unsubscribe. | Refund is not available to unsubscribe. |
| 400 | RefundRefundParamInvalid | Abnormal refund parameter. | Abnormal refund parameter. |
| 400 | RefundRefundQueryOrderFail | Failed to query order for refund field. | Failed to query order for refund field. |
| 400 | SystemConcurrentOperate | Concurrent operation causes failure. | Concurrent operation causes failure. |
| 400 | PricePricingPlanNotFound | Pricing plan tree not found. | Pricing plan tree not found. |
| 400 | OrderInstanceHasTempUpgrade | Instances exist temporary upgrade. | Instances exist temporary upgrade. |
| 400 | PayQueryParentRelationchangedFailed | The financial custody relationship may change, please refresh and pay again. | The financial custody relationship may change, please refresh and pay again. |
| 400 | PayforCreditPayInsufficientBalance | Insufficient quota, please contact your channel partner to increase the quota. | Insufficient quota, please contact your channel partner to increase the quota. |
| 400 | PayforAccountMoneyValidateError | The available amount of your channel partner's account is insufficient, please contact your channel partner to recharge in time. | The available amount of your channel partner's account is insufficient, please contact your channel partner to recharge in time. |
| 400 | BasicInfoUncompleted | You have not completed your basic personal information. Please complete the information and re-operate it. | You have not completed your basic personal information. Please complete the information and re-operate it. |
| 400 | SaleControlVerificationFailedStock | Inventory sales constraint verification failed, please re-match, or contact the product. | Inventory sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedInstanceSpec | Instance specification sales constraint verification failed, please re-match, or contact the product. | Instance specification sales constraint verification failed, please re-match |
| 400 | SaleControlVerificationFailedInstanceNetLevel | The network-level sales constraint verification failed, please re-match or contact the product. | Network level sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedInstanceCpuCore | cpu core sales constraint verification failed, please re-match, or contact the product. | cpu core sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedInstanceBandwidthValue | The bandwidth speed limit value sales constraint verification failed, please re-match or contact the product. | The bandwidth speed limit value sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedInstanceBandwidthType | Bandwidth type sales constraint verification failed, please re-match, or contact the product. | Bandwidth billing method sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedInstanceSystemDiskSpec | The system disk capacity sales constraint verification failed, please re-match or contact the product. | The system disk capacity sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedInstanceDataDiskType | Data disk type sales constraint verification failed, please re-select, or contact the product. | Cloud disk type sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedInstanceDataDiskSpec | Data disk capacity sales constraint verification failed, please re-match, or contact the product. | Cloud disk capacity sales constraint verification failed, please re-match |
| 400 | SaleControlVerificationFailedInstanceDataDiskBlock | The sales constraint verification of the number of data disks failed, please re-match or contact the product. | Cloud disk quantity sales constraint verification failed, please re-match |
| 400 | SaleControlVerificationFailedRegion | The node sales constraint verification failed, please re-select or contact the product. | Node sales constraint verification failed, please re-select |
| 400 | SaleControlVerificationFailedCarrier | The isp failed to verify the sales restriction. Please re-select or contact the product. | Operator sales constraint verification failed, please re-select |
| 400 | EnsAreaCountIllegal | The number of instances in the region is all 0, please re-select or contact the product. | The number of instances with regions is all 0, please re-select |
| 400 | EnsAreaInsufficientInventory | Regional inventory is insufficient, please re-match, or contact the product. | Insufficient regional inventory, please re-match |
| 400 | EnsEnsRegionInsufficientInventory | The node inventory is insufficient, please re-select or contact the product. | Insufficient node inventory, please re-select |
| 400 | EnsRegionCountExceeded | Purchase quantity exceeds the single default limit, please re-match, or contact the product. | The maximum number of nodes or regions purchased at a time is 10, the maximum number of single-node instances scheduled for a node is 100, and the maximum number of total instances is 1000, and the total number of instances scheduled for a region is 100 or less |
| 400 | EnsServiceArrearage | The user is in arrears or the status is abnormal, please contact the product. | The user is overdue or in abnormal status, please recharge |
| 400 | EnsServiceConsumerNotExists | The user has not opened the edge service to pay by volume, please contact the product consultation. | The user has not activated the edge service to pay by volume, please activate and use it again. |
| 400 | GenerateDataKeyFailure | Failed to generate key information, please contact the product. | Failed to generate key information, please try again |
| 400 | InvalidDataDiskCountValueNotSupported | The maximum number of dataDiskCount is exceeded,please re-match, or contact the product. | The number of cloud disks is too large, not more than 15, please re-select |
| 400 | SystemError | Interface call error, please re-match, or contact the product. | Interface call error, please re-select |
| 400 | InvalidParameterCategoryNotSupported | This disk category is not support kms,please re-select, or contact the product. | Cloud disk type does not support encryption, please re-select |
| 400 | InvalidParameterKMSKeyIdCMKNotEnabled | The CMK needs to be enabled, please re-select, or contact the product. | The key status is incorrect, please go to the key management console to enable the key status. |
| 400 | InvalidImageIdSpec | The image does not match the specification cluster information, please re-match. | The image does not match the specification cluster information, please re-match |
| 400 | InvalidParameterInstanceType | Failed to obtain specification information, please try to place the order again. | Failed to obtain specification information, please try to place the order again |
| 400 | InvalidSpecPostPaid | This specification is not supported for a Pay-As-You-Go instance. | This specification is not supported for a Pay-As-You-Go instance. |
| 400 | InvalidSpecNetlevel | The current network level does not support configuring this specification. | The current network level does not support configuring this specification. |
| 400 | SuperfluousDataDiskInstanceSpec | Data disk properties cannot be configured for the current specification. | Data disk properties cannot be configured for the current specification |
| 400 | SuperfluousImageIdInstanceSpec | Image properties cannot be configured for the current specification. | Image properties cannot be configured for the current specification |
| 400 | SuperfluousPublicIpIdentificationInstanceSpec | The current specification cannot create a public network card. | The current specification cannot create a public network card. |
| 400 | SuperfluousSystemDiskInstanceSpec | System disk properties cannot be configured for the current specification. | System disk properties cannot be configured for the current specification |
| 400 | LackImageIdInstanceSpec | Image properties must be configured for the current specification. | Image properties must be configured for the current specification |
| 400 | LackSystemDiskInstanceSpec | System disk properties must be configured for the current specification. | System disk properties must be configured for the current specification |
| 400 | LackPublicIpIdentificationInstanceSpec | The current specification must create a public network card. | The current specification must create a public network card. |
| 400 | LackLabelImageIdEnsRegionId | The instance created by using this image on this node lacks the necessary label, please contact the product or operation classmate. | The required tag for creating an instance using this image on this node is missing |
| 400 | InvalidImageIdSystemDisk | The system disk size does not match the image size, please re-select. | The system disk size does not match the image size, please re-select |
| 400 | SaleNetIpType | There is a conflict between the input parameters related to the double stack. | There is a conflict between the input parameters related to the double stack. |
| 400 | InvalidSKUStatus | Inventory storage unit(SKU) background status is illegal, please submit work order in time. | Inventory storage unit(SKU) background status is illegal, please submit work order in time. |
| 400 | NoPermission | Permission denied. | |
| 400 | EnsPostOpenError | Commodity opening failed. | Commodity opening failed. |
| 400 | VswitchNotMatchIpv6 | The specified switch does not support ipv6. | The specified switch does not support ipv6. |
| 400 | SwitchNotSupportIpv6 | The specified switch does not support ipv6. | The specified switch does not support ipv6. |
| 400 | InvalidNetlevelDeploymentsetid | Deployment sets only support node-level network hierarchies. | Deployment sets only support node-level network hierarchies. |
| 400 | InvalidSpecDeploymentsetid | Deployment sets only support x86 compute instance types. | Deployment sets only support x86 compute instance types. |
| 400 | DEPLOYMENTSETID_RESTRICTIONS | Scheduling failed due to deployment set policy restrictions. | Scheduling failed due to deployment set policy restrictions |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.