This topic describes the cause of the AccessDenied error when you use JindoSDK to access Object Storage Service (OSS) and how to fix the error.

Issue

Failed test connectivity, operation: getFileStatus, errMsg: [RequestId]: 635B6DDE9A1F093434AC6A7C [HostId]: oss-cn-beijing-internal.aliyuncs.com [ErrorMessage]: [E1010]HTTP/1.1 403 Forbidden: <?xml version="1.0" encoding="UTF-8"?><Error> <Code>AccessDenied</Code> <Message>The bucket you access does not belong to you.</Message> <RequestId>635B6DDE9A1F093434AC6A7C</RequestId> <HostId>xxx.oss-cn-beijing-internal.aliyuncs.com</HostId></Error> [ErrorCode]: 1010 [RequestId]: 635B6DDE9A1F093434AC6A7C

Cause

The RAM user does not have the required permissions to access OSS.

Solution

Grant the required permissions to the RAM user. For more information, see Use RAM to manage OSS permissions.

Refer to the following actions if you want to perform fine-grained control on OSS resources.
  • Use JindoSDK to read data from and write data to OSS
    # Bucket-related actions
    oss:ListObjects
    oss:GetBucketInfo
    # Object-related actions
    oss:PutObject
    oss:GetObject
    oss:DeleteObject
    oss:AbortMultipartUpload
    oss:ListParts
    oss:RestoreObject
    oss:PutObjectTagging
    oss:GetObjectTagging
    oss:DeleteObjectTagging
    # Versioning-related actions
    oss:ListObjectVersions
    oss:GetObjectVersion
    oss:DeleteObjectVersion
    oss:RestoreObjectVersion
    oss:PutObjectVersionTagging
    oss:GetObjectVersionTagging
    oss:DeleteObjectVersionTagging
  • Use JindoSDK to read data from OSS
    # Bucket-related actions
    oss:ListObjects
    oss:GetBucketInfo
    # Object-related actions
    oss:GetObject
    oss:ListParts
    oss:RestoreObject
    oss:GetObjectTagging
    # Versioning-related actions
    oss:ListObjectVersions
    oss:GetObjectVersion
    oss:RestoreObjectVersion
    oss:GetObjectVersionTagging

References

Grant access to OSS or OSS-HDFS