All Products
Search
Document Center

Enterprise Distributed Application Service:FAQ about getting started

Last Updated:Aug 29, 2024

This topic provides answers to some frequently asked questions about how to create and deploy applications in Enterprise Distributed Application Service (EDAS).

How do I select between an ECS cluster and a Kubernetes cluster?

To create an application, you must select a cluster type first. You can select a suitable cluster type based on the metrics that are described in the following table.

Note

If you cannot decide which cluster type to select, we recommend that you select an Elastic Compute Service (ECS) cluster.

Cluster type

Deployment mode

Billing

O&M cost

Integration with cloud native services

ECS cluster

One application is deployed on each ECS instance.

  • IaaS: You are charged based on the specifications of the ECS instances that you use. For more information, see Billing overview.

  • PaaS: Bills are generated in EDAS based on the ECS instances on which you deploy applications. For more information, see Billing overview.

The O&M is similar to that in the conventional Linux system. It is easy to get started with and perform O&M on ECS clusters.

N/A

ACK cluster

One application is deployed on each pod, and multiple pods can run on each ECS instance.

  • IaaS: You are charged for the Container Service for Kubernetes (ACK) clusters that you use. For more information, see Billing.

  • PaaS: Bills are generated in EDAS based on the pods on which you deploy applications. For more information, see Billing overview.

You must have basic knowledge and experience in virtualization, containerization, and Kubernetes clusters.

Kubernetes clusters can be integrated with cloud-native services. One image can be run in multiple services and regions.

Why do I see only instance specifications when I select Custom Environment?

  • Problem description

    In the Configurations step, when Custom Environment is selected, only instance specifications are displayed. The information about the virtual private cloud (VPC) and ECS instance is not displayed.

  • Possible cause

    You have not created a VPC, a microservices namespace, a cluster, or an ECS instance by using the current Alibaba Cloud account in the current region. To resolve this issue, you need to only select an instance specification. EDAS creates a default VPC and an ECS instance of the specified specification, and creates a default microservices namespace and cluster for you.

  • Solution

    If you have specific requirements on the network, service isolation, and ECS instance, you can first create a VPC, a microservices namespace, a cluster, and an ECS instance. This way, you can select the corresponding resources in this step to deploy an application.

What can I do if I fail to add an ECS instance to a cluster?

  • Problem description

    In the Configurations step, Custom Environment is selected. In the Instance Source section, Use Existing Instance is selected. Then, Instance not Imported to Any Cluster is selected. Before the application is created, an error message appears, which indicates that the ECS instance fails to be added to the cluster.

  • Possible cause

    EDAS does not support the OS of the selected ECS instance.

  • Solution

    Select another ECS instance whose OS is 64-bit Alibaba Cloud Linux 2.1903 or 64-bit CentOS 7.2, 7.3, 7.4, or 7.6.

How do I change an application port?

  • To specify the port of an application that is deployed in an ECS cluster, you can change the Tomcat port in the application settings on the details page of the application. For more information about the solution in case that the specified port is invalid, see Why does the Tomcat port that I configured not take effect?

  • To change the port of an application that is deployed in a Kubernetes cluster, you can change the port only in the application code or by configuring a Server Load Balancer (SLB) instance for the application.

If you have any question when you follow the new procedure to create applications, join the official DingTalk group for technical support. The DingTalk group ID is 21958624.