RDP connection to Windows instance fails: error 0x112f
This topic describes how to resolve protocol error 0x112f during RDP connections to a Windows instance.
Symptoms
When you try to connect to a Windows instance via RDP, the remote session disconnects and you receive the following error message: Because of a protocol error (code: 0x112f), the remote session will be disconnected. Please try connecting to the remote computer again.
Cause
This error typically occurs when the Windows instance has insufficient memory to establish a new remote session.
Resolution
Choose one of the following solutions.
Solution 1: Upgrade the instance type
Upgrade the instance type of your ECS instance to increase its available memory. For detailed instructions, see Upgrade the instance types of subscription instances or Change the instance type of a pay-as-you-go instance.
Solution 2: Enable virtual memory
As a workaround, enable virtual memory on the ECS instance. This allows the operating system to use disk space as if it were memory. For instructions, see How to configure the virtual memory of a Windows instance.