This topic describes how to resolve the issue that the 0x112f error code is returned when you connect to a Windows instance over RDP.
Problem description
When you connect to a Windows instance, you are prompted with the following error message: Because of a protocol error (code: 0x112f), the remote session will be disconnected. Please try connecting to the remote computer again.
Cause
This issue may occur because the Windows instance has insufficient memory.
Solutions
You can use one of the following solutions to resolve the issue:
Solution 1: Upgrade the instance type of the instance
You can upgrade the instance to an instance type that has more memory. For more information, see Upgrade the instance types of subscription instances or Change the instance type of a pay-as-you-go instance.
Solution 2: Enable virtual memory on the instance
You can configure virtual memory on the instance to obtain sufficient available memory. For more information, see How to configure the virtual memory of a Windows instance.