Problem description
You have purchased an Elastic Compute Service (ECS) instance, but the instance is not found in the ECS instance list.
Causes
The resource is not in the current region.
The incorrect product console is accessed.
The account in use is either incorrect or lacks the necessary access permissions.
The instance is either expired or released due to overdue payment.
Solutions
The resource is not in the current region.
If you do not switch to the region where the instance is located, it does not appear in the list. Use the following methods to locate the instance:
Change the region at the top of the Instance page in the ECS console. If instances are existing in that region, you can switch to view them.
Check the distribution of instances on the ECS instance overview page.
The incorrect product console is accessed.
You may have purchased a product other than ECS, such as Simple Application Server. Ensure you are using the correct product console with the method below.
Log on to the Expenses and Costs console, click Orders in the sidebar, and check the orders for purchased products. If the purchase was made some time ago, filter the orders by Time Period. The order list will show the resource type purchased.
The account in use is either incorrect or lacks the necessary access permissions.
If the instance is not visible, ensure you are logged into the correct Alibaba Cloud account, especially if multiple accounts are used in the same browser.
If you are logged in as a RAM user, verify that you have the necessary ECS access permissions:
Log on to the RAM console to confirm that the RAM user has ECS access, such as:
Management permissions for ECS (AliyunECSFullAccess)
Read-only access (AliyunECSReadOnlyAccess)
For custom policies authorized by tag, check the instance list page to ensure the ECS instance's tag is correct.
The instance is either expired or released due to overdue payment.
Instances that are overdue or expired are automatically released after a certain period. Once released, they cannot be found in the console and are not recoverable. To view notifications related to instance release, visit Internal Messages.