Problem description
You have purchased an Elastic Compute Service (ECS) instance but cannot find it in the instance list.
Possible causes
The resource is not in the current region.
You selected the wrong product console.
The account is incorrect or lacks permissions.
The instance has expired or has been released due to overdue payment.
A refund was issued because of insufficient resources.
Solutions
The resource is not in the current region
If you have not switched to the region where the instance is located, you will not be able to find the instance. You can confirm this through the following methods.
Switch the region at the top of the ECS console. If there are instances in a region, you can directly switch to the destination region to view them.

Check which region your instances are distributed in on the ECS Overview page.

Wrong product console selected
The resource you purchased might not be an ECS instance, but a Simple Application Server or another product, and you have not found the correct product console. You can confirm this through the following methods.
Incorrect account or insufficient permissions
Incorrect Alibaba Cloud account: If you cannot find the instance, you can verify whether this is because multiple Alibaba Cloud accounts have been logged into from the same browser, resulting in an incorrect account being used.
Logged in as a Resource Access Management (RAM) user without permissions
Log on to the RAM console to check if the RAM user has ECS access permissions, specifically the system policies for accessing ECS, as shown below:
Management permissions (AliyunECSFullAccess)
Read-only permissions (AliyunECSReadOnlyAccess)
If you are using a custom policy with authorization by tags, you need to find the target instance on the instance list page and check if the tags on the ECS instance are correct.

Instance expired or released due to overdue payment
Instances with overdue payments or that have expired will be automatically released after a certain period. After release, you cannot find the instance in the console. If an instance has been released, it cannot be recovered. You can check instance release notifications through the Message Center.
Refund due to insufficient resources
This might be caused by insufficient resources in the zone, resulting in an automatic refund by the system. You can confirm if this is the issue through My Orders.
If this issue occurs, you can create a new instance in another zone.