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:What do I do if a Windows instance fails to start or specific Windows features do not work as expected after I install system updates on the instance?

Last Updated:Nov 18, 2025

This topic describes the causes of and solutions for a Windows Elastic Compute Service (ECS) instance that fails to start or has features that function abnormally after a system update.

Problem description

After you install system updates on a Windows ECS instance, the instance fails to start or specific Windows features do not work as expected. Examples include failed driver installations and abnormal Key Management Service (KMS) behavior.

Cause

This issue can occur if a defective system patch is installed on the instance. The patch may cause the operating system to fail to start or cause Windows features to function abnormally.

Solutions

Choose the appropriate method to uninstall system patches based on whether the instance can start.

The instance can start

Method 1: Uninstall system patches in Windows Update

  1. Connect to the ECS instance.

    For more information, see Use Workbench to connect to a Windows instance using RDP.

  2. Click the Start menu, and then click Settings.

    image.png

  3. On the Windows Settings page, click Update & security.

    image.png

  4. On the Update status page, click Update history.

    image.png

  5. On the Update History page, click Uninstall updates.

    image.png

  6. Right-click the update that you want to uninstall, such as KB5029250. Click Uninstall and follow the on-screen instructions to uninstall the update.

    image.png

Method 2: Use PowerShell to uninstall system patches

  1. Connect to the ECS instance.

    For more information, see Use Workbench to connect to a Windows instance using RDP.

  2. Run Windows PowerShell as an administrator.

    image.png

  3. Find the package that corresponds to the patch.

    $package = Get-WindowsPackage -Online | Where-Object {$_.PackageName -match 'KB5029250'}
  4. Uninstall the package.

    $package | Remove-WindowsPackage -Online

The instance fails to start

If the instance fails to start, attach a repair disk to the instance. Then, uninstall the defective patch to resolve the issue. Assume the repair disk is attached as drive D and you want to uninstall the KB5029250 patch. Follow these steps:

  1. Run a diagnostic for the operating system startup failure on the instance.

    1. Go to the ECS console - Troubleshooting page. At the top of the page, select a region and a resource group.

    2. On the Instance Troubleshooting tab, click the Instance Connection Errors or Startup Exceptions problem type.

    3. Select the Operating System Startup Failure on the Instance in the Stopped State problem. Select the Instance ID of the instance to diagnose and a time range. Then, click Start.

      Note

      The instance to be diagnosed must be in the Stopped state. For more information, see Stop an instance.

      image

      After the diagnostic is complete, the instance is in the Running or Repairing status.

      运行中、修复中

  2. Connect to the faulty instance.

    On the Diagnostic Result page, click VNC Connection. Then, enter the Administrator username and password provided in the diagnostic report to log on to the ECS instance to which a repair disk is attached. For more information, see Connect to an instance by using VNC.

  3. Run Windows PowerShell as an administrator.

    image.png

  4. Find the package that corresponds to the patch.

    $package = Get-WindowsPackage -Path D:\ | Where-Object {$_.PackageName -match 'KB5029250'}
  5. Uninstall the package.

    $package | Remove-WindowsPackage -Path D:\
  6. On the Instance page, move the pointer over the Repairing state that corresponds to the instance and click Detach Repair Disk.

  7. Restart the instance to allow the preceding configurations to take effect.

    For more information, see Restart an instance.

  8. Connect to the ECS instance. If you can connect to the ECS instance as expected, the preceding issue is resolved.

    For more information, see Connect to a Windows instance using Workbench.