This topic describes the cause of and solution to the issue that a Windows operating system that serves as the default startup option cannot be started on an Elastic Compute Service (ECS) instance.
Problem description
A Windows operating system that serves as the default startup option on an ECS instance fails to start. After you select another startup option, the instance can be started as expected.
Cause
The default startup option of the instance may be abnormal, causing the operating system to fail to start as expected.
Solution
Connect to the instance by using Virtual Network Computing (VNC).
For more information, see Connect to an instance by using VNC.
Select a normal startup option in the startup option menu.
Run Windows PowerShell or the CLI tool (cmd) as an administrator.
Run the following command to view the identifiers of all startup options:
bcdedit /enum all
The identifier strings shown in the following figure are the identifiers of the startup options.
Specify a normal startup option as the default startup option.
You can use one of the following methods to set the default startup option.
NoteReplace
d7b2481f-65a5-11ee-82d5-************
in the following commands with one of the normal startup option identifiers that you obtained in Step 4.Windows PowerShell:
bcdedit.exe /default "{d7b2481f-65a5-11ee-82d5-************}"
CLI tool:
bcdedit /default {d7b2481f-65a5-11ee-82d5-************}
Restart the instance to allow the preceding configurations to take effect.
For more information, see Restart an instance.
Connect to the ECS instance. If you can connect to the ECS instance as expected, the preceding issue is resolved.
For more information, see Connect to a Windows instance by using a password or key.