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:What do I do if a Windows instance has high disk I/O load?

Last Updated:Jun 23, 2025

High disk I/O load on a Windows Elastic Compute Service (ECS) instance may cause system stutter or slow file reads/writes. This topic describes the causes of and solutions to the issue.

Note

In the following example, Windows 2022 is used. The operations may vary based on the Windows version.

Problem description

When you use a Windows ECS instance, the following issues may occur:

  • System stutter, slow file reads/writes, application performance degradation, or slow internal service response.

  • The disk I/O load displayed in the ECS console is higher than expected. For example, if the current read/write rate is greater than or equal to 80% of the disk I/O performance metric, the disk I/O load is considered high.

  • You are alerted that the disk I/O load exceeds the threshold.

Possible causes

High disk I/O load issue may occur due to the following reasons:

  • An abnormal process or service consumes many disk I/O resources.

  • Business programs and scenarios require high disk I/O that exceeds the disk I/O performance capacity of the Windows ECS instance.

Troubleshoot the issue

To identify and troubleshoot the issue, perform the following steps:

View detailed disk I/O load by process

Use Resource Monitor, a built-in Windows application, to view resource usage such as disk I/O load. You can view the disk I/O load of individual processes in Resource Monitor.

  1. In the lower-left corner of the Windows desktop, enter Resource Monitor in the search box and press the Enter key to start Resource Monitor.

  2. In the Resource Monitor window, click the Disk tab and view the disk I/O load of each process.

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Resolve the issue

The following table describes the causes of and solutions to the issue.

Problem description

Cause

Solution

Abnormal user programs or processes occupy many disk I/O resources for an extended period.

Abnormal programs or processes occupy too many disk I/O resources during runtime.

In the Resource Monitor window, identify the program that occupies many disk I/O resources, right-click it, and then click End Process to terminate the process.

Warning

Before terminating a process, make sure you understand information about the process to prevent business interruption due to accidental operations.

Normal user programs or processes occupy many disk I/O resources for an extended period.

Normal business programs or processes occupy too many disk I/O resources during runtime.

If a disk encounters an I/O performance bottleneck, you can use one of the following methods to resolve the issue:

  • Change the disk category. If a standard SSD encounters a disk I/O bottleneck, you can change it into an Enterprise SSD (ESSD) to improve disk performance. For more information, see Change the disk category of a disk.

  • Change the disk performance level. If an ESSD encounters a disk I/O bottleneck, you can upgrade its performance level. For more information, see Change the performance level of an ESSD.

  • Modify the disk performance configuration. If an ESSD AutoPL disk encounters a disk I/O bottleneck, you can modify its performance configuration. For more information, see Modify the performance configurations of an ESSD AutoPL disk.

  • Upgrade the instance type: If instance type limitations prevent you from upgrading to a better-performing disk, upgrade the instance type first. For more information, see Change the instance type.

  • No programs or processes occupy many disk I/O resources.

  • A program or process occasionally has high disk I/O usage, but the duration is short.

The disk I/O performance required for the normal operation of services hosted on the instance exceeds the disk I/O performance capacity of the instance.

References

For information about how to resolve the high I/O load issue on Linux instances, see What do I do if the disk I/O load is high on a Linux instance?