This topic describes how to troubleshoot and resolve the issue where an ECS instance remains in the Stopping state when you stop or restart it in the ECS console.
Background information
When you stop or restart an ECS instance in the console, the operating system inside the instance must release resources such as processes, CPU, and memory. The hypervisor must also release related resources. The time required for this operation depends on factors such as the number of services running on your instance. For example, when you restart an instance, it first enters the Stopping state, then the Starting state, and finally the Running state. This process can take up to 20 minutes.
Overview
If an ECS instance remains in the Stopping state for more than 10 to 20 minutes, follow the procedure below to troubleshoot and resolve the issue.
The following section describes common causes and solutions for an instance that is stuck in the Stopping state.
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Causes
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If many service processes are running on the ECS instance, the operating system requires more time to release process-related resources after a shutdown command is issued. This can cause the instance to remain in the Stopping state for an extended period.
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The system becomes unresponsive for unknown reasons during the shutdown process.
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Solutions
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After the shutdown command is executed, the instance begins the shutdown procedure, during which the instance status cannot be changed. Wait for the instance to Restart or Stop before you perform other operations.
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To obtain more information about the instance status, connect to the instance using VNC. You can then use the information on the VNC interface to identify and resolve the issue.
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After the instance Restart, you can analyze the system logs to determine the cause of the issue.
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References
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For more information about how to log on to an instance using VNC, see Connect to an instance using VNC.
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For more information about instance lifecycle states, see Instance lifecycle.
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For more information about instance health status, see Instance health status.
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For more information about how to create a snapshot, see Create a snapshot.
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For more information about how to re-initialize a system disk, see Re-initialize a system disk (reset an operating system).
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For more information about how to roll back a disk using a snapshot, see Roll back a disk using a snapshot.
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For more information about how to log on to a Linux instance using the Secure Shell (SSH) protocol, see Log on to a Linux instance using Workbench.
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For more information about how to troubleshoot a startup failure on a Linux instance caused by an /etc/fstab configuration error, see Troubleshoot a startup failure on a Linux instance caused by an /etc/fstab configuration error.