If residual disk driver entries exist on a Windows Elastic Compute Service (ECS) instance, the instance may be unable to recognize a new disk or the disks attached to the instance may become inaccessible. This topic describes how to check for residual disk driver entries in the registry of the Windows ECS instance in the preceding scenario and how to delete the residual disk driver entries.
Problem description
After you attach a disk to a Windows instance in the ECS console, the instance cannot recognize the disk.
A disk attached to a Windows instance is inaccessible.
Cause
Residual disk driver entries exist in the registry of the Windows instance.
Solution
In the following example, an ECS instance that runs the Windows Server 2019 operating system is used. The operations may vary based on the operating system version.
Connect to the Windows ECS instance.
For more information, see Connection method overview.
Open the Registry Editor window.
In the lower-left corner of the Windows desktop, enter Registry Editor in the search box.
In the panel that appears, click Registry Editor.
The Registry Editor window appears.
Go to the HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318} path and check the UpperFilters parameter for residual entries.
Right-click the UpperFilters parameter and select Modify. In the dialog box that appears, check the Value data value. If only the partmgr field exists, no residual entries exist.
Right-click the UpperFilters parameter and select Modify. In the dialog box that appears, check the Value data value. If other fields exist in addition to the partmgr field, residual entries exist. For example, if the test_filter field exists in the Value data value, a test_filter residual entry exists, as shown in the following figure.
Go to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI path and check whether residual disk driver entries exist in the registry of each disk.
If the registry of a disk does not have the UpperFilters parameter, no residual disk driver entries exist for the disk in the Windows operating system.
If the registry of a disk has the UpperFilters parameter, residual disk driver entries exist for the disk in the Windows operating system.
In this case, the driver of the disk in the Disk drives category of the Windows operating system becomes abnormal and the disk is inaccessible, as shown in the following figure.
Delete residual disk driver entries.
Go to the HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318} path.
Right-click the UpperFilters parameter and select Modify. In the dialog box that appears, delete the fields that correspond to the residual disk driver entries from the Value data value. For example, delete the test_filter field.
WarningMake sure that the drivers that correspond to the fields to be deleted are deleted. If you accidentally delete fields that correspond to drivers that are in use, the drivers become unusable. To check whether the driver that corresponds to the test_filter field is deleted, go to the directory in which drivers are installed, such as the C:\Windows\System32\drivers directory, and check whether the driver exists.
Click OK.
Restart the Windows ECS instance.
For more information, see Restart an instance.
WarningThe restart operation stops the instance for a short period of time and may interrupt services that are running on the instance. We recommend that you restart the instance during off-peak hours.