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:Check for residual disk driver entries in the Windows registry

Last Updated:May 15, 2026

Identify and remove residual disk driver entries in the Windows registry that prevent disk recognition or access.

Problem description

  • A disk attached to a Windows instance in the ECS console is not recognized.

  • A disk attached to a Windows instance is inaccessible.

Cause

Residual disk driver entries exist in the Windows registry.

Solution

Note

The following example uses Windows Server 2019. Steps may vary by OS version.

  1. Connect to the Windows instance.

  2. Open Registry Editor.

    1. Enter Registry Editor in the Windows search box.

    2. Click Registry Editor in the search results.

      Registry Editor opens.Registry Editor

  3. Go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318} and check the UpperFilters parameter.

    • Right-click UpperFilters and select Modify. If Value data contains only partmgr, no residual entries exist.

    • Right-click UpperFilters and select Modify. If Value data contains fields other than partmgr, residual entries exist. For example, a test_filter field in Value data indicates a residual entry:Residual entry in UpperFilters

  4. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI and check each disk for residual driver entries.

    • If a disk has no UpperFilters parameter, no residual driver entries exist for that disk.

    • If a disk has the UpperFilters parameter, residual driver entries exist.

      The disk driver under Disk drives becomes abnormal and the disk is inaccessible:Abnormal disk driver

  5. Delete the residual entries.

    1. Go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318}.

    2. Right-click UpperFilters and select Modify. Delete the residual fields from Value data, such as test_filter.

      Warning

      Only delete fields whose corresponding drivers have been uninstalled. Deleting fields for in-use drivers makes them unusable. To verify, check whether the driver file exists in C:\Windows\System32\drivers, such as test_filter.

      Delete residual driver entry

    3. Click OK.

  6. Restart the instance.

    See Restart an instance.

    Warning

    The restart operation stops the instance for a short period of time and may interrupt services that are running on the instance. We recommend that you restart the instance during off-peak hours.