Identify and remove residual disk driver entries in the Windows registry that prevent disk recognition or access.
Problem description
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A disk attached to a Windows instance in the ECS console is not recognized.
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A disk attached to a Windows instance is inaccessible.
Cause
Residual disk driver entries exist in the Windows registry.
Solution
The following example uses Windows Server 2019. Steps may vary by OS version.
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Connect to the Windows instance.
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Open Registry Editor.
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Enter Registry Editor in the Windows search box.
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Click Registry Editor in the search results.
Registry Editor opens.

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Go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318} and check the UpperFilters parameter.
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Right-click UpperFilters and select Modify. If Value data contains only partmgr, no residual entries exist.
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Right-click UpperFilters and select Modify. If Value data contains fields other than partmgr, residual entries exist. For example, a test_filter field in Value data indicates a residual entry:

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Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI and check each disk for residual driver entries.
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If a disk has no UpperFilters parameter, no residual driver entries exist for that disk.
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If a disk has the UpperFilters parameter, residual driver entries exist.
The disk driver under Disk drives becomes abnormal and the disk is inaccessible:

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Delete the residual entries.
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Go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318}.
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Right-click UpperFilters and select Modify. Delete the residual fields from Value data, such as test_filter.
WarningOnly delete fields whose corresponding drivers have been uninstalled. Deleting fields for in-use drivers makes them unusable. To verify, check whether the driver file exists in C:\Windows\System32\drivers, such as test_filter.

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Click OK.
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Restart the instance.
See Restart an instance.
WarningThe restart operation stops the instance for a short period of time and may interrupt services that are running on the instance. We recommend that you restart the instance during off-peak hours.