Renews a subscription Elastic Compute Service (ECS) instance. You can specify the renewal period or renew the instance to a unified expiration date.
Operation description
Before you use this operation, make sure that you fully understand the billing methods and pricing of Elastic Compute Service (ECS).
Make sure that your account balance or credit limit is sufficient.
Only subscription instances are supported. Invoking this operation for pay-as-you-go instances returns an error.
You must specify either the renewal period parameters (Period and PeriodUnit) or the unified expiration date parameter (ExpectedRenewDay), but not both.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
ecs:RenewInstance |
update |
*Instance
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| ClientToken |
string |
No |
The client token that is used to ensure the idempotence of the request. You can use the client to generate the token, but make sure that the token is unique among different requests. The ClientToken value can contain only ASCII characters and cannot exceed 64 characters in length. For more information, see How to ensure idempotence. |
0c593ea1-3bea-11e9-b96b-88e9fe637760 |
| InstanceId |
string |
Yes |
The ID of the instance that you want to renew. |
i-bp67acfmxazb4p**** |
| Period |
integer |
No |
The renewal period for the subscription instance. If you specify DedicatedHostId, the value of Period cannot exceed the remaining subscription period of the dedicated host. Valid values: If PeriodUnit is set to Month, valid values of Period: 1, 2, 3, 4, 5, 6, 7, 8, 9, and 12. Note
You must specify either the renewal period parameters (Period and PeriodUnit) or the unified expiration date parameter (ExpectedRenewDay), but not both. |
1 |
| PeriodUnit |
string |
No |
The unit of the renewal period. This parameter specifies the unit of Period. Valid values: Month. Default value: Month. |
Month |
| ExpectedRenewDay |
integer |
No |
The day on which to renew the instance to a unified expiration date. Valid values: 1 to 28. To use this parameter, you must first set a unified expiration date for ECS instances. The value of this parameter must match the unified expiration date that you have set. Otherwise, the call fails. Note
You must specify either the renewal period parameters (Period and PeriodUnit) or the unified expiration date parameter (ExpectedRenewDay), but not both. |
5 |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| OrderId |
string |
The order ID. |
1234567890 |
| RequestId |
string |
The request ID. |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3**** |
Examples
Success response
JSON format
{
"OrderId": "1234567890",
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3****"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidInternetChargeType.ValueNotSupported | The specified InternetChargeType is not valid. | The specified InternetChargeType parameter is invalid. |
| 400 | InvalidInstanceType.NotSupported | The specified InstanceType is not Supported. | |
| 400 | InvalidParameter | The specified parameter "InternetMaxBandwidthOut" is not valid. | |
| 400 | InvalidInstanceChargeType.NotFound | The InstanceChargeType does not exist in our records. | The specified instance billing method does not exist. |
| 400 | InvalidRebootTime.Malformed | The specified RebootTime is not valid. | |
| 400 | InvalidRebootTime.ValueNotSupported | The specified RebootTime is out of the permitted range. | The specified restart time is invalid. |
| 400 | IdempotenceParamNotMatch | Request uses a client token in a previous request but is not identical to that request. | This request and the previous request contain the same client token but different other parameters. |
| 400 | InvalidClientToken.ValueNotSupported | The ClientToken provided is invalid. | The specified ClientToken parameter is invalid. |
| 400 | InvalidInstanceType.ValueNotSupported | The specified InstanceType does not exist or beyond the permitted range. | The specified instance type does not exist or you are not authorized to manage instances of this instance type. |
| 400 | InvalidInstanceType.codeUnauthorized | The specified InstanceType is not authorized. | The specified InstanceType parameter is invalid. |
| 400 | InvalidInternetChargeType.InstanceNotSupported | The specified instance which is in vpc is not support the parameter InternetChargeType. | The specified billing method for network usage is not supported by the specified instance of the VPC type. |
| 400 | InvalidPeriod | The specified period is not valid. | The specified period is invalid. |
| 400 | MissingParamter | The specified parameter "Period" is not null. | The Period parameter cannot be empty. |
| 400 | Upgrade.NotSupported | Upgrade operation is not supported. | The upgrade operation is invalid. |
| 400 | OperationDenied | Specified instance is in VPC. | The instance resides in a VPC. |
| 400 | InvalidInstanceType.ValueUnauthorized | The specified InstanceType is not authorized. | |
| 400 | DependencyViolation.InstanceType | Current instancetype cannot be changed to the specified one. | The current instance type cannot be changed to the specified one. |
| 400 | InvalidPeriodUnit.ValueNotSupported | The specified parameter PeriodUnit is not valid. | The specified PeriodUnit parameter is invalid. |
| 400 | InvalidDedicatedHostId.NotFound | The specified DedicatedHostId does not exist. | The specified dedicated host does not exist. |
| 400 | InvalidDedicatedHostStatus.NotSupport | Operation denied due to dedicated host status. | The current status of the dedicated host does not support this operation. |
| 400 | IncorrectDedicatedHostStatus | The current status of the resource does not support this operation. | The resource is in a state that does not support the current operation. |
| 400 | InvalidPeriod.ExceededDedicatedHost | Instance expired date can't exceed dedicated host expired date. | |
| 400 | InvalidStatus.Upgrading | The instance is upgrading; please try again later. | The instance is being upgraded. Try again later. |
| 400 | InvalidPeriod.ExceededMaximumExpirationDate | The specified renewal period cannot exceed the maximum expiration date. We recommend you try shortening the renewal period at next attempt. | The specified renewal period exceeds the maximum allowed value. We recommend that you shorten the renewal period at your next attempt. |
| 400 | LastOrderProcessing | The previous order is still processing, please try again later. | The order is being processed. Try again later. |
| 400 | Idempotence.Processing | The previous request is still processing, please try again later. | The request is being processed. Try again later. |
| 400 | InvalidLoanOrderStatus.Uncompleted | Any unpaid order must be cancelled before you try this action again. The scheduled unpaid order is a loan order that cannot be auto cancelled. For more information, visit the loan management center. | |
| 400 | OperationDenied.UnfinishedOrder | The current instance has unfinished refundOrder, this operation is denied. | The instance has an incomplete refund order. Wait and try again later. |
| 400 | InvalidPeriod.NotFound | The specified period and expectedRenewDay cannot both be empty. | |
| 400 | InvalidExpectedRenewDay.StarterPackageNotSupported | The specified starterPackage cannot support renew with expectedRenewDay. | |
| 400 | InvalidParam.ExpectedRenewDay | The specified param ExpectedRenewDay is not valid. | |
| 400 | QuotaExceed.AlignInstance | The maximum number of align operations is exceeded. | |
| 400 | InvalidExpectedRenewDay.Conflict | The specified expectedRenewDay is in conflict with period. | |
| 400 | InvalidExpectedRenewDay.ValueNotSupported | The specified parameter ExpectedRenewDay is not valid. | |
| 400 | OperationDenied.AbnormalInstanceInfo | The current renewable operation is not supported due to abnormal information of the instance, please submit ticket to process. | |
| 400 | NoPermission.Price | The operation requires price permission. Please either apply for permission from your main account, or set the parameter AutoPay as true. | This operation requires price permission. Please apply for permission to your master account, or set the parameter AutoPay to true for automatic payment. |
| 400 | InvalidOperation.ClassicNetworkTypeNotSupported | The classic network instance does not support this operation. | Sorry, the instance you renewed based on the classic network architecture cannot be renewed. You need to migrate to a VPC for normal renewal. |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | ChargeTypeViolation | The operation is not permitted due to charge type of the instance. | |
| 403 | Diskcategory.Mismatch | The disk specified to convert to portable is not allowed due to the disk category does not support. | The specified disk cannot be converted to a removable disk due to disk category constraints. |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | InstanceSpecModification.NotEffective | The specified instance has been reserved for making a spec modification and not taken effective in the current contract period. | The specified instance is retained due to the instance type change. The instance type change cannot take effect during the current contract period. |
| 403 | LastTokenProcessing | The last token request is processing. | |
| 403 | Instance.UnPaidOrder | The specified instance has unpaid order. | |
| 403 | InstanceLockedForSecurity | The specified operation is denied as your instance is locked for security reasons. | The instance to which the disk is attached is locked due to security reasons. |
| 403 | InvalidDisk.NotAllowed | The specified disk is not allowed to be converted to portable. | |
| 403 | InstanceTypeNotSupported | The specified zone does not offer the specified instancetype. | |
| 403 | InvalidChargeType.NotSupported | The chargeType of the instance does not support this operation. | The operation is not supported while the instance is using the current billing method. |
| 403 | OperationDenied.NoStock | The requested resource is sold out in the specified zone, try other types of resources or other regions and zones. | The requested resources are sold out in the specified zone. Try another instance type or zone. |
| 403 | OperationDenied.ImageNotValid | The specified marketplace image is not authorized. Please verify the marketplace image authorization and try again. | |
| 403 | InvalidPeriod.StarterPackage | This instance was created by using a Starter Package plan and can only be renewed monthly, not yearly. | The instance was created in a Starter Package plan and can only be automatically renewed on a monthly basis. |
| 403 | RenewDateNotSupported.StarterPackage | This instance was created by using a Starter Package plan and can only be renewed three days before it expires. | |
| 403 | PrePaidInstance.Expired | The prePaid instance has expired. | The subscription instance has expired. |
| 404 | InvalidDiskId.NotFound | The specified disk does not exist. | The specified disk does not exist. Check whether the disk ID is correct. |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | The specified instanceId is invalid. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.