Modifies the information of a managed instance.
Operation description
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
ecs:ModifyManagedInstance |
update |
*Instance
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| RegionId |
string |
Yes |
The region ID. Supported regions: China (Qingdao), China (Beijing), China (Zhangjiakou), China (Hohhot), China (Ulanqab), China (Hangzhou), China (Shanghai), China (Shenzhen), China (Heyuan), China (Guangzhou), China (Chengdu), China (Hong Kong), Singapore, Japan (Tokyo), US (Silicon Valley), and US (Virginia). You can call the DescribeRegions operation to query the most recent region list. |
cn-hangzhou |
| RegionId |
string |
Yes |
The region ID. Supported regions: China (Qingdao), China (Beijing), China (Zhangjiakou), China (Hohhot), China (Ulanqab), China (Hangzhou), China (Shanghai), China (Shenzhen), China (Heyuan), China (Guangzhou), China (Chengdu), China (Hong Kong), Singapore, Japan (Tokyo), US (Silicon Valley), and US (Virginia). You can call the DescribeRegions operation to query the most recent region list. |
cn-hangzhou |
| InstanceId |
string |
Yes |
The new name of the managed instance. The name must be 1 to 128 characters in length. It must start with a letter and cannot start with a special character or a digit. It can contain letters, digits, periods (.), underscores (_), hyphens (-), and colons (:) and cannot start with |
mi-hz01nmcf**** |
| InstanceName |
string |
Yes |
The new name of the managed instance. The name must be 2 to 128 characters in length. The name must start with a letter and cannot start with a special character or a digit. The name can contain letters, digits, periods (.), underscores (_), hyphens (-), and colons (:) and cannot start with |
testInstanceName |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
Details of the managed instance. |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E |
| Instance |
object |
The name of the managed instance. |
|
| InstanceName |
string |
The ID of the managed instance. |
testInstanceName |
| InstanceId |
string |
The managed instance ID. |
mi-hz01nmcf**** |
Examples
Success response
JSON format
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E",
"Instance": {
"InstanceName": "testInstanceName",
"InstanceId": "mi-hz01nmcf****"
}
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | RegionId.ApiNotSupported | The api is not supported in this region. | The API operation cannot be called in the specified region. Check whether the specified RegionId parameter is valid. |
| 400 | InstanceName.ExceedLimit | The specified instance name exceed limit. | The length of the managed instance name exceeds the upper limit. |
| 400 | InstanceName.InvalidPattern | The specified instance name pattern invalid. | The managed instance name is invalid. |
| 500 | InternalError.Dispatch | An error occurred when you dispatched the request. | An error occurred while the request is being sent. Try again later. |
| 403 | Operation.Forbidden | The operation is not permitted. | The operation is not supported. |
| 404 | InvalidRegionId.NotFound | The RegionId provided does not exist in our records. | Region information error |
| 404 | InvalidInstance.NotFound | The specified instances id does not exist. | The specified managed instance ID does not exist. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.